Previous 1 2 3 4 5 6 Next 87 Replies Latest reply: Sep 26, 2014 1:14 AM by shadow Go to original post
  • jodiks Level 1 (0 points)


    At least now I know why I couldn't get the command to work. ;-/

    Although executing this command and relaunching the Finder apparently worked for others, I had to repair Disk Permissions, as mentioned above by TOAO, to fix it on my iMac with OS10.8.2


    I used MainMenu to rebuild LaunchServices, relaunch the Finder, and then Repair Disk Permissions.

    Finally the duplicates are gone.

  • martymankins Level 1 (15 points)

    Such is the case for me.  I have a late 2008 MBP with an SSD as my main drive and a 500gb hdd that sits in the spot my DVD Superdrive used to be in.  Both have bootable OS's (the SSD has ML, the 500gb has Lion).


    Most of my duplicate entries are caused by having different versions of Safari, Firefox, Preview, etc...  So running the Terminal command works, but some of the duplicated entries come back.


    I've resolved Firefox by keeping both installs updated, but it's going to be a way of life running that Terminal command every so often.

  • TOAO Level 1 (0 points)

    Sad but true.

    I use a Mac Pro and made this discovery as well so it is truly a software "irritation".

    The sad part is that those who use single hard drives with partitions have no other recourse I am aware of.


    Fortunately, we Mac Pro users who do not use hard disk partitions can simply remove the hard drive with alternate operating system with total ease in the space of a minute without one single tool.


    The "irritation" only occurs when an external backup clone is produced or updated.

    I suggest running Repair Disk Permissions after each backup WITH THE BACKUP REMOVED.

    (a restart first can also help)


    Since I have been using this procedure, my duplicates have not returned in Mountain Lion.


    (I cannot comment outside my experience, my experience is a Mountain Lion / Snow Leopard setup on Mac Pro where Snow Leopard was an absolute requirement due to Mountain Lion and Lion incompatibility from more than one CAD and Scientific software vendor up to and including one vendor who no longer produces a Mac version and requires Rosetta to run on Intel.... in simple words I was forced to maintain two operating systems.... if you don't require two operating systems, then why have more than one installed internally?)


    Now for sidenotes:

    We users have the right to be irritated since this problem did not persist in previous operating system versions.

  • TOAO Level 1 (0 points)



    Since it is most wise to make backup clones of our operating systems AND files (something Time Machine does not do) us wise people make backup clones.

    This created the "duplicate open with problem", WHY????


    The answer is Mountain Lion's self protection (anti malware) process.

    To make a clone of the entire system, certain Disk Permissions must be temporarily modified by the cloning software. (these permissions allow or prevent the computer from running applications from "other" operating systems.... your clone IS an "other" operating system and is not detected as malware)


    These Disk Permissions are not typically restored post cloning. (that is the WHY)


    The solution is Very Simple and does not require fiddling with the operating system via Terminal, a dangerous tactic at best.


    I experimented and experimented and discovered that I can remove the "open with duplicates" problem effortlessly.

    The answer was to simply open Disk Utility AFTER THE CLONE IS EJECTED AND DISMOUNTED and run Repair Disk Permissions after each cloning process.

    Here's the kicker....

    The incorrect Disk Permissions are still in Ram after Disk Permissions Repair.

    You must eject the clone drive and make certain it will not remount ..... THEN.... RESTART after you run Repair Disk permissions with Disk Utility.


    I have used this process numerous times both cloning TO a hard drive and restoring FROM a clone and I have had zero problems with "open with duplicates".



    Run Repair Disk Permissions after each cloning backup once the clone is ejected and dismounted then restart.



    This message is relevant to Mac Pro mid 2012, I cannot assume or presume or confirm or state that it works with ALL Mac models. (but it should)

    I have not tested this fix on conditions where the backup clone is a partition or is remounted on each restart.


    (backups made to partitions on system hard drives is mindlessly ignorant and technically incompetent since a failed hard drive IS a failed hard drive.... makes one wonder why there is a Restore Drive on ANY operating system hard drive,.... the restore drive cannot be accessed on a failed hard drive)

  • patorv Level 1 (0 points)

    Thanks for the WHY!


    I do have a  clone as a partition that connects each day. And based on my experience (and specific MacBook Pro) I find that the problem returns every time I MOUNT the disk clone to my macBook. It does not take a "new" clone to recreate the duplicate entries for me. Repairing disks permissions has always solved it, but it is annoying to have to repair so often - so until I find the time to put my clone on a separate disk - I put up with it.


    I appreciate your diligence in figuring this out.

  • bamajr Level 1 (0 points)

    I have a MacBook Pro, 17-inch, (Late 2011), running OS X 10.8.2 (12C60).


    Hardware Overview:


      Model Name:          MacBook Pro

      Model Identifier:          MacBookPro8,3

      Processor Name:          Intel Core i7

      Processor Speed:          2.4 GHz

      Number of Processors:          1

      Total Number of Cores:          4

      L2 Cache (per Core):          256 KB

      L3 Cache:          6 MB

      Memory:          16 GB

      Boot ROM Version:          MBP81.0047.B27

      SMC Version (system):          1.70f5

      Serial Number (system):          C0*******V11

      Hardware UUID:          5D0EDB2F-47D7-5E57-9F4A-9952FAB1A3F9

      Sudden Motion Sensor:

      State:          Enabled


    This "Open With" duplicate entries is a major annoyance for me. I cannot seem to identify, why it occurs, but I can say, it doesn't have anything to do with drive cloning, as I don't have any sort of drive cloning configured.


    I can tell you:


    1. Repairing Disk Permissions does not work.
    2. Running the terminal command:

      /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.fram ework/Support/lsregister -kill -r -domain local -domain system -domain user

      does not work.
    3. Running the terminal command:

      /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

      works, but the problem always comes back.


    I use Time Machine to automaticly backup my files and I do manual file backups to a Western Digital, USB Hard Drive.


    The issue doesn't come back right away. It doesn't come back the first time Time Machine runs after running the terminal command It doesn't come back the first time my Western Digital, USB Hard Drive is used,after running the terminal command.


    ...but it always comes back.


    <Edited By Host>

  • TOAO Level 1 (0 points)

    I did not imply infer or suggest that this was with reference to a "new clone", in fact quite opposite.


    It is a very annoying bug.

    The idea I shared was to simplify the problem solution despite that it always occurs.

    I too must repair disk permissions and restart every time a clone is mounted.

    (I have not tried just restarting after the clone is ejected and dismounted, perhaps I should)


    Fiddling with the operating system via Terminal Commands is NEVER a good idea.


    Thanks for the comment.... since I am brand new to Mountain Lion this took me a while to solve.

    ("solve" meaning no fix but merely an easy solution)

    Terminal Commands DO NOT SOLVE THE PROBLEM.

    Terminal Commands do not make the problem go away any more than repairing disk permissions makes the problem go away. (repairing disk permissions is much much much much!!!!... Safer and Easier)

    The ONLY "FIX" is for Apple to get rid of this bug.

  • TOAO Level 1 (0 points)

    Interesting.... it seems that the Time Machine clone (not really a "clone") introduces the exact same problem.

    I don't use Time Machine but greatly appreciate you sharing that tidbit of information.


    This "problem" was very rare in Leopard but did actually occur.

    In LEOPARD ONLY the solution was to delete the two files in the System Cache and restart.

    In the case of Leopard, the problem went away and did not return.


    Seems that Mountain Lion has different ideas.

    My totally uninformed guess.... this bug is the result of the ability to use applications in the Cloud.

    Cloud demands that the operating system "open with" applications not on the system drive.

  • TOAO Level 1 (0 points)


    This operating system BUG cannot be "fixed" by any means except by an effort from Apple.

    Please keep that in mind. (this problem keeps repeating no matter what is used as a temporary treatment)


    Here is yet another problem associated with this BUG.

    I have been using repair disk permissions and restart with great success and yet.... people such as yourself keep reporting that this method does and does not work.

    I have no reason not to believe this.


    Lo and Behold!!!! this is what I have learned.

    Making a system backup clone causes this problem.

    Making a Time Machine backup causes this problem.

    AND.... believe it or not.... SOME application update installations cause this problem.


    I just experienced a TRIPLICATE "Open With" condition.

    I installed an application (all offline) restarted the computer, then installed the application's first update and restarted the computer, then installed the third application update and restarted the computer.

    Guess what happened????

    I now have Triplicate "Open With" all indicating the exact same application and revision.


    I tried my disk permission repair / restart technique and.... It did NOT work.


    In this case I was FORCED to run a Terminal Command on my Mac Pro mid 2012.



    Place this Terminal Command line in a TextEdit file for handy use when needed.


    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user




    1. Copy the text above.

    2. Quit TextEdit. (if used from a TextEdit file)

    3. select Go from Menu and open Utilities.

    4. launch Terminal.

    5. Paste the copied text into Terminal.

    6. hit Return.

    7. Quit Terminal.

    8. Control + Option click Finder in Dock and select Relaunch Finder.

    9. select LaunchPad from Dock and choose Disk Utility from Other menu or…. select Go from Menu and open Utilities and launch Disk Utility.

    10. select your system hard drive and choose Repair Disk Permissions.

    11. Quit Disk Utility.

    12. Restart computer.




    You may Relaunch this TextEdit file at any time to refer to instructions but Quit TextEdit before executing any procedure.


    This procedure should NOT be used unless repair disk permissions and restart fails.

  • FishandSea Level 1 (0 points)

    I updated Launch Services Database, same problems persisted.


    Then, I used TinkerTool System Release 2 (paid version, not the free version).

    "System Settings > System > Volumes" has  2 options:

    1- It excludes volumes from automatic mounting ( First option)

    2- It prevents volumes to allow execution of programs stored on them.(Second option)

    I do not get duplicates anymore.


    Suppose you have 2 external clones (C1 and C2)

    1) If you boot from iMac: you choose C1 and C2 (in TTS2)

    2) If you boot from C1; you choose C2 and your iMac volume

    3) If you boot from C2; you choose C1 and your iMac volume

    But, I cannot use Disk Utility to repair the volumes (You can verify-repair permissions and only verify disk)

    To Verify Disk, you have to remove the volume you want to repair from fist option in TTS2.

  • TOAO Level 1 (0 points)

    There we have it!


    When a user is forced to utilize third party software to correct the function of an operating system.... facts emerge.


    1. This is an operating system Bug.

    2. This Bug CAN be repaired by Apple.


    What needs to be realized is the condition of "between a rock and a hard place".


    Mountain Lion must be able to launch external applications due to the demands of the network environments that are so common and prevalent. (pretty much everything now has a titanium encased unbreakable kevlar umbilical cord attached to the internet)



    What needs to be incorporated into the ML operating system is a CLEAR external "open with" upon eject or disconnect.

    This reveals the problem.

    If the device or network is attached, the CLEAR "open with" cannot exist.


    Since ML must be able to execute external applications including Install Mountain Lion, then when and how can the "open with" be CLEARED?


    As an effort to make ML as automatic as possible for user convenience, a Bug has been created.




    The "duplicate open with" Bug can be fixed by ALWAYS clearing the "open with" by forcing the user to MANUALLY select any and all external applications and clearing the "open with" after each and every use / Quit. (a secondary .afl file)

    This should all be performed within the operating system and not require any third party software.


    In GUI terms.

    When the user selects "open with".... a secondary menu should appear allowing the selection of external applications as a Manual Option or the disabling of external applications as a Manual Option.






    In the meantime until repair, we know that this Bug is not harmful, its just annoying.

  • ChaseVoid Level 1 (0 points)

    Worked perfectly

  • R C-R Level 6 (17,375 points)

    TOAO wrote:

    1. This is an operating system Bug.

    2. This Bug CAN be repaired by Apple.

    Late to the discussion, but a couple of thoughts some might find interesting:


    • This may not be a bug in the OS per se. One possibility is that the bug is in the cloning software. For instance, that software may not be 100% compatible with ML in some obscure way. A test for this might be to compare results using two different cloning apps (& of course, to make sure whatever you use is the fully up-to-date, latest version & known to be compatible with ML.)


    • The OS identifies different volumes by their Universally Unique ID's ("UUID's"). If a clone or some other process produces two volumes with the same UUID, strange things will happen, possibly including duplicate 'open with' entries, because the OS has no way to tell which volume it is reading from or writing to. (Disk Utility can tell you the UUID of each volume via the "Info" button.)


    • Regarding workarounds, all of them involve running executable code of some kind, so this should not be a consideration in which one(s) you choose. If you are not comfortable running Terminal commands, simply don't use that workaround. But if you are, it is by far the fastest, lowest hassle fix. I strongly suggest that you copy & paste the "code" version macjack posted back in August -- the 'code' posting format guarantees everything will be copied as a single line. If you need to use this often, consider saving it as a shell script or maybe as an AppleScript app so you can just double-click it to run it.


    • To suggest anything to Apple, I strongly suggest that you use the appropriate Product Feedback page. ASC is monitored by the hosts & they do try to pass along issues discussed here to Apple Engineering if they seem widespread, but that is not their primary duty & there is no guarantee they will see every topic. Better to use the 'channel' designed for that.

  • TOAO Level 1 (0 points)

    I had considered that this was a cloning software problem as well.

    It took some time, but eventually this was proven false, by comparing the results to alternate cloning programs including Apple's Time Machine.

    Quite surprising actually, since Time Machine is not a true "cloner".

    In fact, it even happens when some applications (non App Store) are updated offline.


    The final experiment was to use the exact same cloning software on the same computer running Snow Leopard.

    The problem IS Mountain Lion specific only.

    Some instances of similar results do occur both in Leopard and Snow Leopard, (rarely) but are self correcting without any need to take any corrective measure.


    The critical difference is that ML MUST be able to launch applications externally, most notably, its own installer.

    The boolean logic to accomplish this mathematically opens the door to this OS Bug.

    The MAJOR change to OS from any Leopard OS to any Lion OS, IS external online installation Only.

    THAT, is where the Bug began. (changes in the form of the Launcher .plist)


    Identical UUID's cannot be created by any means except OS manipulation (malware) or failng hardware.



    So far I have not experienced any operational problems when this "open with duplicates" bug repeatedly appears at all.... it is merely annoying.

    If I was two bit lawyer, I could debate whether or not this annoyance qualifies as an OS bug at all.

    Since it is annoying to MANY Apple customers, it becomes a customer satisfaction issue.

    No matter what.... this can only be fixed by Apple. (there is no other permanent fix)

  • R C-R Level 6 (17,375 points)

    TOAO wrote:

    The final experiment was to use the exact same cloning software on the same computer running Snow Leopard.

    That doesn't completely rule out the possibility that the cloning SW isn't fully compatible with ML.

    Some instances of similar results do occur both in Leopard and Snow Leopard, (rarely) but are self correcting without any need to take any corrective measure.

    Not in my experience. Mostly with Leopard & (IIRC) sometimes with Tiger I had this same problem & it definitely was not self correcting. The only solutions for me that worked were the Terminal or Onyx ones. Repairing permissions had no effect, either.

    The critical difference is that ML MUST be able to launch applications externally, most notably, its own installer.

    I'm not sure what you mean by this. OS X has been able to launch apps from external sources (IOW, from something other than the internal drive) for ages. I also don't understand why you think online OS installation is a factor in this. Can you explain more about this?


    Identical UUID's cannot be created by any means except OS manipulation (malware) or failng hardware.

    Not true. Several block-based copy routines faithfully copy everything, including the UUID. This was a problem with some early cloning softwares that used block copying for speed but did not subsequently call an OS (or other) routine to generate a new UUID & write it to the clone. At one point some even argued this was desirable & done on purpose to create a "true clone," often with the advice that the clone & the original should never be mounted at the same time.

    No matter what.... this can only be fixed by Apple. (there is no other permanent fix)

    Maybe. I can't duplicate any of your results reliably, most notably not at all with Time Machine backups, which work fine for me without creating any duplicate "open withs."


    Something must explain why this happens, & why different users are reporting different symptoms & different success rates with different workarounds, permanent or otherwise. It is easy to jump to the conclusion that a bug in the OS is the cause, but harder to explain how it is one that affects some users one way, others in different ways, & at least some users not at all.


    For instance, from what I can tell for most of us the permissions repair fix didn't help at all, not even temporarily. That it did for you suggests there may be something else involved with your system, but I have no idea what exactly that might be.