Skip navigation

"open with" duplicate entries

41953 Views 86 Replies Latest reply: Oct 7, 2013 1:10 PM by mario.fornieles RSS
1 2 3 ... 6 Previous Next
justin_case Level 1 Level 1 (55 points)
Currently Being Moderated
Aug 29, 2012 11:02 AM

"at times" using "open with" shows many duplicate entries....reboot fixes it for a while..

 

I'm still trying to determine what is triggering this.

 

Any idea? Anyone see this in 10.8? I couldn't find anything searching the forums.

Screen Shot 2012-08-29 at 1.55.14 PM.jpg

Macbook Pro 15 (2.4 Santa Rosa), MacBook 13 (2.0), iMac 17, Mac OS X (10.7), iPhone 3GS v4.3.1, 100% Apple networking (AEs, AXs, TCs)
  • SP Forsythe Level 5 Level 5 (5,200 points)
    Currently Being Moderated
    Aug 29, 2012 11:23 AM (in response to justin_case)

    I am not familiar with all the causes of this phenomenon, but it happens to me from time to time, and I know why it is for me. I work with "clone" images all the time with dev work. When a clone is mounted alongside booting into  the main volume, Launch Services, which keeps track of applications used to open certain file types, "sees" the other application files on the mounted clone volume, and adds them to the database, resulting in the apparent duplication of "open with" entries.

     

    Resetting the 'Open With' menu will remove duplicates and ghost applications (ones you have deleted) from the list. You reset the 'Open With' menu by rebuilding the Launch Services database your Mac maintains. There are multiple ways to rebuild the Launch Services database, including third-party system utilities like Cocktail and Onyx.

     

    If you don't own a system utility that can rebuild the Launch Services database, don't worry; you can perform the rebuild yourself using Terminal.

     

    Using Terminal to Rebuild the Launch Services Database:

     

    Launch Terminal, located at /Applications/ Utilities/.

     

    For OS X 10.5.x and later, enter the following at the Terminal prompt:

     

    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.fram ework/Support/lsregister -kill -r -domain local -domain system -domain user

     

    ----------------

     

    I don't know wjhy it is happening for you, but rebuilding the database will at least reset things to normal. The question to ask is whether you have other mounted volumes, say from other systems on your network, that contain Mac Apps.

     

    I have also found a way to keep it from happening (in certain cases, for my dev work). When I create a clone, I also create what is called a "fstab" file entry, in the fstab file. This entry prevents named drives from auto-mounting. So, if I boot to a clone, my main volume on my internal SSD won't mount. Hence, no extraneous Launch Services database entries will created on the clone drive. If however, I boot to my main SSD, and then mount a clone, I don't use any fstab entries on the main SSD. This just means I have to periodically rebuild the Launch Services database. It is way too much trouble keeping fstab entries for all my clone drives on my main SSD. I only use the fstab method on the clones themselves.

  • SP Forsythe Level 5 Level 5 (5,200 points)
    Currently Being Moderated
    Aug 29, 2012 11:24 AM (in response to justin_case)

    I'll bet a buck that it is those clones that are causing the duplicate entries. You can minimize the problems if you immediately eject those drives, as soon as they are auto-mounted when you physically connect.

  • macjack Level 9 Level 9 (50,445 points)
    Currently Being Moderated
    Aug 29, 2012 11:34 AM (in response to SP Forsythe)

    Apps on other volumes shouldn't cause multiple entries in "Open With" unless they are different versions of the application. i.e. Abode CS4, Adobe CS 5.

     

    Try this syntax for the Terminal command...

    (be sure to copy the entire line it's a scroll)

     

     

           
    Code:
           
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

     

    Then press return. Wait until terminal returns to the command line. Quit Terminal. After that, log out and back in or restart. Let us know

     

     

    Or, use the free utiltiy OnyX to do the same via gui

  • SP Forsythe Level 5 Level 5 (5,200 points)
    Currently Being Moderated
    Aug 29, 2012 11:34 AM (in response to SP Forsythe)

    These two articles may be of interest to you, if you continue to keep those clones around on a physical drive that is mounted on boot.

     

    http://www.tannr.com/2009/09/01/preventing-a-volume-from-automatically-mounting- in-os-x/

     

    http://hints.macworld.com/article.php?story=20060930150059172

     

    Just so you know, fstab files can be more easily made, without error, by using a program called TinkerTool System (not regular TinkerTool). Just be aware that TinkerTool System is somewhat advanced tweaking software, not the harmless version they have for consumers (TinkerTool)

  • SP Forsythe Level 5 Level 5 (5,200 points)
    Currently Being Moderated
    Aug 29, 2012 11:38 AM (in response to macjack)

    macjack wrote:

     

    Apps on other volumes shouldn't cause multiple entries in "Open With" .....

    I wish they wouldn't, but they do. It is a reproducable problem using clone images that I routinely observe.

     

    BTW, did you not notice the post above where I have answered the question in the same manner? (Terminal Solution)

  • macjack Level 9 Level 9 (50,445 points)
    Currently Being Moderated
    Aug 29, 2012 12:02 PM (in response to SP Forsythe)

    I have 3 connected drives with 8 volumes with clones of my system and when I use my "Open With", I have only 1 instance of each. As I said, it shouldn't be an issue.

     

    The reason I added the code is because our syntax differs.

    You should get the Solved for the post, if it works.

  • bamajr Calculating status...
    Currently Being Moderated
    Oct 21, 2012 10:40 AM (in response to justin_case)

    When I run:

     

    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.fram ework/Support/lsregister -kill -r -domain local -domain system -domain user

     

    ...on my MacBook Pro, running OS X - Mountain Lion, I get the following error:

     

    No such file or directory

  • bamajr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2012 6:35 AM (in response to bamajr)

    Is there something different that has to happen, to remove duplicate entries from the "Open With" menu, under OS X, Mountain Lion?

  • macjack Level 9 Level 9 (50,445 points)
    Currently Being Moderated
    Oct 22, 2012 8:39 AM (in response to bamajr)

    Use the code I posted above copy the entire line, that way there are no line breaks. The syntax is important.

  • bamajr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2012 8:58 AM (in response to macjack)

    @macjack -

     

    I did a COPY/PASTE of your code, two or three times now. Each time, I got the same error.

     

    This time, I expanded the window, so that when I did a PASTE of your code, it didn't wrap, in the terminal screen. This time, it worked!

     

    Weird, huh?

  • macjack Level 9 Level 9 (50,445 points)
    Currently Being Moderated
    Oct 22, 2012 9:01 AM (in response to bamajr)

    bamajr wrote:

     

    Weird, huh?

    Yes.

  • bamajr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2012 9:07 AM (in response to macjack)

    Either way, the issue is resolved now!

  • TwoSonic Calculating status...
    Currently Being Moderated
    Nov 21, 2012 6:23 PM (in response to macjack)

    Just relaunch Finder (control+option+click on Finder icon in the Dock) it will work. and dont have to logout or restart.

1 2 3 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.