4 Replies Latest reply: Mar 5, 2014 8:45 AM by King_Penguin
Avi_f Level 1 (0 points)

Can not update my apps

iPad, iOS 4.3.3
  • King_Penguin Level 10 (120,071 points)

    If you getting a 'cannot connect to the iTunes store' message then try logging out of your account on the iPad by tapping on your id in Settings > Store and then log back in and see if it then works.


    If that doesn't solve it then I've also seen suggested going into Settings > General > Date & Time and change the date to a few months in the future and then re-trying.


    If you are getting a different message or problem ... ?

  • RodrigoMonaco Level 1 (0 points)

    Have you tried to sign out of your account, and then sign in again?

    That worked for me.

  • Regina Demetras Level 1 (5 points)

    I am unable to update software.  I get a notice of updates that need to be done.  When I try to log in there's an ID  in the window (it's gray so I can't change it)  Checking my account my ID is correct but I am unable to remove the timblock ID so I can update.  How did this get in the ID window and how can it be removed?


    <Email Edited by Host>

  • King_Penguin Level 10 (120,071 points)

    Do you recognise the id ? All downloads from the iTunes store are tied to the account that downloaded them, and the id that shows an app's update should be the id that 'owns' the id i.e. the one that downloaded it.