10 Replies Latest reply: Nov 17, 2012 8:02 AM by KSantos
TominTexas Level 1 Level 1 (0 points)

Recently I upgraded to Safari 6.0, on my MacBook Pro using 10.7.4. Trouble ever since. Most of the time the back arrow in the upper right-hand corner is grayed out an non-functional. Worse than that, no video will play. It keeps telling me a new version of Adobe Reader is available. I download it, and in a day or two it tells me that all over again. Got o Youtube, e.g., and the screen is bland with the message "Blocked Plug-In." On Google Chrome, videos play fine. Driving me sane!

 

Tom in Texas


MacBook Pro
  • Carolyn Samit Level 10 Level 10 (95,580 points)

    Safari 6 blocks outdated versions of Flash which is required for most YouTube content which is why you are seeing the Blocked plugin dialog.

     

     

    Uninstall the old plugin here > Troubleshoot Flash Player | Mac OS

     

    Then reinstall new here >  http://get.adobe.com/flashplayer/

     

    Then open System Preferences > Flash Player then select the Advanced tab. Click: Delete All

     

    Quit and relaunch Safari and try a video.

     

    If you have the ClickToFlash extension installed, that can prevent Flash based video from streaming. It can also be installed as a plugin in /Library/Internet-Plug-Ins.

     

    And check to see if Safari is running in 32 bit mode. Right or control click the Safari icon in your Applications folder then click Get Info. If the box next to:  Open in 32 bit mode  is selected, deselect, quit then relaunch Safari.

    Most of the time the back arrow in the upper right-hand corner is grayed out an non-functional

     

    From your Safari menu bar click Safari > Reset Safari. Select:  Clear History  (that also empties the cache)

     

    Deselect the other boxes then click Reset.

     

    If that didn't help the back arrow issue, open the Finder. From the Finder menu bar click Go > Go to Folder

     

    Type or copy / paste:   ~/Library/Caches/com.apple.Safari

     

    Click Go then move the Cache.db file from the com.apple.Safari folder to the Trash.

     

    Quit and relaunch Safari to test.

     

     

     


  • TominTexas Level 1 Level 1 (0 points)

    Ok..don't think that worked. I still get the same message.

  • BradenThomas Level 1 Level 1 (0 points)

    What are the contents of the directory /Library/Internet Plug-Ins on your computer?

  • TominTexas Level 1 Level 1 (0 points)

    Here 'tis...

     

    Internet plug-ins.png

  • BradenThomas Level 1 Level 1 (0 points)

    Delete "_Flash Player.plugin" and your problem will go away.

  • TominTexas Level 1 Level 1 (0 points)

    Wow, that turned out fuzzy...like the 7-11 videos they show trying to identify robbers. Let's try it another way...

     

    file://localhost/Library/Internet%20Plug-Ins/_Flash%20Player.plugin/

    file://localhost/Library/Internet%20Plug-Ins/AdobePDFViewer.plugin/

    file://localhost/Library/Internet%20Plug-Ins/CouponPrinter-FireFox.plugin/

    file://localhost/Library/Internet%20Plug-Ins/CouponPrinter-Safari.webplugin/

    file://localhost/Library/Internet%20Plug-Ins/DirectorShockwave.plugin/

    file://localhost/Library/Internet%20Plug-Ins/DivXBrowserPlugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/EPPEX%20Plugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/Flash%20Player.plugin/

    file://localhost/Library/Internet%20Plug-Ins/flashplayer.xpt

    file://localhost/Library/Internet%20Plug-Ins/Flip4Mac%20WMV%20Plugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/GarminGpsControl.plugin/

    file://localhost/Library/Internet%20Plug-Ins/Google%20Earth%20Web%20Plug-in.plug in/

    file://localhost/Library/Internet%20Plug-Ins/iPhotoPhotocast.plugin/

    file://localhost/Library/Internet%20Plug-Ins/JavaAppletPlugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/nsIQTScriptablePlugin.xpt

    file://localhost/Library/Internet%20Plug-Ins/OfficeLiveBrowserPlugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/PandoWebPlugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/Quartz%20Composer.webplugin/

    file://localhost/Library/Internet%20Plug-Ins/QuickTime%20Plugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/RealPlayer%20Plugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/Scorch.plugin/

    file://localhost/Library/Internet%20Plug-Ins/SharePointBrowserPlugin.plugin/

    file://localhost/Library/Internet%20Plug-Ins/SharePointWebKitPlugin.webplugin/

    file://localhost/Library/Internet%20Plug-Ins/Silverlight.plugin/

     

    That's better.  TnT

  • BradenThomas Level 1 Level 1 (0 points)

    No problem.  See above about _Flash Player.

  • TominTexas Level 1 Level 1 (0 points)

    Ok..but not flashplayer.xpt?

  • TominTexas Level 1 Level 1 (0 points)

    Ok...tried it...didn't work. Still blocked.

  • KSantos Level 1 Level 1 (0 points)

    Having the same problem. It's been months and still not fixed!!