5 Replies Latest reply: Aug 30, 2012 2:17 PM by Matt Michaelson
Matt Michaelson Level 1 Level 1 (5 points)

While trying to transfer my iweb-created website to Godaddy suddenly I cannot find the site at all or any pages -- just one pages that says "blank".  Any suggestions?  Did I accidently delete my entire webpage files?  Are they recoverable?  Thnaks.

  • Old Toad Level 10 Level 10 (121,315 points)

    The published pagers that were on MMe are not needed.  Everything iWeb needs is in its Domain.sites2 file that's located in your Users/Home/Library/Application Support/iWeb folder. 

     

    If you're running Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

     

    To open your domain file in Lion or Mt. Lion or to switch between multiple domain files Cyclosaurus has provided us with the following script that you can make into an Applescript application with Script Editor. Open Script Editor, copy and paste the script below into Script Editor's window and save as an application.

    do shell script "/usr/bin/defaults write com.apple.iWeb iWebDefaultsDocumentPath -boolean no"

    delay 1

    tell application "iWeb" to activate

     

    You can download an already compiled version with this link: iWeb Switch Domain.

     

    Just launch the application, find and select the domain file you want to open and it will open with iWeb. It modifies the iWeb preference file each time it's launched so one can switch between domain files.


    WARNING: iWeb Switch Domain will overwrite an existing Domain.sites2 file if you select to create a new domain in the same folder.  So rename your domain files once they've been created to something other than the default name.

     

    Once you get your domain file and get it opened you will need to publish the site to an FTP hosting service. If you're running iWeb 2 you must publish to a folder on your hard drive and upload the site folder and it's external index.html file to the server.  If you're running iWeb 3 you can publish directly from iWeb to the server.

     

    OT

  • Eugene Spriggs1 Level 1 Level 1 (40 points)

    Many thanks as I had the same problem, searched & searched for my Domain file on my own until coming here about 30 minutes ago.

     

    I did the Terminal instructions and I have my Doamin file, making back up copies and off to solve my Web hosting & Web design issues!

     

    Many thanks......Gene

  • Eugene Spriggs1 Level 1 Level 1 (40 points)

    OT - everything worked fine and I can open iWeb 09 with the Domain and my website is all intact. I made a couple of changes to check it out & that worked fine.

     

    One problem, I have iWeb 09 on my MB Air and I'm meeting with Apple folks later for a One to One session to review my Web hosting plans goting forward and want to go over it.

     

    I can not get it to open with the new Domain as it always starts up with a blank slate, asking which templates I want to use. The correct file is there as it is 535 MB in size. I put it into Dropbox as well as I also connected to my iMac from the MB Air, copied the Domaine over to the desktop, double clicked it and same results. Everything I try, I can't seem to get this correct Domain into the MB Air iWeb 09. I'm running the latest version on both systems.

     

    I know it is staring me but seem unable to "crack" the answer!

     

    Thanks / Gene

  • Eugene Spriggs1 Level 1 Level 1 (40 points)

    Please ignore the previous request as problem solved!

     

    We found the problem at the Apple store as it appears that their was another Domain file that was being created that was NOT in the same library (system) and it overrode the correct Domain!

     

    Gene

  • Matt Michaelson Level 1 Level 1 (5 points)

    Thanks all, it doesnt look like my files exist anymore.  I looked in time machine app support and the domain file was the same.  So I think I probably deleted the site files I made and didnt back them up.

     

    iweb switch domain didn't help anything.