Skip navigation

An unknown error has occurred app store

172784 Views 166 Replies Latest reply: Mar 13, 2014 10:44 AM by matt.m.edwards RSS
  • njbc Calculating status...
    Currently Being Moderated
    Sep 10, 2012 12:14 PM (in response to afiszone)

    same problem on macbook air running 10.6.8 and wanting to download Mountain Lion.

  • Dave Simple Calculating status...
    Currently Being Moderated
    Sep 10, 2012 9:03 PM (in response to OlofMork)

    I can't log in to App Store either.  My TuneUp app keeps saying it was downloaded from another computer and needs me to sign in to download from the App Store.  It was downloaded on this machine.  It's the only one I have at the moment.  I rebooted the machine, changed password twice, but nothing works.  I keep getting "An unknown error has occurred" message.  This has been happening for the past couple of days.

  • anonyhosking Calculating status...
    Currently Being Moderated
    Sep 14, 2012 7:22 AM (in response to Dave Simple)

    Same issue for me.  Macbook Pro running 10.8.1.  On my Mac Mini my login from App Store works, but not from my laptop.

  • carnecro Calculating status...
    Currently Being Moderated
    Sep 14, 2012 2:23 PM (in response to OlofMork)

    Same here. In the last couple of days I have seen a lot of discussions in the community forum describing the problem. Neither solution I found worked for me. 

  • wbc795 Calculating status...
    Currently Being Moderated
    Sep 15, 2012 5:17 AM (in response to OlofMork)

    I'm having the same issue on an iMac with 10.7.4. Mac Mini, iPad and iPhone all work fine with App Store. Spoke with tech support. They suggested reloading OS.  I did, but only change was that Safari kept crashing. Reloaded Time Machine backup to get browser working again.  Very frustrating!

  • Kalkas Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 15, 2012 1:43 PM (in response to OlofMork)

    I have the same problem. "An unknown error has occured" when trying to sign in App Store, or update softwares, or buying stuff. I am sure that it registers correct username and passowrd, for otherwise I would get "Your Apple ID or password was entered incorrectly." I have tried all suggestion, removing the whole appstore folder from the Library Cache, but it did not work.

  • Dave Simple Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 15, 2012 2:30 PM (in response to OlofMork)

    My problem turned out to be network related.  I added a wireless airport card to my Mac Pro and disabled the onboard ethernet that was named "en0" (computer not near to a port).  This caused my wireless card to be renamed to "en0".  Why is this a problem?  Apparently, the system checks that the onboard ethernet is working properly before allowing acces to the App Store.  If onboard ethernet is not working, it'll display that cryptic message.  To fix this:

     

    1. Click on Apple menu and choose "System Preferences..."
    2. If the wireless (or some other piece of network hardware other than onboard is name "Ethernet (en0)", delete it.
    3. Make sure the onboard gets renamed to "Ethernet (en0)".  If it was somehow deleted, you'll have to recreate it by clicking on the "+" sign and choosing the onboard port.  This has to be done even if the port isn't connected to anything.
    4. The other port can be recreated afterwards

     

    I know it's a pain.

  • anonyhosking Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 15, 2012 5:23 PM (in response to Dave Simple)

    My problem is clearly not network related.   If I create another user and login as that user then use my account with App Store then I can successfully log in.  Must be something in my own account.

     

    I've tried all the other things like removing ~/Library/Caches/com.apple.appstore/Cache.db and ~/Library/Cookies/com.apple.appstore.plist.  There must nbe another corrupted file somewhere in my account that is causing the problem.

  • carnecro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 15, 2012 5:26 PM (in response to Dave Simple)

    My network interfaces are ok. I tried to track down the App Store login process and discovered, that the following error message is written into my /var/log/system.log

     

    Sep 16 01:52:13 MacBookPro.local App Store[40652]: [IMKInputSession deactivate] exception caught.

                        IMKInputSession:<IMKInputSession: 0x7f83392c0870> --

                        NSInvalidSendPortException : [NSMachPort sendBeforeDate:] destination port invalid

     

    The NSMachPort class is used for distributed object connections on the local machine. Seems the login process has problem with interprocess communication. 

  • anonyhosking Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 15, 2012 5:44 PM (in response to anonyhosking)

    An update.  I get the following errors logged in /var/log/system.log:

     

    Sep 15 20:43:04 chappell com.apple.ShareKitHelper[439]: --warning: [ShareKit-XPC] Received XPC_ERROR_CONNECTION_INVALID

    Sep 15 20:43:04 chappell com.apple.ShareKitHelper[439]: --warning: [ShareKit-XPC] connectionWithClientInterrupted

    Sep 15 20:43:04 chappell com.apple.ShareKitHelper[439]: --warning: [ShareKit] Cancel UI for running services with Client PID: 961

    Sep 15 20:43:04 chappell Dock[310]: LaunchPad: __53-[LPAppManager(StoreSupport) _acceptStoreConnection:]_block_invoke_0 app store xpc message error: Connection invalid

     

    Any ideas?

  • carnecro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 16, 2012 3:21 AM (in response to anonyhosking)

    The problem is definitely associated with my account. I created another account and I can connect AppStore and update my apps.

  • antlibotte Calculating status...
    Currently Being Moderated
    Sep 16, 2012 3:25 AM (in response to anonyhosking)

    100% same problem and errors here: logging in to App Store also succesful from another user account, same tricks tried on Cache ans plists without any success.

     

    Help, please!?

  • jb2683 Calculating status...
    Currently Being Moderated
    Sep 17, 2012 2:40 AM (in response to OlofMork)

    same problem here. I already explained the problem in another thread:

    https://discussions.apple.com/message/19447702#19447702

     

    email discussion with apple support did not help...

     

    hope the problem will be fixed automatically with 10.8.2. as a temporary and inconvenient solution one can use a second user account on the same mac to update or install apps.

  • antlibotte Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 17, 2012 11:50 AM (in response to jb2683)

    I ended up re-creating a new user account and moved all my stuff across to this new account; everything back to normal.

     

    But of course, we can hope someone somewhere will eventually come up with a more user-friendly workaround!

  • carnecro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 17, 2012 11:56 AM (in response to antlibotte)

    That is a workaround, not the solution. Looks like a solution from Windows world.

1 2 3 4 ... 12 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.