Previous 1 2 3 4 5 Next 180 Replies Latest reply: Dec 9, 2015 8:35 PM by mycarehealth Go to original post
  • pdokas Level 1 (0 points)

    I’ve had this problem since 10.8.1 and unfortunately it’s survived into 10.8.2 which was released today.

     

    I’ve tried all the tips suggested in this forum, all to no avail.

  • jb2683 Level 1 (0 points)

    same here. no luck with 10.8.2. very dissapointing...

     

    if anyone has experienced this problem and was able to solve it: please post the solution!

    many people will be very grateful 

  • carnecro Level 1 (0 points)

    Same here. 10.8.2 solved only the problem with Parental Control, there are obviously another reasons for this issue. Workaround is to create another account dedicated for AppStore access. I hope Apple will address this issue as soon as possible.

  • mohd hatta Level 1 (0 points)

    to  resolved the issue

    navigate to Library/Preferences/SystemConfiguration and then delete NetworkInterfaces.plist

     

    then restart ur mac, setting ur network and sign in app store.

  • carnecro Level 1 (0 points)

    This solution is based on the idea, that for AppStore login the main network adapter name must be "en0". And really some people reported succes after rebuilding the interface list.

     

    For me this did not work. Like other solutions circulating in the internet. As system programmer I do not believe that AppStore application has data link layer dependecies, but its worth a try.

  • jb2683 Level 1 (0 points)

    thanks for the suggestion mohd hatta.

     

    i tried this, unfortunately it didn't work for me...

  • unixy_goodness Level 1 (0 points)

    As I just posted elsewhere, I discovered what was preventing me from doing updates/installs from the App Store was a permission problem that occured when I did a SetupAssistant transfer to my brand-new MBP. This permission issue did not get fixed by Disk Utility's "repair permissions."

     

    Opening up the terminal, and doing the following worked for me:

     

    cd ~

    chmod 755 Library/Cookies

     

    It may be desirable to change the permissions on all of the Cookie files, if the permissions on the individual files got messed up somehow. In that case, you would type:

     

    cd ~

    chmod -R 755 Library/Cookies

     

    I don't know if this is the cause of other people's issue, but it solved mine. Good luck!

  • anonyhosking Level 1 (0 points)

    No luck for me.  I know there must be some sort of permissions issue in my Library folder but I have no idea what it could possibly be.

  • seangaffneycc Level 1 (0 points)

    Confirming that mohd hatta's solution has solved the Mac App Store login issue on my wife's MacBook Air. For reference, the solution was to delete the "NetworkInterfaces.plist" file in the "/Library/Preferences/SystemConfiguration" folder. Then restart your Mac so the system can re-create that file for you.

     

    Thanks mohd hatta!

  • afiszone Level 1 (0 points)

    Not work for me .... ,

  • mosslack Level 1 (0 points)

    The network interface problem is known older problem. This is something new and the problem is on Apple's end. IOW it's something they changed which caused this. So far, none of the solutions posted has worked for me.

  • jconstantine Level 1 (5 points)

    I was not able to remove that file, despite the fact I was logged in as an administrator.  I received a "permission denied" message.  ???

  • seangaffneycc Level 1 (0 points)

    jconstantine, if you're in Terminal, you'll need to `cd` into the directory, then run `sudo rm -f NetworkInterfaces.plist`. The `sudo` bit runs the command after it with heightened security privileges (that of an admin). If you're trying to delete the file via Finder, then I'd expect the password prompt to show up.

  • jconstantine Level 1 (5 points)

    Thank you.  I had just figured that out myself.  And deleting the NetworkInterfaces.plist file worked for me as well!  Thank you mohd hatta!

  • willdicki Level 1 (0 points)

    Thanks, This just worked for me!!

Previous 1 2 3 4 5 Next