Previous 1 2 Next 27 Replies Latest reply: Oct 10, 2013 1:13 PM by emmylu83
Shin124 Level 1 (0 points)

Hi,

 

Ive been searching on the net for 2 days in a row hours and hours and decided to place the question here.

 

Since updating to Mountain Lion iMessage doesn't recognize my Apple ID anymore, it was working good on the beta.

When i try to login it says Apple ID and/or Password incorrect. It works fine on the store and iCloud.

 

I've tried changing the DNS to 8.8.8.8, did the keychain tricks with deleting the acounts and resetting, tried booting in Safe mode, tried killing the agent in activity monitor and tried deleting the all the iMessage/Agent/iChat files in the preferences directory. I also re installed the Mountain lion update, no go.

 

I tried everything on every topic i could find.

 

Also iMessage isnt working on my iPhone either anymore, it does send to my phone number but not to my Apple ID email anymore, when i try to login with apple id it says it cannot connect as well.

 

Since it isnt working on my iphone and my macbook, i reckon it has something to do with my Apple ID, but i find it weird that it just happened after the update. Ive been using this ID for 3.5 years withouth problems, it's also verifeid.

 

Anyone help?

 

 

Thanks in advance

 

Etienne.


MacBook Pro, OS X Mountain Lion (10.8.1)
  • Shin124 Level 1 (0 points)

    Oh and Facetime doesn't work either :-/ and i also tried setting the time to automatic as well.

  • Shin124 Level 1 (0 points)

    .

  • Shin124 Level 1 (0 points)

    Ok, typical it works after I ask a question here, but my problem is solved with something that i havent seen on ANY discussion about this, i did the following:

     

     

    (All the above solutions i tried, didnt work)

     

    - Go to the App store,

    - Check your acount,

    - Edit your account,

    - Then apply your edit

     

    (i edited my phone number and re aplied my payment form) i got a mail confirming my changes.

     

    Then i tried loggin in iMessages again and it worked, now it also works on my iPhone.

     

    So after hours and hours of trying and messing with my mac for nothing and allot of frustration, this seemed to be the solution.

     

    I hope it can help anyone else.

  • Jason486 Level 1 (0 points)

    I have the same problem just with Messages and Facetime but what Shin suggests doesn't work for me. I also tried changing my password, doesn't make a difference either. I checked with other applications (iOS, app store, apple id site) and the account works fine there.

  • Shin124 Level 1 (0 points)

    Did you get a conformation email by apple from your edit to your account?

     

    By coincidence my phone number had changed, so i edited that.

     

     

    At the same time i got that conformation email i also had a conformation mail from click&buy that i did buy something from apple, which verifies my acount yet again.

     

    --------

     

    I do have to say, it still doesnt work flawlessly, it logs me in, but kicks me out randomly and i have to re enter my password during messages all the time and just logs me out of imessage all the time, it's frustrating because i have important work messages through imessage.

  • Jason486 Level 1 (0 points)

    Yes, I did get a confirmation email. I changed my phone number too. Messages still doesn't work at all. Hopefully this is fixed soon because I don't see any possible workaround. The problem seems to be server-side, not local. Looking at the number of threads about this problem, it's pretty serious for a major new OS feature.

  • cjsparks27 Level 1 (0 points)

    THIS DID THE TRICK FOR ME!!!!! Thanks!

  • Jason486 Level 1 (0 points)

    I have tried all of the above and other solutions on this forum, and none of it worked. I ended up calling Apple support, here is what they have you try:

     

    -Try logging in to messages on another user account. If succesfull, you know the problem is not in Apple's servers but in your user folder.

     

    -Delete all messages/imessage related files from the /user/library/preferences folder. Then restart. Then try logging in to Messages.

     

    -If not succesfull, delete ALL files from the preferences folder. Then restart. (This is apparantly safe, you could always restore these files.) Then restart. Then try logging in to Messages.

     

    -If not succesfull, you have reached the end of what they can do, because there are no other files related to messages that you can alter. Their solution at this point is a fresh reinstall of Mountain Lion.

  • rand027 Level 1 (5 points)

    I was getting a server error with my appleID. My brother is a computer guy and he solved the problem pretty quickly. In the terminal he found that my copy of adobe creative suite was using the same server to send info about the products trial/license. He got rid of it and imessage and facetime work perfectly. I can post details if anyone thinks they may be in the same boat...

  • Shin124 Level 1 (0 points)

    Please share! Because I am getting kicked out all the time and have to re enter my password (like 10x's in 1 minute) and indeed when my adobe programms are running

     

    Thanks in advance

  • rand027 Level 1 (5 points)

    Here is what my brother said: As it turns out I was doing some port forwarding that was conflicting with iMessage. Following the instructions at http://www.switchingtomac.com/tutorials/how-to-edit-the-hosts-file-in-os-x/ (or a similar how-to) carefully modify your host file, removing anything (you don't need) below fe:80::1%lo0 localhost. After that you should be able to connect using your Apple ID just fine. I hope this helps, I was really scratching my head on this one

  • polanza Level 1 (0 points)

    What is exactly the address I have to remove, because most of the thing I have in the file hosts I need it.

    Thanks

  • Ralph Johns (UK) Level 9 (71,111 points)

    HI,

     

    It should read

    hosts
    Uploaded with Skitch!

     

     


    10:07 PM      Tuesday; October 9, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • a_cat002 Level 1 (0 points)

    Hi Ralph

    I'm having the same issue. On the image you posted in my terminal I have a long list of adobe addresses. THey are using 127.0.0.1 also. I scroll down and eventually see the 255.255.255.255 broadcasthost etc underneath as in your picture. 1) Is this my issue with iMessage not working?

    Thanks

Previous 1 2 Next