Previous 1 2 Next 22 Replies Latest reply: Apr 29, 2014 10:18 AM by QBBettyBoop
ObiJuan2080 Level 1 Level 1

Screen Shot.png

Here's what I've tried so far to fix this:


1. I saw on the boards that someone said that all they had to do was uncheck "Mute" in the Audio MIDI Setup. All Mutes were unchecked. No go there.


2. Restted my SMC...that's didn't work at all.


3. What seems to work is resetting PRAM/NVRAM...that is until the iMac goes to Sleep Mode. Once out, it goes back to what you see in the pic above. Restting PRAM/NVRAM all the time can't be good for the iMac...right?


4. And no there is no red light coming from any of the audio connectors in the back.





What's off the table:


Reinstalling Lion 10.7.4. I can't, no way, don't want to.




Is there any other way to fix this? Any help would be greatly appreciated.


Message was edited by: ObiJuan2080

iMac, Mac OS X (10.7.4), 3.4GHz i7, 16GB RAM, ATI 2GB VRAM
  • rkaufmann87 Level 9 Level 9

    Have you tried turning up the volume and please describe the exact process  you did to reset the PRAM and SMC, please do not skip a step. Also check to see if anything is plugged into the audio connectors in the back.

  • ObiJuan2080 Level 1 Level 1

    "Have you tried turning up the volume..."


    Yes I have and I get what you see in the bottom of the pic.




    "...please describe the exact process  you did to reset the PRAM and SMC..."


    The procress on resetting both PRAM/NVRAM and SMC were no different from these:


    SMC Reset:




    PRAM/NVRAM Reset:


    I followed both of these instructions carefully.



    "...please do not skip a step."


    I assure you, I did not.



    "Also check to see if anything is plugged into the audio connectors in the back."


    Nothing is hooked up to the back of the iMac except my Firewire 800 external HDD and USB External HDD, which I'm assuming has no connection to the audio connectors of the iMac.

  • rkaufmann87 Level 9 Level 9

    There are multiple methods for resetting the SMC based on the  type of Mac you have. Please describe the steps you took for your iMac, they are totally different than those of say a MacBook or MacBook Air.

  • ObiJuan2080 Level 1 Level 1
    1. I Shut down the computer.
    2. I unplugged the computer's power cord.
    3. I waited fifteen seconds.
    4. I then attached the computer's power cord.
    5. I waited another five seconds, then I pressed the power button to turn on the computer.
  • rkaufmann87 Level 9 Level 9

    Try resetting it with all the peripherals unplugged. Leave them unplugged and then retry the sound. If that doesn't work create a new user account (call it TEST ACCOUNT), log into it and see if you have the same issue. If it disappears you know it's a software issue in your normal user account and not global.

  • ObiJuan2080 Level 1 Level 1

    I found a work around to this problem. I went to the Activity Monitor and Quit the "coreaudiod" service. This service restarts on its own almost immediately after quitting of course. I went to my son's 2nd B-Day party so I haven't turned on my iMac yet to see if it's a permanent fix. I'll keep you posted.

  • ObiJuan2080 Level 1 Level 1

    Just turned on my iMac and it looks like this method fixed it. I'll come back tomorrow to see if it's a fluke. So far, it looks like a permanent fix...we'll see.

  • ObiJuan2080 Level 1 Level 1

    No fluke. This method was a permanent fix to this problem. SPREAD THE WORD!

  • leemsutton Level 1 Level 1

    If its any use to anybody I had this exact same issue with no sound. I googled and tried everything suggested to no avail so booked a Genius appointment.

    I then remembered I had been trying to get the Dictation tool to work so I could dictate into the word processor instead of typing. So I went to Dictation and Speech and simply turned off dictation and the sound came back on! I hope it helps some of you.

  • kok kong hong Level 1 Level 1

    me too !!no sound

  • intepid Level 1 Level 1

    I had this problem a while back, but it went away before I could work it out. It happened again today and I now believe it is a transient hardware issue in the headphone jack (possibly related to temperature/humidity/dust). The system seemed to get confused and think it was using digital audio out when it wasn't, and plugging in my headphones in a few times and twisting the jack a little seemed to make it the problem go away.


    Similar description:

  • Dean Huxley Level 1 Level 1

    Thanks ObiJuan2080!!!


    I just ran into the same problem as you.  Nothing plugged into my iMac except power, kbd and mouse and for some reason I had no sound.  Pressing volume up/down keys on the keyboard wouldn't do anything but show the "not permitted" circle with slash through it like the image in your original post.


    I killed coreaudiod and after it restarted (automatically from launchd I presume) the sound was working fine!


    A reboot might have fixed it, but killing coreaudiod was a lot quicker...




  • jehrke7 Level 1 Level 1

    I had this same iMac's sound just mysteriously stopped working.  I went into System Preferences>Sound>Internal Speakers ....checked the mute button and then unchecked it and the sound magically came back....not sure what the deal was but it's working now. 

  • David Ross17 Level 1 Level 1

    I can't find 'coreaudiod' in the activity monitor or indeed anywhere on my Mac (21.5 inch mid 2011, OSX 10.8.2). Never had any sound problems on any revious mac until this one. Shop bought, not refurb. It worls fine with headphones but not without. The only options with the headphones out are: for output, Digital Out Digital-out port for which it says "The selcedt device has no output controls" and for input built in internal microphone and line ine audio line in port. The volume slider can be used but not input level or the mute button (unchecked) which are greyed out.


    With headphones in, output changes automatically to headphones port and there are no other options. On the input tab the volume slider works for both input and output and the mute button can be accessed.


    Nothinng else hooked up and iTunes works okay without headphones


    This is driving me crazy

Previous 1 2 Next