Previous 1 2 3 Next 117 Replies Latest reply: Jun 15, 2014 7:23 AM by BiiTii Branched to a new discussion.
AbbotThomas Level 1 Level 1 (5 points)

Hi,

 

I bought an ATV2 last year and it was very responsive, even though my Internet connection at home isn't great (max of 5Mbps). When the ATV3 came out I upgraded to it and for a while it worked fine. However, over the past few months buffering movies has taken so long (typically two hours until they're even ready to play), I've practically given up on them. I've tried lowering video quality (right down to Standard Definition), but this doesn't seem to make any difference. I've also tried re-starting, reseting and restoring the ATV, and fiddling around with the network settings, but this hasn't made any difference either. Netflix content streams fine and at a good quality, it's just iTunes content that's the problem. Looking online, I can see that lots of other users have been reporting similar issues, with some pointing the finger of blame at the last major ATV software update. This certainly seems to tie in with what I've experienced, since I've not changed any aspect of my network setup recently, but have updated the ATV software. Any ideas/suggestions?

 

Thanks


Apple TV
  • Binary Man Level 1 Level 1 (0 points)

    I'm having the same issue.. I have an apple tv 3 I just bought.  It doesn't matter if I connect it wirelessly through my airport express, or wired directly to the airport express LAN port...    Hulu, youtube, etc. all work fine... Just itunes content.  It doesn't matter if it's via home sharing or standard movies\etc.    a 45min tv show takes 40+ minutes to buffer!!  a 2 hour move?  2+ hours....  My internet is comcast 25mb\s, wireless is Wireless N, and even with ethernet...  this doesn't make any sense...

     

    I've tried restoring the device, resetting the device, changing DNS, wired, wirelessly... Nothing matters...  I just canceled cable and bought all my shows on itunes.. heavily regretting that decision.  I come home from work, sit down to relax, and have to wait an hour before I can watch tv??? 

  • AbbotThomas Level 1 Level 1 (5 points)

    I've now tried a wired Ethernet connection and there's no difference, so that rules out WiFi for me too. I've still got the ATV2, so I'm going to dust that off over the weekend and try it in the same place, with the same movies. I'll let you know how I get on. Anyway, must dash, got a movie to watch that I started downloading two days ago...

  • Sundanz Level 1 Level 1 (0 points)

    Same thing here it's ridiculous.

     

    APPLE ARE LISTENING!!

  • AbbotThomas Level 1 Level 1 (5 points)

    Just finished testing the performance of the ATV3 and ATV2 in my living room. I did this by swapping the units in exactly the same location, on the same WiFi connection, with the same AV connections, and at the same quality setting: 720p HD. I started with a selection of HD movie previews and the ATV2 was consistently faster and more reliable than the ATV3 (e.g. the Hunger Games preview stuttered a couple of times on the ATV3, but played back fine on the ATV2). I then purchased a HD movie on the ATV2 - The Best Exotic Marigold Hotel - and it was ready to play within three minutes. After swapping the boxes, I tried playing the movie on the ATV3: downloading was much slower and I gave up after 10 mins with the progress bar reporting that it would be ready to play in a further 50 mins. I think this pretty much proves that there's a problem with the ATV3 - I wonder if it might always be trying to download in 1080p HD, whatever quality setting you select? I'm going to try and get in touch with the right Apple support people, but for the time being I've disconnected my ATV3 and am back to using my ATV2. Happy days!

  • LuckyLuciano2011 Level 1 Level 1 (0 points)

    Anybody have an update on this.

     

    I'm glad I found this thread since it's exactly the same issue I am having.

     

    When I bought my ATV3 I had no issues, everything worked great.  Then a few months ago I started having this buffering issue.  My ATV3 is physically connected to my network and I have a 100mb\s connection at home.  Everything is very fast at home, except my ATV3.

     

    I've tested my routers, wiring, etc cause I just thought it couldn't be my ATV3.  And you are right Abbot I tried Netflix and it is working fine.

     

    Will there be a fix by Apple to fix these issues?

  • AbbotThomas Level 1 Level 1 (5 points)

    @LuckyLuciano2011 I've hit a bit of a brick wall with this. I took the ATV3 back to the Apple TV store - it worked fine there, but they replaced it anyway. The replacement unit was no better than the original though, still much slower than the ATV2. I was starting to think that either the ATV3 was downloading at a higher bit rate than the ATV2 (despite the quality setting on both being 720p HD), and/or that the ATV3 was more cautious about pre-buffering content. However, if you're getting the same problem on a 100Mbps connection, I don't think that can explain it. Few thoughts:

     

    1) My ATV3 is connected to a Billion 7800n router. What router are you using?

     

    2) I've read some reports that your DNS settings can cause problems. I've tried changing mine and it's made no difference, but you may want to try it out if you haven't already.

     

    3) What quality setting have you selected for your Netflix account? I've left mine on the middle setting, which works fine on my on my 5Mbps connection, but I'd be interested to know what results you get if you crank the quality up to maximum.

     

    4) I'm going to try moving the ATV3 to a different location - at the moment, it's next to the AV amp. I can't believe that this will make any difference, but it's about the only thing I haven't tried yet. If anything miraculous happens, I'll let you know!

  • u.l.b. Level 1 Level 1 (0 points)

    You all are certainly not alone. I, too, have an ATV 3 and have buffering issues when renting movies. Very, very, frustrating. I'm using an Airport Extreme Base Station and get very good transfer speeds when doing anything other than movie rentals. I.e., I can stream a movie that's located on another computer on the network and it buffers extremely fast.

     

    My Airport Express shows that the Apple TV has about 60 Mbps transfer rate and an "excellent" connection. Yet renting movies has recently become unbearable. I wish I could remember when this started, but I want to say that it is in the last couple of months. I've also had some trouble watching videos recorded with my iPhone via Airplay, but it is not nearly as bad as with movie rentals.

     

    Sigh.

  • LuckyLuciano2011 Level 1 Level 1 (0 points)

    Thanks @AbbotThomas and @u.l.b for the responses.  So I was going to try some of the things @AbbotThomas was suggesting. But I first noticed there was an update available from Apple, so I applied the updates.

     

    This latest version appears to have fixed my issues, I was able to watch trailers and previews right away without any wait time.  I hadn't had time yet to switched anything in my setup.

     

    So it used to work, then I applied an update and it stopped work.  Then yesterday I applied a later update and it's all working again.

     

    So for me it was defintely something with the update a few months back...  Check your ATV for newer versions.

     

    Luciano

  • AbbotThomas Level 1 Level 1 (5 points)

    @LuckyLuciano2011 Good to hear you're up and running. I updated to 5.1 last week - I was hoping it would improve things, but it didn't. Anyway, I've now selected Standard Definition on the ATV3, so I'll see how I get on with that over the next couple of weeks. Last time I tried it, it didn't seem to make any difference, but maybe with the update it will. Very frustrating that the ATV2 works fine at 720p HD, but I'm pretty much out of ideas, so I'll be sticking to Netflix content for the time being!

     

    @u.l.b. I guess you've already tried a wired ethernet connection direct to your router, but if not it might be worth trying as a quick test to eliminate WiFi problems.

  • GGfrom florida Level 1 Level 1 (0 points)

    I am in Florida, and  have a comcast business account and get download speeds of 22mbps (as tested).

    The Apple tv is hooked directly into the modem with ethernet.

    We have tried about 6 different routers with apple TV and none of them make the Apple Tv perform without stuttering and buffering.  So we decided to use direct hook up.

     

    I have called Apple repetitively because when trying to watch a trailer/preview, the preview stops and the buffering starts.

    This will also happen when watching movies.

    Lowering TV resolution to 600x480 does not help either.

     

    Apple fail to tell me where their Itunes servers are located, so it's impossible to do a traceroute to see if there's a problem on the way.

     

    Desperate with this situation I opened a DSL account with Centurylink :same problem!!

     

    It seems that Apple should fix their Apple TV product before placing a product on the market that does not perform as stated.

     

    We took this a step further, and purchased a few Apple Tv's which we are setting up with different Internet providers to see what the results are.

     

    You may think I have nothing better to do, but I'm building a case against Apple and shall get to the bottom of this. There are no excuses for placing faulty products on the market.

  • dino2000 Level 1 Level 1 (0 points)

    I have seen this on numerous posts and have the same issue myself -- APPLE, WHERE ARE YOU?  CRICKETS IS ALL I HEAR OUT THERE ON THIS ISSUE.  I am going to dump the Apple TV for my old Roku which worked more reliably and consistently.  The problem here is with Apple movies and only with Apple movies.  If they are going to force us to pay more for their stuff it ought to be faster and better quality!  Been trying to watch 'Lawless' for 90 minutes now and it has been interrupted 5 times for buffering.  Any help from you experts out there would be appreciated. 

  • FlashInPan Level 1 Level 1 (0 points)

    I'm just chiming in to be in the thread in case this ever gets fixed.

     

    My streaming, from my computer (iTunes) has always been fine but since the last update it is so slow there is no point. The movie will start playing, then stop, then buffer for 5 minutes, then play for 5, then stop. You can't watch a movie like that.

     

    This is a movie which I own and is resident on my machine... that USED to play fine before the recent updates.

     

    I've got the world's best WiFI signal in this spot. I've also wired up an ethernet wire there. Same problem. So its not the network. Besides, if I watch a Netflix movie, or rent a streaming movie from Apple, they play fine.

     

    I suspect it has something to do with the iMac and home sharing since it all stems from things located there. Maybe the last iTunes update messed it up? I'm using a new iMac with the latest Mountain Lion and all that.

  • John Wardlaw Level 1 Level 1 (5 points)

    Just purchased the ATV3 today and regret it. Plus the Apple guy at Samys Camera, an authorized apple dealer, said that any video itunes would play, would stream on the apple tv. Not true. Most of my movies that play in itunes still have to be converted to "apple tv version" using the itunes advanced menu I think it was.

     

    I am having buffering issues as well. I have a 1080 video that was only 59 seconds long and it buffered forever, then stopped to rebuffer when it got to 50 seconds.

     

    I have the original 160gb hard drive Apple TV, and I loved it. Since everything was stored on it, no buffering. How am I supposed to shuffle music videos if I have to wait between each one.

     

    WIsh I could take it back for a full refund.

     

    I regret this purchase.

  • dadofjared Level 1 Level 1 (0 points)

    I am in the same boat.  Just got an ATV3 for Christmas and am at a loss to explain the pausing and buffering.  Have tried turning the wifi off on other devices being used (to prevent interference?) and it doesn't make a difference.  My system receives a wifi signal from a source only about 50 feet away.  Our Xbox, upstairs, and over 150 feet away does not suffer the same issue...does anyone have a solution?

Previous 1 2 3 Next