Previous 1 2 Next 20 Replies Latest reply: Oct 10, 2012 6:04 AM by disconnekt
disconnekt Level 2 Level 2 (490 points)

I accidentally formatted an SD card containing AVHDC files that I needed, so I used a data rescue program to rescue the MTS files. Getting them into FCPX has been very trying. I used Smart Converter to "rewrap" the files as .mov, and Quicktime can read both audio and video, but for several of the files, FCPX only imports the audio track. I tried several different conversion programs, and even used a program to create an archive directly from the MTS files, but FCPX is refusing to see the video track on several important clips. Since Quicktime can read the video, I know it's there, but how can I get FCPX to see it? Thanks in advance for any help, I have been ripping my hair out over this one...

  • Tom Wolsky Level 10 Level 10 (110,540 points)

    Open the file in the QuickTime player and report the exact specs of the media. If you have the QT7 Pro player use that and report the track information as well.

  • disconnekt Level 2 Level 2 (490 points)

    Format: H.264, 1,920 x 1,080

    AAC, 48000 Hz, Stereo (L R)

     

    FPS: 23.98

    Data Size: 4.03 GB

    Data Rate: 49.67 Mbit/s

    Current size: 1,627 × 915

     

    Does this help?

    (BTW the specs for this clip are identical for the clips that do have both audio and video in FCPX.)

  • Tom Wolsky Level 10 Level 10 (110,540 points)

    Not really.

     

    (BTW the specs for this clip are identical for the clips that do have both audio and video in FCPX.)

     

    That shouldn't be. The audio should not be AAC put uncompressed when it's imported using the camera import function.

     

    Maybe a screen shot of what appears in the browser, viewer, and info inspector.

  • disconnekt Level 2 Level 2 (490 points)

    I checked out the info window in FCPX and think I found some clues. The no-video clips are reporting as NTSC 1080p with 11.99 fps. The others are plain 1080p with 23.98 fps.

     

    Question is, why is QT able to read the video on these clips correctly and FCP is not? They were NOT shot in NTSC or at 11.99 fps—all the clips were shot on the same day with the same settings. I suppose the data recovery program may have introduced some kind of corruption into the files but, again, QT is reading them fine...

     

    Thanks for your support! I hope I can find a solution.

  • Tom Wolsky Level 10 Level 10 (110,540 points)

    Not a big fan of Smart Converter. Great for some things. Not so much for production purposes. Try using ClipWrap and see if it does a better job. First, it won't leave the AAC compressed.

  • disconnekt Level 2 Level 2 (490 points)

    Thanks, I downloaded Clipwrap and tried a 1 minute sample of an affected clip—same result, no video, just audio. That was with the "rewrap (don't alter video samples)" setting. I suppose I should try another setting, but which is losless and can be seamlessly incorporated into my existing project which is all AVCHD footage?

  • disconnekt Level 2 Level 2 (490 points)

    Bump... anyone have some advice? I'm desperate to save my footage!

  • fox_m Level 5 Level 5 (4,485 points)

    Yeah... Quicktime plays the media? and FCPX thumbnails are black?

     

    Might have to do with Field Dominance Override. If FCPX is being "lied to" then it can show black video -- usually with 1080/60i AVC.

     

    What do I mean? If Smart Converter wrapped it up with a Progressive flag set, then FCPX tries to represent progressive media.  It's NOT! 

     

    Select the clips and go into Inspector > Info > Settings View and set the Field Dominance Override to Upper First which is the proper setting for anything *interlaced* except DV/DVCPro (which should be lower first.)

     

    If this is the problem, you should see your video reappear instantly in the Event Browser thumbnails.

  • disconnekt Level 2 Level 2 (490 points)

    Hi fox_m and thanks for your suggestion. You were right that the clips in question were set to "Lower First", but when I switched it to Upper First, nothing changed. I checked the clips that have both audio and video, and they are showing Progressive, so I tried that too, but no dice. The problem clips are still showing as NTSC and 11.99 fps no matter what I choose for field dominance, which I suspect if causing the video not to be displayed. I have been digging around FCPX trying to find a way to modify these settings, to no avail...

  • fox_m Level 5 Level 5 (4,485 points)

    Ok -- go back into Smart Converter. In Preferences, Advanced, make sure Force Conversion of AVCHD is checked (actually ALL the options in Advanced are checked) and try again.

  • Tom Wolsky Level 10 Level 10 (110,540 points)

    Smart Converter should not be used for this. It's designed for creating files for use on mobile devices not in production. The output options are not suitable for FCP as far as I can see.

  • fox_m Level 5 Level 5 (4,485 points)

    Smart Converter works great - every bit as good as Clipwrap and less cost (for pro - there's a free version too). Just set the conversion to Other > Apple > Quicktime. It does the same as Clipwrap in so far as (when possible) it will simply change the file wrapper and leave the media alone.

  • Tom Wolsky Level 10 Level 10 (110,540 points)

    You don't want it to leave the media alone, especially if it can't set it properly. The Apple>QuickTime rewrap doesn't work as FCP does. It doesn't convert the audio, but passes it through it as AAC, which neither camera import nor ClipWrap do. It also doesn't handle frame rates properly. 29.97 video gets flagged as 59.94, though the files still shows interlacing, which is impossible, so I don't know what the app is doing if it's making 59.94 interlaced.

  • fox_m Level 5 Level 5 (4,485 points)

    The fewer times video is "stepped on" the better so, I do want it to leave the original video alone if at all possible. Audio... don't really care. Most 44.1/128kbps stuff is good enough for me (partial hearing loss...) but, I am meticulous, so all my audio is at least 48kHz 24 bit AIFF for production. FCPX does quite well with AAC, but obviously it should be analyzed and fixed on import... it is not an editing format. *My* camcorder exports AVC/AAC audio. AAC is usually an MPEG-4 Audio format and pretty much the current standard for AVCHD video.

     

    I have never seen SC Pro change the frame rate. However, I do know several consumer grade camcorders actually "lie" about their frame rates. Everything is shot at 59.94 and "interpolated" to the "advertised" optional framerates of 24 or 30 (technically: 23.98 / 29.97 p) if those options are selected by the camcorder user. If the video is 1080 -- it's 60i -- it doesn't matter what framerate you think you set (gotta read the fine print on these cameras!) 720 is actually 60p. SD is 60i interpolated down to (usually) 30i (and some cameras have the option of 30p.) So, Smart Converter must be seeing the original h.264/AVC video in it's native format when passing it through as 59.94 interlaced. That is not a bad thing. However, in FCPX, a 1080 project should be manually set up for 29.97p and have the 1080/60i media conformed to the 30p framerate.

     

    PS - I've actually seen perceptible color changes/loss of dynamic range after using ClipWrap (it was trying to do a transcode...) so, not convinced. Quicktime 7 Pro is the best app to use IF it can open and play the original video. Every conceivable/available export option (depending on system installed codecs) is available, so ProRes + Apple Lossless (AIFF) audio conversion and considerably less trouble to use (and 20 bucks cheaper) than Compressor. Unfortunately, it is no longer included with the OS and part of the FCP toolbox [free "Pro" activation when installing FCP Studio — which is too bad].  The best scenario is having FCPX import/ingest the original video without the use of a extra or third party app. That is, however, not really an option for the OP.

Previous 1 2 Next