4 Replies Latest reply: Jan 4, 2014 7:43 AM by salvo1962
KelBarnes Level 1 Level 1

I have a unique problem with my Verizon iPhone 4S.  I am unable to reliably receive incoming phone calls and text messages.  I can place outgoing calls, I can use data with normal speeds over 3G.  When someone calls me, the phone will go straight to voice mail or will ring a couple times on the caller's end and go straight to voice mail.  On my end, the phone will not ring and does not notify me in any way that there is an incoming call.  If the caller leaves a voice mail, I will get that notification. 

 

I've worked through Verizon's tech support, reset the network settings on my phone, done *228 options 1 and 2, done *73 to make sure that call forwarding is disabled, and Verizon has even gone so far as to send a technician to my area to check the signal quality. 

 

Verizon states that i'm in a "marginal" signal area, but I always get 4-5 bars of signal strength on my phone.  The Verizon tech told me that iPhones perform poorly in poor signal areas. 

 

I should also add, my wife's iPhone 4 works perfectly here.  So does my Android phone and my work Blackberry. 

 

Any thoughts or suggestions? 

 

Thank you.


iPhone 4S, iOS 5.1.1
  • Hny_b Level 1 Level 1

    You wouldn't happen to have Google voice set up on your phone? Just a shot in the dark....

     

    Anyway, this sounds like a problem that may require a phone replacement. How long have you had the  phone? Were I you, I would bring the phone to an apple store right away (make a reservation first).

  • KelBarnes Level 1 Level 1

    Sorry, I forgot to add.. when I first noticed this problem, I took the phone to my local Apple Store and the exchanged the phone for a new unit.  It didn't solve the problem, so I took the new phone back and they restored it at the store to factory settings.  Still didn't solve the problem.

  • KelBarnes Level 1 Level 1

    Sorry, no Google Voice on the phone.  Thank you for the response, though. 

  • salvo1962 Level 1 Level 1

    I had same problem with my 5s and what solved it for me was shutting off "Do Not Disturb"

    Go to settings/do not disturb/then shut off manual mode