Previous 1 2 Next 21 Replies Latest reply: Dec 29, 2014 1:01 PM by thomasfromutrecht Go to original post
  • Shootist007 Level 6 Level 6 (16,645 points)

    What do you mean when you boot to Windows? How are you getting to Windows without using the Option key Boot.

     

    Was it selected from Startup disk in OS X? Or is it just booting to Windows as there is not bootable version of OS X on the drive?

     

    Whether or not the keyboard works once windows loads doesn't mean there isn't some type of problem with it when the system frist starts up. If there wasn't a problem with it, or a Logic board program, then the Option key boot, the command+r key boot and the Reset key commands would work.

     

    From what you've posted None of these keyboard commands work at all.

     

    HOLD DOWN Command+Option+r then press the power button. Continue to hold down those 3 key until you see a Spinning Globe in the center of the screen.

     

    If that does not work to boot the computer from the Internet recovery system (that is if your Mac was made in 2011 or later) then You Have a Keyboard or Logic Board problem. There is NO doubt about it.

  • Richard Dickins Level 1 Level 1 (0 points)

    It always boots to windows instead of booting to Mac OSX as it cannot boot from the OSX partition.

     

    None of the keyboard commands are working whatsoever, I tried holding Cmd + alt + r, it didn't work.

     

    Mac was made in 2011 so I will try the internet recovery system.

     

    Thanks for this you are being incredibly helpful by the way.

  • Richard Dickins Level 1 Level 1 (0 points)

    Ok, I just manage to eject a disk while at the grey screen after the chime so it does at least recognize commands at that stage.

  • Richard Dickins Level 1 Level 1 (0 points)

    Ok, I have determined it is a keyboard problem, I can eject disks through holding mouse click however when I hold eject it does not work.

  • Shootist007 Level 6 Level 6 (16,645 points)

    Was therer a CD/DVD disc in the SD all this time?

     

    If there was give the Command+Option+r key combo another try. By the way THAT IS the way to boot to the Internet recovery system when there is a recovery HD on the internal drive.

     

    EDIT:

     

    And you are Welcome.

  • Richard Dickins Level 1 Level 1 (0 points)

    Not the entire time no, but the DVD is bootable so should show up if I hold alt.

     

    Cmd + alt + R still doesn't work when the disk is out.

  • thomasfromutrecht Level 1 Level 1 (0 points)

    i realise this is an old thread, but for the sake of other people googling this issue: i may have a solution.

     

    reason i ended up in this thread is because there doesnt seem to be anyone experiencing exactly this issue (lots of people have the ' i only see a cursor when i boot with alt pressed'-issue; which is usually related to a failing internal drive (ie: no recognized system at boot, no EFI folder/partition recognized)

     

    This issue is different in that it actually never reaches the EFI boot manager stage.

    This is caused by a 'call' for a drive that is not 'answered' ; in many cases a defective hard drive (doh.) but, to my surprise, can also be caused by an (intermittently) defective Optical Drive.

    Solution in my case: disconnect the optical drive (temporarily) and boot it up with Alt pressed.

    This should bring up the boot manager.

    This tells me the EFI system is waiting for the Optical drive to answer its call; which it never will, since it's defective.

     

    Give it a try (you might have to get dirty and open up the darned thing), i'm pretty confident this should solve your problem as well, seeing all the steps you have already tried. (i went through the exact same disappointment of following up everyone else's logical suggestions, all to no avail..)

     

    Good luck!

Previous 1 2 Next