10 Replies Latest reply: Jun 6, 2013 8:39 AM by Mo40
MGW Level 7 Level 7 (27,020 points)

Whenever I send an email, it appears in my inbox as though I had sent it to myelf.  I have cc and bcc unchecked and can't seem to figure out how to stop this.  View related messages is unchecked.


iMac, OS X Mountain Lion