9 Replies Latest reply: Feb 28, 2015 12:12 PM by Should I say anything ummm....
Serge Dufort1 Level 1 (5 points)


I noticed recently that Safari is not asking anymore to save passwords. It still uses the one I have in Keychain but doesn't see, to care about new one. In Safari  preferences under auto-fill, everything is checked. I tried to trash the preference file, verivy keychain but nothing work.

I use a Macbook pro with 10.7.4 and Safari 6.0

Thanks for your help



  • Linc Davis Level 10 (192,897 points)

    Please read this whole message before doing anything.


    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.


    Step 1


    The purpose of this step is to determine whether the problem is localized to your user account.


    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem(s)?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.


    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.


    Step 2


    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:


    1. Be sure your Mac is shut down.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.


    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    *Note: If FileVault is enabled, or if a firmware password is set, you can’t boot in safe mode.


    Test while in safe mode. Same problem(s)?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • Serge Dufort1 Level 1 (5 points)


    The results of my tests are not positive.

    Step1, same results

    Step2, unable to test because the wifi is not activated on my computer whle in safe mode. Unable to get a hard wire connection to the internet.


    As an update, I notice a few minutes ago that Safari still asks me to save certain password. Don't know if it is related to the web site I visit. For example, I have two gmail accounts, the first account's password is save in keychain ut not the second one. As i visited gmail a few minutes ago, Safari asked me to save the password of the second gmail account. Going to http://www.l-camera-forum.com does not generate the "save password question" and my account on this site is brand new, so I was never asked to save the infos.

    Same with Hotmail, no question .


    thaks again



  • Linc Davis Level 10 (192,897 points)

    Password autofill doesn't work with all sites. Some are constructed to prevent it from working. I don't think anything is wrong with your system.

  • Serge Dufort1 Level 1 (5 points)

    That explain everything now.

    Thank you again.

  • dl80 Level 1 (0 points)

    Hi there,


    I don't this solves everything because the website I am hoping will save my name/password does allow both firefox and chrome to save them. But Safari never asks...

  • virg Level 2 (380 points)

    Like Linc has already stated, my AT&T update for my Yahoo DSL account asks me to sign in each time I pull up the Home page. When I click on the "Keep me signed in" box, it does nothing. It just explains what keeping "signed in" means.


    Also, Safari will not accept my home page as a default when choosen in preferences. Just keeps going to the AT&T page to let me sign in. Very annoying. But have too much data at this site to bother changing. I don't have this problem with FireFox.


    When asked at the AT&T help site, they stated they had problems with Safari and were working on it. That was over a month ago. I think this was planned when AT&T/Yahoo updated their webb site which is when this problem first appeared.



  • Willy W. Level 1 (5 points)

    I am having the same problem.  In all this time, if anyone - Apple or ATT - is working on it, it has not shown any results yet.  Unfortunately.

  • Helga Level 2 (277 points)

    The site I am trying to save the password for is not protected.  I know fellow teachers whose password is saved, but safari won't save mine (or ask).  Is there maybe a preference I should look at?



  • Should I say anything ummm.... Level 1 (0 points)

    Omg don't listen go to Setting Safari passwords and auto fill and slide the tab where it says names and passwords, worked for me!