3 Replies Latest reply: Sep 4, 2012 12:13 AM by HACKINT0SH
LauraBerenice Level 1 Level 1

The AppStore icon had a white "do not enter" type of sign on top and wouldn't open. It said the file/program/app was boken or corrupted. I ran the system updates (none for the Os, but still I tried), and nothing.


So before asking I googled a lot, and someone suggested to take the AppStore icon, take it to the trash, empty trash and then try to download the 10.6 Combo Update directly from the Apple website. I did just that, but since my OS is currently at 10.6.8 it wouldn't let me install that particular update. I googled again and read about downloading the OS 10.6.8 update, that it fixed some AppStore problems and it probably included the AppStore there. Tried that, and again, nothing. Still no AppStore installed.


Long story short, my App Store broke, I erased it and need to download it again. Help?

MacBook Air, Mac OS X (10.6.8)
Reply by Carolyn Samit on Sep 3, 2012 7:51 PM Helpful
Reinstall Snow Leopard v10.6 from your install disc. Then go to your Apple menu and click Software Update from the drop down menu. You need to have at the very least v10.6.6 installed to have access to the App Store > About the Mac App Store

All replies