5 Replies Latest reply: Apr 25, 2014 11:36 PM by AdrianHirst
kingofpants Level 1 Level 1 (0 points)

Hi all,

 

A few weeks ago I started playing with iTunes U Course Manager and found that when referencing an iBook in an assignment, one could choose the chapter that will open when the link is clicked.

 

Today that option isn't there. I'm using Apple's official iOS 5.1 User Guide, and know that the chapter links were working previously.

Screen Shot 2012-09-03 at 11.18.52 PM.png

 

The iTunes U Guidelines (http://www.apple.com/support/itunes-u/docs/iTunesUCourseGuidelines0712.pdf) state:

 

Screen Shot 2012-09-03 at 11.17.40 PM.pngScreen Shot 2012-09-03 at 11.18.23 PM.png

 

Anyone know where my user error is here?

 

Thanks,


iPad 2, iOS 5.1.1
  • 1. Re: Deep linking to iBook chapter gone?
    thedukeinpa Level 1 Level 1 (35 points)

    I don't think this feature works with pdf as htey don't have a table of content to pull chapter informaiton from.

  • 2. Re: Deep linking to iBook chapter gone?
    kingofpants Level 1 Level 1 (0 points)

    Agreed. I'm using an iBook, created by Apple, Inc., and downloaded from the iBookstore.

     

    Thanks for the clarification.

  • 3. Re: Deep linking to iBook chapter gone?
    AdrianHirst Level 1 Level 1 (0 points)

    Hi there,

     

    I have also been having the same issues. When linking an iBook from the iTunes store link, My Materials or from my Mac I am able to link the book, but the 'Link to a Chapter' pop-up does not appear as it should to allow deep-linking.

     

    Believe me, I have tried every possible combination of resources and approaches, all with correctly referenced contents data, but I just can't get the deep linking option to show!

     

    I am currently in email discussion with iTunes U support to try to resolve the issue. We have tried linking identical iBooks in our iTunes U courses and the screenshots from the support team show the 'Link to Chapter' option, yet in my course the option never appears!

     

    I am beginning to think this may be a regional problem, as the support team is in the USA while I am based in Switzerland. He has said that he will pass it on to the engineers to see if they have a solution, so I will keep you updated once I hear more...

     

    Really want to use this feature, as it makes life much easier for my younger students.

  • 4. Re: Deep linking to iBook chapter gone?
    FutureLIFE Level 1 Level 1 (0 points)

    I am also having this issue.  Did you ever get this resolved?

  • 5. Re: Deep linking to iBook chapter gone?
    AdrianHirst Level 1 Level 1 (0 points)

    It seems to be working again for me now... It just fixed itself. As the updates to Course Manager take place behind the scenes and are not necessarily documented at the time they can be difficult to track.

     

    I raised a ticket with support a while back and we went through lots of hoops, including making sure the iBooks in question were from the same store and the country where my Apple ID is registered for iTunes U, but nothing seemed to help so we put it down to a bug in the system. A few months later, with no mentioned big fix, it just started working again.

     

    I mostly use this feature for books I have created in iBooks Author for my students, so that may be a factor - maybe try with a test book you create yourself?