1 Reply Latest reply: Jan 1, 2014 9:11 PM by rps
DebraNB Level 1 Level 1 (0 points)

I am not a very technical person, so this was quite an ordeal for me.  I was very frustrated by the process and almost gave up.  I am glad that I did not

 

I just upgraded to Snow Leopard and after many hours of reading blogs and instructions etc. I finally got my HP LaserJet 2100TN network printer to print in SnowLeopard.   I am running a 24" imac.

 

All of the blogs/support documents tell you that you have to enter the IP address of the printer to set up an IP printer.  To obtain the IP address for the printer, you are told to print a Configuration Page.  But I had no idea how to do that.  So I found a manual online for my printer, learned that if I pressed the Job Cancel and the Go button at the same time that I would print a configuration page.  And it did !!!!  It was listed under Printer Informations as HP JetSend Address: ip: 192.xx.x.xx. (I left out my IP address as yours will be different.)  I then used the Network application located under Utilities, went to PING, entered the IP address and I pinged the printer.  The ping was successful.  Then I used the instructions provided at the link below  to add the IP printer.  Here is the info for the add printer info: http://support.apple.com/kb/HT4507.

 

Here is the link for the LaserJet 2100 manual.

http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/bpl06466/bpl06466 .pdf

 

Good luck.


iMac, Mac OS X (10.6.3)
  • 1. Re: HP Laserjet 2100TN - how to add IP printer in Snow Leopard
    rps Level 1 Level 1 (0 points)

    Many, many thanks. This worked for me.

     

    My HP 2100TN is connected to a router and pinging the JetDirect ip address didn't work at first. After many tries and variations under "Print & Scan" sys prefs, the ping did work with the JetDirect ip address and I finished connecting by following your helpful instructions and links.

     

    The HP 2100TN now prints from OSX 10.8.5 on a "late 2012" 27-inch iMac. The HP 2100TN printer drivers were copied to the sys printer folder from a previous computer running OSX 10.5.8 and which always printed sucessfully through this same router to the 2100TN and still does.

     

    An even worse problem was trying to log into Apple Support Communities with the "username" endless runaround. I finally got to a "Find my Apple ID" link and discovered I had an old Apple ID which I didn't know still existed. I changed the password on that ID and then logged into ASC using the old ID. The login took me straight into the forum and displayed my old and long-forgotten ASC username for that ID. Why that worked, who knows?