Previous 1 2 Next 27 Replies Latest reply: Jan 21, 2014 12:01 PM by Dreyfuzz Go to original post
  • dakasner Level 1 Level 1 (0 points)

    I have the same issue. After updating a lab to Mountain Lion, ARD Screen Sharing won't work with more than 1 computer at a time. Sharing with multiple computers causes the client computers to display a black screen, on the Admin station everything looks like its working...no crashing or shutting down here. Screen Sharing with 1 computer works fine. I'll try expermenting with downgrading the admin software.

  • jkking2000 Level 1 Level 1 (0 points)

    I'm having the exact same problem.  I thought I found a workaround but that didn't hold up long.  I found that if I log onto each computer one at a time then I could share my screen with the lab computers.  That worked once then never again.  Working for a large school system I'm hearing other schools having the same problem.  I've been searching for an answer since October 2012. 

  • Pizzy Level 1 Level 1 (0 points)

    Hi everyone!

     

    The workaround I proposed above for Lion still seems to work, however, everyone after is ABSOLUTELY right!  Mountain Lion is still staying black after the initial use.

     

    This is what we've determined so far:  The problem is ARDAgent!!!! (HD/System/Library/CoreServices/RemoteManagement).  Once it is used once, it doesn't let go, making all subsequent screen shares impossible.  This probably only starts failing in conjunction with busy caches, etc. but at this point, we're seeing every time.

     

    WORKAROUNDS for us right now. 
    1) Restart Macs after every screen share!  It works because ARDAgent was forced to restart.
    2) Use ARD to killall ARDAgent - I only got this to work once.
    3) And our most successful method:  System Preferences : Sharing : off-check RemoteManagement option, wait a sec, then re-check it.  ARD will work with screen sharing again.

     

    In short, I believe this problem (even if my workarounds don't work for you), is related to the ARDAgent not letting go or responding properly to the Screen Share task.

     

    What do you think?  It's kinda nuts to have your students all go and OFF-CHECK Remote Management after every screen share, but that currently works for us.

     

     

    If someone can write a script to automatically RESTART ARDAgent after every use, I think we've got ourselves a solid workaround. :-)

     

    Good luck!  (Oh, and PLEASE APPLE - READ THIS!!! HELP US TEACHERS!!!!)

     

    Note: These workarounds have been tested in three Mountain Lion lab environments with ARD.

  • Pizzy Level 1 Level 1 (0 points)

    UPDATE:

     

    Latest workaround  (DONT ASK):

     

    1) ARD is not screen sharing! Only a black screen.
    2) STOP screen sharing.
    3) Select all clients and go to Manage > Open Application.
    4) Launch System Preferences on all clients.
    5) Now go to Interact > Share Screen...  and try it!

     

    And for us anyways... it somehow WORKS!!!!   No off-checking needed.  Does ARDAgent become submissive the moment System Preferences is opened?

     

    UPDATE A FEW MINUTES LATER: 
    1) It appears using ARD to Open any Application (not just System Preferences) may cause screen sharing to work again if going to black.  I assume that means it is simply refreshing ARDAgent to take in another command, releasing ScreenSharing to work again.

     

    2) We also saw that Repairing Disk Permissions seemed to have a lasting effect on Screen Sharing staying stable in conjunction with the above.

     

    MAN - this shouldn't be this hard.

  • Henry Rexroad Level 1 Level 1 (80 points)

    i got burned by this in the 3.6.1 update last fall. made the mistake of doing it while i was REALLY remote too... lost access to my server until I could get remote hands on the machine. managed to downgrade back to 3.5 and all was well and right in the world again.

     

    yesterday I was doing some work on the server and saw there was a 3.6.2 update. went ahead and installed it. BIG MISTAKE! same problem happens all over again. Thankfully this time I was in the same building as the server so I was only locked out for about 20 minutes.

     

    Unbelievable a bug like this has been kicking around for six months with no fix. Are the Apple engineers even testing their code before they release it? This seems like a pretty significant problem for a fair number of people.

  • dknchin Level 1 Level 1 (10 points)

    I found out a quick fix that worked for me. I just connected to the Mac I want to control via Curtain Mode. The display worked. Without Curtain Mode, the display was black.

     

    Donald

  • knotquiteawake Level 1 Level 1 (0 points)

    We are having the same issue in our school district as well.  The Mac Lab Teachers are getting really agitated about it.  Has anyone found any better solutions?  We've tried all the workarounds listed above (other than rolling versions back). 

    Apple has something seriously broken here and we really don't want to pay $6000 for a 1 year enterprise support contract with Apple.

     

    Also, we have one lab that is using 10.7 still and ARD 3.6.2 and they are working fine!  Only the labs that were upgraded to 10.8 are having the issue with ARD 3.6.2.

  • Pizzy Level 1 Level 1 (0 points)

    Hi knotquiteawake,

     

    Sadly, to this day, it's still an issue. The ONLY workaround that has truly worked over and over again lab to lab running Lion (10.7) is replacing the ADMIN file with a Remote Desktop 3.5.x app, and then updating the client and admin through Apple's support page (posted earlier). I personally had to do it again just a month ago because one of our schools accidentally updated the teacher's workstation. 

     

    You're right, though - all of our new labs work just fine now with the Remote Desktop updates.  It's any lab that was updated that sees its issues.  Have you made sure you're not screen sharing to any LOGGED OUT computers?  They all have to be logged in for best results.  So many other things we've messed with, but the one stable "fix" for older macs being upgraded is the first one we posted here. 

     

    Hope this helps!

  • knotquiteawake Level 1 Level 1 (0 points)

    Thanks for the information.

     

    I've got a good lead on a workaround that doesn't involve using the ARD at all.

    So far in small scale its worked perfectly.

    Here is what I'm trying to setup (hopefully it doesn't confuse the teacher or student too much):

    1. Install Vine Server 4.01 on the teacher's computer.

    2. Setup Vine Server to allow multiple connections, and disable Keyboard, Mouse, and Clipboard input from incoming connections.

    3. Turn on the Vine Server.

    4. Create a desktop shortcut to use Apples VNC Client with the IP address of the Teacher's computer.

    5. When student's click on this they will connect to the teacher's screen but not be able to control, only observe.

    6. Teacher can disable the Student's access simply by turning the Vine Server back off.

     

    So far in small scale with 5 computers its worked well (Better than ARD at least!).  Not sure how its going to do with a class of 27 computers.  We DO have gigabit ethernet.

  • knotquiteawake Level 1 Level 1 (0 points)

    Has anyone checked out ARD 3.7 yet?  Just wondering if anyone has updated all their clients and admin with this ARD 3.7 update?  Did it help at all?

  • Dave Essel Level 1 Level 1 (0 points)

    Yes, I  have upgraded to osx10.9  running ARD 3.7 from 10.8.5 and whereas I had no problems before (strange, given the existence of this discussion), I am now experiencing what is described above and looking for a solution, which is why I find myself here.

  • Dreyfuzz Level 1 Level 1 (5 points)

    I had a lot of trouble downgrading ARD using Pizzy's method. After throwing out Remote Management, I got errors during the install like "Client version is newer than Admin version." Then I tried throwing out various plists associated with the client and got "Cannot find Remote Deskotp on this computer." What eventually worked was forcing the package to run from the terminal:

     

    1. Download the installer package from http://support.apple.com/kb/dl1424
    2. Open the dmg
    3. In terminal, enter sudo installer -pkg <remote desktop package path> -target /
    4. Enter your admin password to run the installer

     

    Note, this method wiped all my ARD preferences, lists, commands, etc. You can get the package path by dragging the package icon (the yellow box) into the terminal window.

  • Dreyfuzz Level 1 Level 1 (5 points)

    Update: I was on Mountain Lion when I posted previously. Can't do this any longer in Mavericks. ARD 3.5.1 is no longer supported.

Previous 1 2 Next