Previous 1 5 6 7 8 9 Next 126 Replies Latest reply: Sep 9, 2013 5:55 AM by Giles Go to original post
  • brianfromwaverly Level 1 (0 points)

    I am having the same symptoms described by most people on this thread. I can use Mail after my MBPr wakes, but I have to wait about two minutes every time it wakes up.  The beachball spins for that long and the program will not respond (resarting Mail does fix the problem, but that's a work arournd, not a solution).

    I have read all the way through the thread, and I have to say I find it daunting.  I know a lot more than most users, but I am not a networking specialist, and I get lost sometimes in the lingo.

    I work for a college, and I have the problem both at home and at work.  The machine behaves in an identical manner in both places.  My DNS seetings under "Network/Advanced/DNS" have my router's IP address--, but it is greyed out, so I cannot modify it. My router DNS pulldown menu (using Tomatoe firmware 1.28 on an ASUS router) is set to "Use WAN IP Address173.31.182.38 (recommended)."  This, I assume, means that my ASUS router is controlling the DNS and is using the address. My level of expertise is not high when it comes to networking, so I would appreciate some addvice abou how to try a different (hopefully better) DNS server, as softwater and robolz have been suggesting.  Where and how do I enter the address for a different DNS server?  Will doing this affect how things work both at home and at my work setting (a college network, about which I know little)?

    Tnx. BJ

  • scott321 Level 1 (15 points)

    Hi Brian, I'm no expert, but I think it's weird that you can't modify your DNS settings and that they are grayed out. Can you highlight and then delete them using the minus sign? Then add with the plus sign? What OS are you using?


    Either way, you should probably create a new Network Location. Network>Location drop down>Edit Locations> Plus sign.


    Then enter new DNS settings in the new location. You can always revert to your old Network location.


    I think one of the guys solved this by changing his DNS from the his router's IP address to external DNS such as these two pairs, which were recommended to me my Apple Tech support:






    Also, I never got the colored beach ball when I had this problem. Good luck.


  • scott321 Level 1 (15 points)

    Hugo, sounds like you have an issue unrelated to the Port Failure. Anyway, why not schedule your Mac to wake from sleep ten minutes before you get to work in Prefs> Energy Saver> Schedule. Wouldn't that load all your emails?

  • brianfromwaverly Level 1 (0 points)

    Thanks for the reply scott321.  I did not realize the greyed out number did not mean it was locked.  I was able to add a different DNS number.  I tried waking from sleep a couple of times, and it worked fine.  Mail came up working right away; I did not have to wait two minutes before I could use Mail.  I see that many have had the experience of trying something, thinking it worked, and then the problem reappeared.  So I will post again in a few days to document whether my problem was permanently fixed.

    I am running 10.8.2 on my MBPr that I got in August.  Fast machine!--as long as the software doesn't hang.

    Here's a bit more about the machine, just in case it matters:

    Model Name:          MacBook Pro

      Model Identifier:          MacBookPro10,1

      Processor Name:          Intel Core i7

      Processor Speed:          2.3 GHz

      Number of Processors:          1

      Total Number of Cores:          4

      L2 Cache (per Core):          256 KB

      L3 Cache:          6 MB

      Memory:          8 GB

      Boot ROM Version:          MBP101.00EE.B02

      SMC Version (system):          2.3f32

  • MyndSurfers Level 1 (0 points)

    That did not work for me.

  • MyndSurfers Level 1 (0 points)

    I believe I installed the 10.8.2 supplemental update. However, problem of Mail not restarting after sleep persists.


    OS X 10.8.2 (12C60)

  • brianfromwaverly Level 1 (0 points)

    I have learned by hard experience that I cannot change my DNS at my work location.  If I do, I loose all connection to the campus network.  Changing the DNS server settings at home did not change my problem in any case.  When I have time, I plan to move back to Outlook.  I had been using Outlook before I tried Mail, and I was okay with it.  I just like to use Mac native programs.  But between this issue with Mail connecting again after sleep and a feature issue (I cannot import a comma delimited list of email addresses into Contacts, a feature I need since I have 75 different students every term that I need to temporarily place in one email list), I feel I need to move back.  Frankly, it make me sad.  I really wanted Mail to work.  Thanks to all those who have been posting advice; the discussion boards have saved my bacon repeatedly.

  • ach1 Level 1 (0 points)

    I just upgraded from Snow Leopard MPB and its Apple Mail to Mountain Lion rMBP and its Apple Mail.  I used the migration utility to move my account from the old computer to the new computer.


    And, like so many of you, I now find my email connections dropping constantly.  Particularly an IMAP account, but also a GMail account.


    Any idea of whether Apple is aware of this problem (and doing their typical stonewalling in the hopes that nobody notices the poor quality of their shipping product) or are they actively denying that such a problem exists?


    Any known workarounds?  I'm on 10.8.2, but the supplemental update won't install, claiming "This software is not supported on your system"




  • scott321 Level 1 (15 points)

    Hi ach1,

    Did you try changing the DNS settings in System Prefs, as described on page 6 of this thread? That worked for me and others.

  • ach1 Level 1 (0 points)


    Thanks for the suggestion (changing DNS servers to Google),


    Changing DNS settings to solve this problem is like finding that driving in reverse solves car problems.  Even if it does solve the problem, DNS settings have many consequences (performance, security, reliability) that make it unreasonable to change them to Google (or any specific value).


    I'll wait until Apple can solve the real problem, keeping in mind that I never had a problem on Snow Leopard and my previous MBP even with my local DNS settings.



  • glennfromspruce head Level 1 (0 points)

    I saw this solution here which has worked for me:



    This might seem weird and unlikely, but these steps (originally written to restore broken Dictation) fixed it for me:

    1. Go to ~/Library/Preferences ( ++G )
    2. Locate and move it to the Trash
    3. Open Dictation & Speech preference panel, disable dictation
    4. Reboot
    5. Re-enable Dictation & Speech.


    I did not re-enable Dictation & Speech

  • softwater Level 5 (5,370 points)

    I'm giving Outlook a try. If its proves stable I'll stick with it. For one thing, the UI is similar to Mail but better in that it has colour icons in the sidebar and the taskbar. √

  • brianfromwaverly Level 1 (0 points)

    I am glad to report that since Apple's most recent system update (which re-flashed the ROM in my rMBP as well as updating the system software, about 3 weeks ago) my problems with Mac Mail have gone away.  I had previously tried a number of things suggested in this thread, but nothing helped, until this most recent update.  I am suspicious that it was the ROM update, rather than a tweak to the system, that resolved the problem, but I have no evidence to support my suspicion.  Anyway, I am a happy user of Mail at last.

  • Giles Level 4 (1,745 points)

    Still not working here after 10.8.3 update....

  • Rakeau2 Level 1 (0 points)

    I recently upgraded a bunch of computers to Macs in an office (one of many). There are 4 brand new iMacs, straight out of the box, 10.8.3 update on a vanilla OS X install, and brand new IMAP accounts on a brand new server.


    All 4 experience the exact same issue. Works fine, computers sleep, wake up, no connection. Restart Mail, works fine. Rinse and repeat.


    I found that I could replicate the error if I disconnected from the network. Didn't matter if it was Ethernet or WiFi - Turn WiFi off, or unplug the cable. Mail, as you'd expect, could no longer connect. Turn WiFi back on, or plug the cable back in, and it would not connect again, preferring to remain offline. I took the problem not as being Sleep itself, but rather, the fact that the iMacs were dropping off, and re-connecting to the network again, when going to sleep.


    Given they had all the same symptoms, I suspected foul play on the network. I could replicate the exact same fault behaviour across all computers. I got an IP, DNS info, so on. Websites would work, it would rejoin an AFP share on a server, everything would come back, all except Mail.


    As a test, I swapped the existing modem+router (Doing PPPoE [DSL], NAT, DHCP, and DNS), to a different modem running in Bridge mode with an Airport Express doing PPPoE, NAT, DHCP, and DNS. Attempted to reproduce the error, nothing. Disconnect, Mail would lose connection. Reconnect - cable or Wifi, Mail would come back to life straight away, no restarting necessary, just as you'd expect it to -- as did file shares, websites, etc.


    Perhaps the only testing I didn't do was using the original modem/router and a Static network config on the affected iMacs rather than relying on DHCP.


    I'm leaving the new makeshift config in place for a few days so they can test it out and report back if it's reliable or not.

Previous 1 5 6 7 8 9 Next