Previous 1 2 3 4 Next 59 Replies Latest reply: Jun 15, 2014 8:27 AM by ajm_from_WA Go to original post
  • drtime3r Level 1 Level 1 (25 points)

    Wow! What a crazy thread this has turned into! Just because of the wallpaper? I know, these little things drive us nuts. Are you still having the problem? Have you updated to OSX 10.8.3 yet?

     

    Good luck, Richard

  • tteo Level 1 Level 1 (0 points)

    Hey people i find a solution, i have this problem in 10.8.3 Retina MBP. I do this:

     

    1. Close all desktop (leaving just main desktop)

    2. Change the wallpaper

    3. Then run "Memory Clean app"

    4. Clean the RAM memory

    5. and then add a new desktop the problem is gone )

  • Jack Oak Level 1 Level 1 (5 points)

    funny thing is that I have this problem on my rMPB with 10.8.3, but when it is hooked up to the thunderbolt display, the wallpapers are working fine. It is just when I am using the laptop screen that the wallpaper defaults to some other random desktop picutre....weird. ive tried all the suggestions and nothing helps.

  • Bear Issues Level 1 Level 1 (0 points)

    Had the same problem with wallppaper running Mtn. Lion.  Followed your "first" advice from 9/6/12  exactly, and when I restarted my iMac 10.8.3 all was perfect again.

     

    Thank you! Thank you! Thank you!

  • GoodguyUK Level 1 Level 1 (0 points)

    Ok, I have just had this problem, it wasnt only the desktop wallpaper it was any changes i made in system prefrences would revert back after i rebooted.


    The way i fixed this was to :


    First unhide the user / library folder by opening terminal and entering this : chflags nohidden ~/Library/
    Locate the / library / prefrences folder, right click and select Get Info (or CMD-I).
    Open the padlock on bottom right of Get Info box so changes can be made. In the sharing & permissions section, change permissions to :


    name (Me) - read & write


    everyone - No Access


    To the right of the + & - (on the bottom left of get info window) there is another selection box, click on it and select 'Apply to enclosed items'
    Now restart, From now any changes will be saved

  • drtime3r Level 1 Level 1 (25 points)

    Hi Goodguy,

    Just to make sure, what version of OS X are you running?

     

    Thanks, Richard

  • GoodguyUK Level 1 Level 1 (0 points)

    Hi,

    Well, yesterday i was running snow leopard, but now i am running mountain lion 10.8.3.

     

    I made a bootable sparce image backup of my snow leopard installation just incase some of the audio plugins i use didnt work in 10.8. Then i just did an upgrade from an up to date 10.6.8 to 10.8.

     

    I have my trackpad setup a particular way, so that was the 1st thing i tried to set up, but everytime i rebooted it would go back to default, then i noticed it was the same with more or less everything in the system prefrences.

     

    I created a new user, just so i could see the default permission settings for a user library folder and its contents, then i did what i described above. And it worked!!

     

    And more to the point, all my favorite au synths and fx work fine with the exception of the BBE sonic maximizer

  • GoodguyUK Level 1 Level 1 (0 points)

    I meant locate the user / library / preferences folder,

    NOT the / library / prefrences folder

  • kaytenlizz Level 1 Level 1 (0 points)

    This worked great!! Thanks!! been trying for days to resolve this issue!!!

  • Gregory Rivers Level 2 Level 2 (450 points)

    had the same problem since turning on automatic login.

     

    goodguyuk's tip worked;

     

    selected ~/Library/Preferences/

    sharing and ownership prefs were correct, but I selected "Apply to enclosed items" for good measure.

    logged out of the account, and logged back in again.

     

    all good :-)

     

    cheers, and thank you.

  • 512banque Level 1 Level 1 (0 points)

    +1, the only solution which worked is the GoodguyUK's one :

    • Go in Finder.
    • Click on "Go to" in the upper bar.
    • Hold "Alt" to show Library and click on it.
    • Right-click on Preferences, select Read Informations, and check for the ownership preferences : user (Me) : read and write, everyone : no access.
    • Click on the lock on the bottom right to unlock it, enter your admin password.
    • Click on the gear then apply to enclosed items.

     

    You can now change your background, logout then login and watch your wallpaper remain

  • DavidPabian Level 1 Level 1 (10 points)

    A couple of earlier posts suggested the culprit might be PathFinder (can't say what the problem might be if you don't have PF, as all has worked fine since finding my solution).

     

    In Pathfinder I deselected Start on boot AND (important) the next two buttons (menu bar and default browser), so PF doesn't reactivate on searches, etc. Make sure the desktop options in Features are all desected and that in the Finder interface all buttons are unchecked.  For good measure relaunch the finder.

     

    Then restart in Safe mode. Once there open Sys Prefs to change the desktop.  Twice with this problem, at this point I found that even though the default desktop was on my screen only a question mark was in the first desktop setting.  I set the one I wanted - the question mark was replaced by the correct image - and rebooted. All is well.

     

    I haven't restarted Pathfinder, but assume that if I did and reverted to my usual settings I would find the same problem occuring with the new desktop.

     

    For those with this problem who don't use Pathfinder, do you have any other Finder enhancement apps?

     

    Hope the above isn't too confusing - but it worked for me.

  • Gregory Rivers Level 2 Level 2 (450 points)

    none.

  • Rahim 123 Level 1 Level 1 (0 points)

    i had changed my background desktop but when i shutdown my macbook pro and switch on . it goes back to the previous one i had even delete the item but it doesn't work .

  • ajm_from_WA Level 1 Level 1 (10 points)

    I had this problem in mavericks.

     

    Deleting

    User/Library/Caches/com.apple.systempreferences

    and

    User/Library/Application Support/desktoppicture.db 

    fixed it for me

Previous 1 2 3 4 Next