1 Reply Latest reply: Sep 6, 2012 8:37 PM by shldr2thewheel
penguinfiasco Level 1 Level 1 (0 points)

Is it compatible to Install OS X Mountain lion with my OS X v10.6.8?

Clearly I have no idea with how Mac software works, so can anyone kindly give me an answer?

Or is snow leopard compatible with my current software?


iMac, Mac OS X (10.6.8)