10 Replies Latest reply: Sep 9, 2012 12:18 PM by dwb
terriergal Level 1 (5 points)

I recently upgraded to ML, but now both Pages and Preview will not open.  When I try to open a file, or open the actual application, they look like they're going to, but then they just bounce in the launch bar for ages and I get the nice little rainbow spinner.


Pages I don't think ever has worked since the upgrade, but Preview stopped right in the middle of using it one day and I had to force quit it.  I had one image open in it, and tried to create a new document from clipboard, which resulted in it hanging forever with the little spinning rainbow ball, and I had to force quit.  Since then it has never opened.  Like Pages, It bounces and bounces and never asks me to restore windows or anything.  Then it stops bouncing and the little indicator remains under the icon in the launch bar indicating it's open, but if I have tried to open an image, there are no windows for it open.  I have tried repairing permissions and restarting without success.

MacBook, OS X Mountain Lion (10.8.1)
  • terriergal Level 1 (5 points)

    Update.  I trashed the plist file for preview, which solved the preview issue.  But I can't seem to find something like that for Pages.

  • terriergal Level 1 (5 points)

    Ah, yes, nothing from Iwork 09 will open.  Is it incompatible with ML?

  • CT Level 6 (17,475 points)

    What version of Pages do you have?


    Preference files for Pages are files starting with com.apple.iWork.Pages.



  • CT Level 6 (17,475 points)

    iWork 09 does work with ML.


    Have you tried software update/App Store to make sure everything is up to date?

  • dwb Level 7 (22,225 points)

    I've seen several cases where the upgrade to ML has done something to iWork that can be resolved by a reinstall of iWorks. (Perhaps something less drastic is possible but the typical deletion of iWork preferences wasn't enough.) In my case (on one computer) I deleted the applications and then reinstalled the programs.

  • terriergal Level 1 (5 points)

    Ok, so I tried manually updating Iwork 09, no joy.  I  uninstalled Iwork 09, reinstalled, and updated before opening, through the AppStore which updated me to 9.0.2 (which I was pretty sure I already had).  Still nothing.  I haven't tried manually updating Iwork 09 since uninstalling.


    When I do get info on the three Iwork 09 apps,


    Keynote is 5.2
    Numbers is 2.2
    Pages is 4.2


    And just FYI, I used AppDelete to get rid of Iwork 09 the first time, removing everything.  There are no more plist files associated with iwork to be found on the computer (removing those happens to have helped others, but not me!).

  • dwb Level 7 (22,225 points)

    Yours is the most recent version. If none of the three programs is working and we know the plists have been deleted then that strongly suggests the problem exists in one of two Application Support folders - either the one in the root level directory Library or in the Library in your drive space. And if none of the three work I'd suspect the root rather than your own. So the next step would be to delete either just the iWork folder in the Application Support folder in the root level Library both of them. (If you have your own created templates be sure to copy them elsewhere before deleting the iWork folder in your own Application Support.

  • terriergal Level 1 (5 points)

    Ok, backtracking a little... because Preview is being stupid again.  :-)  It opens, but I get the same mess happening again every time I try to save an image.  Throwing out the plist file for preview makes it immediately able to open files again. All I have done is crop an image and try to save it or export it.  The export command does not even come up.  The menu highlights as if it is going to but no dialog ever comes up.   Preview at the same time becomes utterly unusuable.  I have to force quit it, throw out the plist, and start again.


    OK I trashed the Iwork '09 folder in application support.  (I still had an Iwork '08 folder in there too and I trashed that.)  Starting from scratch, reinstalling, then updating.  If this doesn't work, then my husband is thinking, since Preview (something awfully integral to the OS) is so messed up that the next step will be backing up everything, wiping the drive and starting the entire OS from scratch.  Sigh.

  • terriergal Level 1 (5 points)

    All right.  So now after a complete reinstall of the OS, I am still in the same boat.  However, my husband created a new user account and both Preview and Iwork '09 (updated before opening) work just fine in those as far as I can tell.  The export dialog pops up right away in Preview and I can get all three Iwork '09 programs to open just fine.


    I would like to know what the issue is, so I can fix it more easily if it crops up again, but if I can just transfer everything to that new account I'm ok with that too.

  • dwb Level 7 (22,225 points)

    There's an iWork forum here and a fellow named Yvan Koenig who has created an AppleScript that deletes all the files that the iWork installer writes. He created it for a different reason but I'll bet it solves your problem now that we know it is your user folder that is causing the problem.