Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.


Question: Solved Mac Mini (late 2010) Blue Screen Hang issue

I posted several questions about blue screen hang and was able to fix my problem, after LOTS of work and searching in various forums.

I had been unable to use my computer for over a month; it was simply hanging at the blue screen, and that seemed to happen when my Finder.app had crashed, hiding all my document icons on my desktop, etc. I also had been having issues with Time Capsule and my backup Iomega disk, which is touchy.

When I tried a fix my icons had returned but I had been unable to use computer after rebooting, and I had tried every sort of key combo including trying to boot from the original install CD, etc., but nothing worked. I could not even reboot using original 10.6 software CDs, and was only able to log in Single User Mode and had tried many fixes with Terminal, and finally, this worked, two of the fixes I used are listed below.

It seems, in part, that resetting certain "privileges" worked.

This tip first tip is for Mac OSX 10.3 to 10.3.9 and even though I am on 10.6.8, I ran it, and it worked. THis is the original link location: http://support.apple.com/kb/TS1411

1. Start up the computer in Single-User Mode.

2. Type: in Terminal the command

mount -uw /

3. Press Return.

4. Type (in Terminal, note space before mv)

mv /Library/Preferences/com.apple.loginwindow.plist preferences2.old

Note space between ".plist" and "preferences".

5. Press Return.

6. Type:

mv /Library/Preferences/com.apple.windowserver.plist preferences3.old

7. Press Return.

8. Type: reboot

9. Press Return.

Then I followed up with this tip to "Reset certain privileges"

1. Start up the computer in Single-User Mode.

2. Check the volume with fsck.

3. Type: mount -uw /

4. Press Return.

5. Type: chmod 1775 /

6. Press Return.

7. Type: reboot

8. Press Return.

When I rebooted, yayyyy! I was able to log back onto my computer, however, all icons were missing, again, so I typed this fix

/System/Library/CoreServices/Finder.app/Contents/MacOS/Finder & disown

I am not sure what 1775 means, but this fix got my computer back up, saving me at least a $150 bill at the Genius Bar.

When I typed those commands into Terminal, this is what returned, and seems to be some QXPscrpiting issue, though I have no idea what that is. and again, some Dropbox issues. If anyone has any idea what all those issues are regarding ScriptingCodes please let me know.

My-Mac-mini:~ username$ /System/Library/CoreServices/Finder.app/Contents/MacOSFinder &

[1] 892

Rangdrols-Mac-mini:~ username$ -bash: /System/Library/CoreServices/Finder.app/Contents/MacOSFinder: No such file or directory

[1]+ Exit 127 /System/Library/CoreServices/Finder.app/Contents/MacOSFinder

My-Mac-mini:~ username$

Rangdrols-Mac-mini:~ username$ /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder & disown

[1] 894

My-Mac-mini:~ username$ 2012-08-25 19:37:10.594 Finder[894:903] Error loading /Library/ScriptingAdditions/QXPScriptingAdditions.osax/Contents/MacOS/QXPScript ingAdditions: dlopen(/Library/ScriptingAdditions/QXPScriptingAdditions.osax/Contents/MacOS/QX PScriptingAdditions, 262): no suitable image found. Did find:

/Library/ScriptingAdditions/QXPScriptingAdditions.osax/Contents/MacOS/QXPScript ingAdditions: no matching architecture in universal wrapper

Finder: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/QXPScriptingAdditions.osax" declares no loadable handlers.

Dropbox: Entered INJECT_pthread_entry

Dropbox: Installing event loop timer

Dropbox: proc: 0x11d171e53

Dropbox: upp: 0x11d171e53

Dropbox: InstallEventLoopTimer: 0x101341dd8

Dropbox: GetMainEventLoop: 0x101341c41

Dropbox: timer installed!

Dropbox: Loading /Library/DropboxHelperTools/Dropbox_u501/DropboxBundle.bundle/Contents/MacOS/Dr opboxBundle

Dropbox: dlopen returned: 0x11bb12090

module initializer in main thread?: 1

Mac mini, Mac OS X (10.6.8)

Posted on


Page content loaded

Sep 7, 2012 2:55 PM in response to Rangdrol In response to Rangdrol

Great work, thanks.

As far as those errors, ypu have some missing OS components it seems.

And, before the mount -uw you really should've done this...

/sbin/fsck -fy

Repeat until it shows no errors fixed.

(Space between fsck AND -fy important).

Resolve startup issues and perform disk maintenance with Disk Utility and fsck...


Sep 7, 2012 2:55 PM

Reply Helpful

Sep 8, 2012 6:31 AM in response to BDAqua In response to BDAqua

Yes, the reason that I didnt include -fy is because I printed it the same way the tip was presented, and most people know to include -fy for a more complete (force, yes) cleaning. Also, I had done this many times, and none of that alone ever fixed it.

As I had mentioned earlier, and in past posts, I was NOT EVER able to log into my system with the originall install CD, so I couldnt use Disk Utility., and I couldnt use the Command-C key, or numerous other key combinations to get access to my computer.

The reason I reposted my fix is because the tip worked, AS IS, and I'm pretty sure it's the "Change certain privileges" which got my computer back up.

Sep 8, 2012 6:31 AM

Reply Helpful
User profile for user: Rangdrol

Question: Solved Mac Mini (late 2010) Blue Screen Hang issue