Previous 1 2 3 4 5 6 Next 87 Replies Latest reply: Jan 31, 2015 3:08 PM by Todd Kogutt Go to original post
  • Legoman557 Level 1 Level 1 (0 points)

    I had the same problem! I recently recorded

    A screen audio & Bluetooth head phone audio

    So my problem was that my iMac was stuck in

    Headphone mode but, I switched my Audio

    From a device that I created, that only would

    Supply sound to my headphones so switch

    Out of the device to speakers and it works

  • ollywicken Level 1 Level 1 (0 points)

    This morning I had the problem described originally on this thread.

     

    The solution that worked for me was to blow into the audio jack a few times. For whatever reason (an accumulation of dust?), this worked.

     

    (Short-term at least. If there's an underlying problem, I'll see in due course.)

  • frylock67 Level 1 Level 1 (0 points)

    Wow, amazingly enough (since this sounded hokey to say the least) this actually worked for me.

     

    NOTE: "this" was BulldobMac's suggestiong to slowly insert/remove the headphone jack while simultaneously playing with the volume. It took a few tries but eventually worked. Playing with the volume was a necessary step as I had inserted/removed the headphones dozens of times previously.

     

    I had previously tried all sorts of "wiggle the headphone jack" and play with NVRAM solutions to no avail. This is certainly a software/firmware problem though as other operating systems could use the speakers just fine.

     

    Message was edited by: frylock67

  • alanatmadisoncollege Level 1 Level 1 (0 points)

    It worked!

     

    Had the same issue but followed BulldobMac's advice and the issue cleared up. The last time my internal speakers worked was when I was using the Apple EarPods. So it made sense to me that the EarPods my have been the culprit.

  • Krati_Golash Level 1 Level 1 (0 points)

    I just had this issue n it was really mind boggling,speakers were working on windows but not on mac n i was getting 'digital out' with red light on. I tried resetting every thing, PRAM,SMC n what not, what ultimately worked was wiggling out the head phones slowely, keeping it stuck half way longer n wiggling it out n it worked. Jai Ho apple ki (all hail Apple) stupid hardware issue!! Request to all who suffer this issue, pls be patient n try with the head phones, chances are that if that does not work you might need a replacement.

  • Treenson Level 1 Level 1 (0 points)

    It works

  • mattjl Level 1 Level 1 (0 points)

    I'm on a Macbook Pro I bought in early 2012.

     

    Pressing the heaphone jack hard in and wiggling it around a bit worked for me and I now have the black sound sign again and the internal speakers working.

  • mcscradley Level 1 Level 1 (0 points)

    Had the same issue as original post, very frustrating. Tried all solutions listed above and the one that eventually worked was blowing into the jack hole. I assume it was dust, however as a user above has stated, if it is and underlying problem I'm sure I'll find out soon enough.

  • rdj.apple Level 1 Level 1 (0 points)

    Thanks it worked for me....

  • pictoperson Level 1 Level 1 (0 points)

    With a MBPro/mid-2009 I had this problem. I tried many of the other things, and then what worked finally was the solution from SkyfromHilo: 

      "What solved this for me, was going to Sound in System Preferences, then to Sound Effects, and where it says Selected Sound Device, it said Choose Sound Device.  To my surprise, Internal Speakers was available.  When I chose it, my Internal Speakers started working again, and came available as an Output in preferences."

     

    Now why would apple disallow the sound output through your internal speakers when the sound effects are being directed elsewhere?  Does this ever make sense?

  • ISOROM Level 1 Level 1 (25 points)

    i had this problem a long long time ago (before i knew all this stuff) so i think you should download the trial for boom  even though its to increase your system volume it corrected my speakers (dont know how) HOPE IT WORKS

  • sizanator Level 1 Level 1 (0 points)

    I had the same problem.

     

    I turned the macbook on its side and blew as hard as i could into the headphone socket several times.

     

    Speakers started working straight away - must be something relating to the switch inside the socket getting stuck.

  • filincrew Level 1 Level 1 (0 points)

    Thanks, skyfromhilo! It works for me too

  • Ncsimac Level 1 Level 1 (0 points)

    I still have the problem and no amount of blowing in the headphone jack or inserting the headphone jack whilst tinkering with volume controls on either my MBP or iMAC desktop fixes the issue.   A few restarts with a reset of the PVRAM sometimes works, but after 3 or 4 restarts I usually give up.

     

    BUT,  I have noticed another related issue.  When I get no sound option, I am not able to read from the SD card either.  There is no switch or internal LED on that one to gather dust.    When I restore the system to get sound, the SD card reader works again !!   Does anyone else have this as well?

     

    Come on Apple get this sorted, there is obviously an operating system interupt hangup on these interfaces and has nothing to do with hardware switches, LEDs and dust. 

  • KillingTime Level 1 Level 1 (0 points)

    Thanks - the plugging and uuplugging of the hearphone jack sorted the issue out.   It took a few goes though.