Previous 1 2 Next 15 Replies Latest reply: Jun 26, 2014 6:22 PM by cltaylor12
Gorhamgrey Level 1 (0 points)

I recently installed Mountain Lion and since my "Arrange by" does not work for by name. All of the other sorting methods seem to work but when I try to arrange by name they do not sort alphabetically. They seem to sort randomly. I've searched every where and it seems to be just a problem for me.

 

Does anyone know anything?


iMac (27-inch Mid 2010), OS X Mountain Lion (10.8.1)
  • macjack Level 9 (51,622 points)

    Go to your Finder "Go" menu hold the option key and choose Library. Then go to Preferences folder and trash

    com.apple.finder.plist

     

    Then, restart, or log out and in again.

    (You will have to reset a few finder prefs the way you like them.)

  • Gorhamgrey Level 1 (0 points)

    Hrmm Thanks but that didnt seem to help.. I tried it a couple times for good measure but no luck.

  • macjack Level 9 (51,622 points)

    Hmm... don't need a few times for good measure. It should work the first time or not.

     

    Have you tried starting in Safe Mode and see if the problem still occurs?

    Restart holding the "shift" key.

    (Expect it to take longer to start this way because it runs a directory check first.)

  • Shootist007 Level 6 (16,660 points)

    In finder open the View settings. Select List (command+2) and then Arrange by None. Then you can click on the list heading to arrange by Name or any other heading Ascending or Descending.

     

    If you select Name from the Arange By it never give you what you think.

     

    You can then switch back to Column view if you like and the files/folder will be listed in Alpha order.

     

    Screen Shot 2012-09-08 at 6.50.54 PM.png

  • Gorhamgrey Level 1 (0 points)

    Funny so the list view works alpha order.. Its just when I go back to Column view it goes back out of order..

    There is def some kind of bug

  • Gorhamgrey Level 1 (0 points)

    MacJack I tried the safe mode and no luck.. I really seems to only happen when Its in column view.. Of course the one view that I use all the time.

  • Shootist007 Level 6 (16,660 points)

    If you select Arrange By Name, instead of None. it does funny things. Once you have NONE selected and then arrange by name from the Headers in List view it should stay that way. At least mine does.

  • Gorhamgrey Level 1 (0 points)

    Yeah that makes sense.. But I've tried that and no luck.. Its so weird, once I go back to column everything just changes..

  • Barney-15E Level 8 (46,274 points)

    You are confusing Arrangement with Sort. Arrangement groups items according to the option selected. Sorting Sorts the items in a particular group by the option chosen. However, Arrange by Name should just sort alphabetically. It does seem to remember the sort direction from List view, so you may sometimes see the sort inverted.

     

    The plain click on the Arrangement button or selection from the menu is an arrangement. If you option-click the button or the menu, you will get the sort options for that Arrangement. If you want to just sort, set the Arrangement to None and then set the sort to by Name.

  • Shootist007 Level 6 (16,660 points)

    When you are back in Column view make sure that Arrange By Name is not selected. Finder is Odd and does very Odd things IMHO.

  • Shootist007 Level 6 (16,660 points)

    Thanks Barney. I forgot that little detail.

  • macjack Level 9 (51,622 points)

    Mine lists alpha order by name in Column View, which my default. Every folder and all it's nested folders listed in alpha order.

     

    Here are my settings...

     

    With Finder window and Mac HD chosen > View menu Arrange by > Name

    With Finder window closed View menu > Sort by > None.

  • Gorhamgrey Level 1 (0 points)

    Barney this worked! Thanks alot.. I've never run into a problem like this before

  • artdesi Level 1 (0 points)

    THIS WORKED FOR ME!!! Had this issue since purchase of refurbished 2011 MBP 17...and new Finder window opens at top left like old times. Thank-you!

Previous 1 2 Next