Previous 1 2 3 Next 44 Replies Latest reply: Jul 29, 2015 2:09 PM by AngieCorbett Go to original post
  • schmedrake Level 1 Level 1 (0 points)

    I have had the same issue with my Macbook Pro for months now. Everything I tried did not work. And I tried all of the five steps above, repeatedly. I finally got it out today. It was a combination of the running your thumb along the seal (although I used a greeting card) and turning the computer on its side and shaking it up and down while the ejecting (or non-ejecting) is happening. I got the shaking idea from another thread about this. I did try just clearing the opening as suggested above, but it didn't work that way all by itself. So I added the shaking.

  • Brandon Fairbanks Level 1 Level 1 (0 points)

    the hard drive in the mac didn't get seated right and made the computer freak out and not want to give me my disc back for some reason. but as soon as i took the hdd out and put it back in the computer allowed me to eject the disc

  • JHW1234 Level 1 Level 1 (0 points)

    Thank you SO much jnmaloof!!!! Finally, finally, finally, finally.

     

    I had to keep holding down the eject key (after the boot screen came up). It ended up ejecting a little at a time, sliding part way out and then on a bit, and then out further again. Finally it was far enough to pull it out. (At this point I didn't want something to go wrong and so took the risk to pull it.)

  • jhnmorely Level 1 Level 1 (0 points)

    This worked like a charm.  Thank you. 

  • jhnmorely Level 1 Level 1 (0 points)

    This = right-clicking on the mouse during Restart

  • jhnmorely Level 1 Level 1 (0 points)

    Had the same problem again, but right click didn't work.  Put the tapered end of a wooden chopstick between the rubber on the sides of the eject slot and slid it down slowly.  This separated the rubber enough and the disc ejected when I hit the eject button.   I had the problem with a CD-R, but it does not occur with a store-bought music CD,

  • 655Jack Level 1 Level 1 (0 points)

    Jnmaloof...it worked! Thanks!!

  • Honeycrisp_Hardware Level 1 Level 1 (0 points)

    After building my iMac from scratch, the optical drive failed to release my OS disc.  I could hear the disc attempting to be read, but, could not proceed from that point.  So, I did the right click + thumb in the optical drive maneuver and it worked straight away.

  • Ellemmaya Level 1 Level 1 (0 points)

    to jnmaloof ...

     

    thanks so much!

    after twenty-four hours of panic this method worked for me.

  • suhadanie Level 1 Level 1 (0 points)

    thank you so much jnmaloof! in first try, it failed because I didn't shut down my macbook, just restart it over and over again and continously try the option button and eject button method. I try this method sooo many times, other methods too but failed. so I leave my macbook overnight and try it again in the next morning, and it worked flawlessly! thank you so much. to anybody who has a same trouble, good luck

  • Robert Enyeart Level 1 Level 1 (15 points)

    "I also have a computer with no OS installed.

     

    What worked for me was to 1) hold down the option key on start-up until the disk/boot icons appear.  2) Then press the eject key (or F12) on the keyboard.  Pressing eject on its own did not work."

     

    Yes, this is the ticket!

    Thanks!

  • JOHNCOOPER15 Level 1 Level 1 (0 points)

    I had tried everything to eject my Windows 8.1 disk and then I read your advice. Brilliant. Now can you tell me how I can stop my Macbook Pro (OS X Mavericks) from booting up in Windows?

  • pole1108 Level 1 Level 1 (0 points)

    Mactopman trick did it for me, thx

  • ajFLORIDA88 Level 1 Level 1 (0 points)

    I had a DVD that was stuck in my macbook pro and none of the steps listed worked.  So I folded a piece of paper, slid it into the DVD slot (on the left side of the opening), and made contact with my DVD (which was still spinning).  And once I slowed it down and almost stopped it from spinning.  The computer recognized it and spit it out! This was very frustrating, so I wanted to share what worked for me and hopefully it will help someone else in the same jam I was in.

  • 13g0 Level 1 Level 1 (0 points)

    Your very first tip worked!  Restart with left mouse button held down (Bluetooth wireless Magic Mouse) - viola!  And I was nearly booking the iMac in for repair.

     

    Thank you!