14 Replies Latest reply: Jul 14, 2013 7:38 AM by lavenderlemur1 Branched to a new discussion.
CKYL Level 1 Level 1 (0 points)

I've accidentally deleted my desktop icon from the Users folder. It doesn't really make a difference, but when using Sharing to access my iMac files from another computer, I can't go to files on the desktop.

 

Can anyone help me please?

  • roam Level 6 Level 6 (13,555 points)

    Is it in the Trash? If it is, put it back in the Users/Home account.

     

    If it is not, recreate it in Terminal* with this command. Copy and paste the following to avoid typing error.

     

    mkdir ~/Desktop

     

    and press return.

    Quit Terminal.

     

    *Terminal is found in Applications/Utilities

  • CKYL Level 1 Level 1 (0 points)

    Nope it's not in the Trash, and sorry, the command doesn't work Terminal actually shows a message that the file exists, but when I go to Finder>User (Home Icon) where all the folders (i.e. Documents, Downloads, Pictures etc.) are, there's no Desktop icon.

  • roam Level 6 Level 6 (13,555 points)

    OK, In Finder, open its Preferences, and click on the Sidebar tab, and where it says Places, check to see if Desktop is selected. I hope it is as simple a thing as that for you.

  • CKYL Level 1 Level 1 (0 points)

    Oh dear, no, the Desktop still appears in the Finder sidebar and yes Desktop is selected in Finder Preferences. The icon I'm referring to is with the other folders under MacintoshHD Users.

     

    Thanks for your tips though!

  • roam Level 6 Level 6 (13,555 points)

    We are at an impasse it seems.

    When you say you "accidentally deleted my desktop icon from the Users folder." can you elaborate about what you did here, if anything?

    What I see on mine is this. Can you post an image of what is missing in your setup?

    Users01.png

    Also, as your query is about Sharing, check your System preferences > Sharing to see if your selections are as you intended.

  • Allan Jones Level 7 Level 7 (32,080 points)

    As there seems to be an impasse, It might be helpful to tell us which version of the Mac operating system you have. This forum covers iMacs made from 1998 through 2005, so the range of OS versions is rather large and can affect the answers you get.

     

    "About this Mac" under your Apple menu wil display the OS version:

     

    About_this_Mac_PPC.png

  • CKYL Level 1 Level 1 (0 points)

    I deleted the Desktop icon by mistake and only realised some time later that it was missing.

     

    This first picture shows my iMac User folder without the Desktop folder.

    Screen Shot.png

     

    This second picture shows my MacBook User folder with the Desktop folder.

    Screen Shot 2.png

     

    It shouldn't be a Sharing issue as I've enabled sharing for everything. It's just that direct access to the Desktop folder is missing, which is rather annoying.

  • CKYL Level 1 Level 1 (0 points)

    Oops really sorry, I didn't realise this forum was for Macs up to 2005. I bought mine in 2010 and my version is 10.7.4!

  • roam Level 6 Level 6 (13,555 points)

    Oh 10.7.4, I don't use it, so I would be just guessing.

  • D.I. Johnson Level 3 Level 3 (815 points)

    Hi.

     

    What happens if you select the Desktop folder icon which is still in the sidebar?  Do the contents of your desktop folder display in the Finder window?

     

    If so, then go to the Finder Menu bar and click View > Show Path Bar.  When the contents of the Desktop folder are displayed in the window, the path bar (at the bottom of the window) should display the current path to that folder, as it does in this screenshot: 

    Screen Shot 2012-09-09 at 9.41.25 PM.png

     

    Is it possible that the Desktop folder was somehow relocated into another folder?  (I don't even know if that's possible).

     

    Perhaps the folder itself has become hidden.  You said that when you use Terminal to create a new Desktop folder, the response was that the file already exists.

     

    Try this Terminal command to unhide the folder...

     

    chflags nohidden ~/Desktop/

     

     

    Post back and let us know if this has any affect.

  • CKYL Level 1 Level 1 (0 points)

    Wow, thanks so much, the Terminal command worked!

  • D.I. Johnson Level 3 Level 3 (815 points)

     

    You're welcome. Happy to help.

  • roam Level 6 Level 6 (13,555 points)

    Great work D.I.Johnson.

  • lavenderlemur1 Level 1 Level 1 (0 points)

    I had the same problem as the above and the chflags worked for me too, Many many thanks D I Johnson.  I was using appcleaner and it will not let you pull anything out of the trash.  Please do not use this tool