1 Reply Latest reply: Sep 9, 2012 11:52 AM by Terence Devlin
lekaiser Level 1 Level 1 (0 points)

I have used iPhoto 09, and currently have about 102,000 photos (12 years worth).  When iPhoto 11 dropped the keyword under the thumbnails, I decided not to upgrade.  And, with this many photos, I know I am overstretching iPhoto.  My 'old' 20" iMac is 5 years old.

 

At Christmas, my husband bought me a new, top of the line 24 inch iMac, and an external 8TB raid hard drive.  We have exported the iPhoto library from the old iMac to the external hardrive (library is about 750 Gig, HD raid 8Tb).  We've tried to import this directly into Aperture on the new iMac- fail.  We tried to update the library to iPhoto 11 on the new iMac, and that hangs.  We tried another import to Aperture, and it looked like it finished, but all the photos are corrupted and not viewable.

 

Each of these operations took anywhere from hours to nearly a week!  I tried for a while; my husband took over and tried for a while.

 

I really want a SINGLE library if I can do that.  I have keywords on every one of these 100,000 plus photos, and I regularly search out groups of them that span the years.  We started this process last CHRISTMAS, and we still can't get it working.

 

I was relatively happy with iPhoto, but my library has grown too big, and the lack of the keywords showing means I need to move on.  I am still using my old iMac, and old iPhoto 09, because I can't get this danged thing to update!!

 

We have tried and tried to research this but it's not seemed to work.  My husband wants me to split my library in to much smaller libraries.  I am really resisting this.  I read that Aperture can handle a massive library like mine.

 

I have Aperture 3, but honestly I would be willing to buy anything that would actually WORK at this point... and keep and show my keywords.

 

Any suggestions?   Pleeeeeease. 

 

Lynne


multiple, Mac OS X (10.5.1)
  • Terence Devlin Level 10 Level 10 (131,480 points)

    Here's what you want to do.

     

    Upgrade iPhoto 11 to the latest version.

     

    Open the Library with it.

     

    Then open the Library with the latest version of Aperture.

     

    No importing as the latest versions of both apps can use the same Library.

     

    I noted this:

     

    We tried to update the library to iPhoto 11 on the new iMac, and that hangs. 

     

    Try rebuild the Library:

     

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Repair Database. If that doesn't help, then try again, this time using Rebuild Database.

     

    If that fails:

     

    Option 2

    Download iPhoto Library Manager and use its rebuild function. (In Library Manager it's the FIle -> Rebuild command)

     

     

    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.

     

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. 

    Regards

     

    TD