6 Replies Latest reply: Jan 17, 2015 3:31 AM by cheddar-sharp
Toivo Level 1 Level 1 (0 points)

I was using iTunes on a computer set to use English as the default language. I backed up the library, then moved it to my new computer. The new computer is set to use Finnish as the default language. So far, so good.

 

When I open iTunes, everything's still fine. However, as soon as it has a reason to touch a track, for example playing it, it automatically with no confirmation begins to translate the genre field, so for example "Celtic" becomes "Kelttimusiikki" and "Classical" becomes "Klassinen." This of course completely mucks up all smart playlists where it doesn't change the genres accordingly.

 

Any advice on how to deal with this? I really don't want iTunes to automatically muck with any of the information if I don't allow it to. If it insists on translating things, I'd rather it translate everything.

  • turingtest2 Level 9 Level 9 (55,455 points)

    Change the language of the iTunes interface to English...

     

    tt2

  • Toivo Level 1 Level 1 (0 points)

    I don't see any obvious way to change the iTunes interface language in the settings? Where does one change that?

  • turingtest2 Level 9 Level 9 (55,455 points)

    Muokkaa > Asetukset... > Keili > Englanti (Yhdysvallat) > OK

     

    You can also delete the folder "Lisää automaattisesti iTunesiin" from your media folder.

     

    tt2

  • Toivo Level 1 Level 1 (0 points)

    I appreciate the help.

     

    Unfortunately, turning of the "Kopio Tiedostot iTunes Media -kansioon" setting had no effect. Also turning off the keep folders organized setting "Pidä iTunes Media -kansio järjestettynä" makes no difference; iTunes still changes the genre.

     

    As to changing the language, I'm afraid I'm failing to follow the instructions. The iTunes top menu bar does have a "Muokkaa" (Edit) option, but there is no "Asetukset" (Settings) in the menu. The only iTunes settings I can find are through the iTunes menu next to the apple at the top left, the command+comma ones (iTunes -> Asetukset...). I haven't been able to find any iTunes specific language settings, except for the playback language preference.

     

    Looking at this article: http://support.apple.com/kb/HT2242 it would appear that the Windows version has the language option, but you cannot control the MacOS iTunes language separely from the OS language.

     

    Message was edited by: Toivo -- added reference to HT2242

  • turingtest2 Level 9 Level 9 (55,455 points)

    Ah, my apologies. I'm frequently caught out by the inconsistencies between the versions. I'm hoping to get access to a Mac before too long.

     

    In the PC version of the iTunes application folder is a file called ../iTunes.Resources/fi.lproj/localizable.strings. Having switched iTunes into Suomi and seen the genres change I renamed this file localizable.strings FI, copied in the English file from ../iTunes.Resources/en.lproj/localizable.strings then started iTunes again. Genres switched from Suomi back to English

     

    Hopefully you can perform a similar hack on the Mac.

     

    tt2

  • cheddar-sharp Level 1 Level 1 (0 points)

    I know it's an old topic, but I figured out a simple workaround. I'm posting it here in case anyone else has the issue.

    1). Make sure that all of your classical tracks are labelled 'Classical'. The genre 'Klassinen' should not appear on the genre sidebar.

    2). Take one track that you don't care about and change the genre to 'Klassinen'. 'Klassinen' now appears in the sidebar as a new genre.

    3). iTunes will no longer try to create the new genre 'Klassinen' because it it already exists. It will no longer localize your genre names.