Previous 1 2 Next 16 Replies Latest reply: Dec 17, 2012 5:34 AM by Henry Cline1
Scott Schroeder Level 2 (205 points)

Since installing Mountain Lion, a dialog for downloading and installing software appears each and every time I turn on my Epson printer.

 

There is no update available, nor does clicking "Install" solve the issue. It simply replies "Software is currently unavailable"

 

This happens in each account on the machine.....

Epson.jpg

 

epson2.jpg

  • mende1 Level 10 (92,201 points)
  • Scott Schroeder Level 2 (205 points)

    I should have stated this also:

     

    1) Reinstalling the Epson software doesn't solve the issue (For example, installing again from the link above. Thanks anyway mende1)

     

    2) The problem occurs with each account on the machine.

     

    I suspect some non-trival issue with a previously installed Epson driver package, or some dinged preference file.

     

    I'm tempted to blow away all Epson prefs and do a reinstall, but wanted to see if such surgery really was required, or would work.

  • mende1 Level 10 (92,201 points)

    Open Disk Utility and repair permissions before

  • Scott Schroeder Level 2 (205 points)

    It's not a permissions problem. Nor are there any directory structure issues.

  • ShlomiL Level 3 (770 points)

    Try resetting the printing system abd check if that may help::

    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01371980&tmp_task=useCatego ry&cc=us&dlc=en&lc=en&product=3853829

    Once the printing system reset completes, click the plus sign and add the printer once again.

     

    If that does not help I would also recommend you to try repairing the disk permissions anyway and then try  installing the DL1938 package again.

     

    Regards,

    Shlomi

  • Scott Schroeder Level 2 (205 points)

    Resetting seems to have solved the problem...I say hesitantly

     

    I suspect it will recurr.

     

    The issue was 100% repeatable now, but was not always so. The repeatability comes and goes.

    Possible connection to this issue: https://discussions.apple.com/thread/3816878

  • WebSailor Level 2 (310 points)

    I had the identical issue with my Canon printer.   But since upgrading to 10.8.2 it has disappeared altogether.

  • WebSailor Level 2 (310 points)

    Oops!  After several days of proper operation since updating to 10.8.2, this problem came back last night when I turned on the printer and now it occurs every time I turn on the printer.  So NOT fixed in 10.8.2

  • WebSailor Level 2 (310 points)

    Normally I do not shut down my iMac - rather I just let it sleep as per System Preferences > Energy Saver settings.   This morning I did a complete shut down and then restarted and the problem has gone away again.  Then I did a bunch of testing by launching all the usual applications I might have run since updating to 10.8.2 to see if one of these triggers the problem.  After each new application launch I turned on the printer to see if the problem would occur (and then shut down the printer before the next application launch.)   So far I haven't found what triggers this but once triggered it seems to then occur with each printer start (until I shut down the iMac again I guess.)  I will have to keep a close watch on what I launch for a while to see what I have missed.

  • Mike Osborn Level 4 (1,205 points)

    Just curious, WebSailor....have you been able to resolve this issue? 

     

    I've got the same thing going on with my Epson Artisan AIO printer.

  • WebSailor Level 2 (310 points)

    Hi Mike,

     

    No not resolved yet.  I still have an Applecare case open, and on the last attempt the Apple tech had me reset the printing system.   Since that time there has been another update for the Canon printers (which is what I am using) but the problem persists.   Normally I don't reboot my system often, but if I do, then the problem goes away for a week or so and then comes back.   However I am presently shutting down often due to a dusty home renovation so it won't be meaningful for me to contact Apple again to report the present status, while the problem is temporarily masked by the shutdowns.    When I get back to it, I will report any resolutions that will hopefully be found.

  • Mike Osborn Level 4 (1,205 points)

    Websailor,

     

    Thanks. Like you, I've tried resetting the printing system, deleting my Epson folders, then adding the printer back. The problem goes away for a week or so, then reappears. I'm sure it's an obscure file I need to delete to fix this issue, but I've no idea where that file is, or what it's called.

  • Scott Schroeder Level 2 (205 points)

    Do any of you also noticed the problem to recurr when your Mac sees "another computer unsing the same IP address"?

     

    I seem to only get the problem after seeing my local computers name was in use....

    This happens when

    1) My home machine is asleep

    2) My laptop is active on the same network

    3) My home machine reawakens

    4) I try to print from my home machine

     

    Again, this is not 100% repeatable, but the printing error so far has ONLY happened when steps 1-3 had already occurred

  • Mike Osborn Level 4 (1,205 points)

    Scott,

     

    I never considered the sequence of events you listed, so I can't say for sure....but I don't think it's relevant for me.  I get the "...download and install..." message sometimes but not all the time.  Normally I will get it when I wake the computer from sleep...and when changing from one user account to another one.  I get the message without even trying to print anything...and, in fact, I have no trouble printing anything.

     

    Now...whether my iOS devices being active on the same network is relevent...I've no idea.

Previous 1 2 Next