Previous 1 2 Next 21 Replies Latest reply: Nov 2, 2012 9:18 PM by Jeff S.
filthy D Level 2 Level 2

It's completely gone! How do I get it back in the printer list? It's a Canon PIXMA MP500 connected by USB and was working fine up till last night. Still not sure why I deleted it from the printer list since I did this once before!!!! I can't find the thread that explained how to get it back on my Mac. I reinstalled the drivers and software but still nothing. I'm using 10.8.1. Please help!


OS X Mountain Lion
Solved by PAHU on Sep 15, 2012 10:55 PM Solved

filthy D wrote:

 

OK it does not show up in the USB section of my sytem profile

Then this is the problem. If you are to have any hope of printing to it when it is connected to the Mac via a USB cable, then it must appear in this view.

 

Some users have had success with turning off the power to the printer and then unplugging the power cord for 5 minutes. They then reconnect the power cable to the printer and turn it back on.

 

If you try this and the printer reappears in the USB section of System Information, then you can remove the printer proxy you have currently in Print & Scan and add the printer again.

 

But if the printer still fails to appear in System Information then it may be time to get a new printer.

 

filthy D wrote:

 

...but it does show up when I select printers in system profile.

This is because you used the information in that other post to get the printer proxy back into Print & Scan. But this printer proxy does not have a physical connection to the printer, due to the lack of a USB connection, and this results in the offline status.

  • Matt Clifton Level 7 Level 7

    Normally you can safely delete and re-add any printer, since the drivers remain installed - no need to reinstall the software. Did you already try simply clicking the "+" button under the printer list?

     

    Matt

  • filthy D Level 2 Level 2

    Yes and nothing shows up in the add window that follows.

  • Matt Clifton Level 7 Level 7

    Try rebooting, and make sure the printer is turned on and attached to the Mac.

     

    Matt

  • filthy D Level 2 Level 2

    Thanks Matt. I did that too, nothing. Very frustrating.

  • Imp68 Level 4 Level 4

    Turn off printer.

    Unplug USB cable.

    Delete canon folder from /Library/Printers.

    Reboot.

    Plug in printer to different USB port.

    Turn printer back on.

    Wait for its warm up noises to stop.

    Attempt to readd it.

    Do software update if it adds.

    Try to print.

  • filthy D Level 2 Level 2

    Still nothing...

  • AnaMusic Level 9 Level 9

    filthy D wrote:

     

    Still nothing...

     

    Try a different USB Cable... One that you know is working...

  • filthy D Level 2 Level 2

    yep tried that too.

  • richardchan66 Level 1 Level 1

    Yes ever since I upgraded to Mountain Lion 10.8.1 my Pixma MP500 also stopped working

  • Radiation Mac Level 5 Level 5

    I found the following on their Support Site:

     

     

     

    About PIXMA MP500

    See Other PIXMA MP Series

     

      Photo All-In-One Printer
    Item Code: 0579B002

     

     

     

    Drivers & Software

    Select an Operating System and OS Version from the drop down menu below then click on a category to view the latest supported files for your product. Click on the file description to navigate to download, then click on "I Agree - Begin Download" to start downloading.

        How to find your OS?

     

     

    Hope this helps
  • filthy D Level 2 Level 2

    yep know that BUT in my case it's been working fine until I deleted it from the printer/fax list the other night and that's only because I can't get it to show up again in the list.

  • filthy D Level 2 Level 2

    Anyone know how to get the Canon printer back into the printer/fax list????

  • filthy D Level 2 Level 2

    Well I got my printer back following directions in this thread,

     

    https://discussions.apple.com/thread/2775350?start=0&tstart=0

     

    Only problem is the Canon is showing up as offline. I've tried everything in this thread over again but still nothing, any other suggestions out there?

Previous 1 2 Next