5 Replies Latest reply: Nov 18, 2012 10:08 AM by Victoria Herring
iMac-newbie Level 1 Level 1 (0 points)

Hi,

 

I am in process of backing up large HD video files from one external hard drive to another using Carbon Copy Cloner software.  I get this error message:  "This file or folder is sitting on a bad section of hard disk media and is unrecoverable. Delete this item (i.e. in the Finder) and restore it from a known good backup, then try the backup task again."

 

  • I have tried to delete that folder in Finder and I get error code-50, it won't delete. 
  • I tried to delete individual files within folder - error code 50.
  • I tried to "replace" folder with good copy from other external hard drive.  Error code-50
  • I tried to "repair disk" in Disk Utility application and I get error message "cannot unmount disk." 
  • NOTE:  the files in this folder are .m2ts format, from an old PC.  I converted then into .mov but want to retain originals. 
  • NOTE:  I was successfully able to copy the folder from a 3rd external hard drive to the backup disk without a problem (which makes me think it's not the files/folder but has to do with the actual disk.), but cannot fix it on the original (source) disk.

 

Bad disk?

Bad files?

How do you fix a "bad section of a hard disk"? 

Might reformatting the entire disk fix the "bad section"?

 

Any advice welcomed and appreciated!

Thank you!


iMac, Mac OS X (10.6.8)
  • Klaus1 Level 8 Level 8 (46,490 points)

    Error code -50 usually means a bad character in a file name:

     

    http://support.apple.com/kb/TA20831

  • iMac-newbie Level 1 Level 1 (0 points)

    It is a long file name, but if this were the case...

    • would I have been able to copy it to other external hard drives with no problem?
    • why I am I unable to delete individual files within the folder that have nothing more than a # for the file name?
    • what about the fact that 3rd party software (Carbon Copy Cloner) says "bad section of hard disk media"

    Thanks in advance...

  • Bengt Wärleby Level 6 Level 6 (19,450 points)

    Hi

     

    Error -50 paramErr  Error in user parameter list

     

    Can there be any external hard disks - if so How is/are it/they formatted ? Must be Mac OS Extended (hfs) if used for Video.

     

    UNIX/DOS/FAT32/Mac OS Exchange - works for most but not for VIDEO.

     

    What this means in Your situation is above me.

    • free space on internal boot hard disk? How much ?

     

    Video codec

    • streamingDV, AIC etc. (not .avi, .mp4, .m4v, .wmv etc as they are containers not codecs)

     

    Pictures

    • in what format ? .jpg, .bmp, .tif, else ?

     

    Audio

    • from where/what format ? iTunes, .avi, .mp3, .aiff, else ?

     

    The "com.apple.iMovie.plist" file

     

    Many users has not observed that there are TWO libraries.

    • Library - at root level

    • Library - in user/account folder - THIS IS THE ONE to look into

     

    from Luke Burns

    I fixed the problem.. but it was very, very strange. I had a very long section for credits and set the line spacing to 1.0.. for some reason this caused it. I removed it, and it worked fine. I put it back, and I couldn't preview or play the video.

     

    I don't know why that could cause that big of a problem, but it did..

     

    Klaus1

    You need more free space on your hard drive.

     

    jonorparkerjon

    After phone support from apple I ended up creating a new project and adding all 117 clips back in individually till I found out what clips flagged and would not allow me to export. I had 3 I deleted and replaced and everything works now 1hr after tedious work....

     

    Where do Your material come from

    • Camera

    • External hard disk

    • USB-memory

     

    And all are connected so that iMovie can find it ?

     

    Yours Bengt W

  • iMac-newbie Level 1 Level 1 (0 points)

    To Klaus1:  I should also mention that I am unable to rename the folder (which does in fact have a long unwieldy name).  I have tried the most simple name possible and I get the message: "Try using a name with fewer characters, or with no punctuation marks."  I am using 4 characters, all letters, no punctuation marks.  But given that it copied fine at least 3x already, my uninformed guess is that it has to do with the "bad section" on the disk...what to do if that is the case?? Thanks.

     

    To Bengt - thanks. I did see this reply to another post.  The drive is formatted for the Mac (OS Extended (Journaled)), almost 2/3 of the drive is free space.  I'm not sure what else on this list applies to this situation? Thanks.

  • Victoria Herring Level 2 Level 2 (290 points)

    I am getting the same message -- I was trying to delete a folder full of files off an external drive but decided to try to do it by smalleer bits and just picked one folder -- same message == the folder's name is AIR and it has zero bytes -- any suggestions?