4 Replies Latest reply: Dec 29, 2012 11:19 AM by kalkap
s_w_i_t_t_e_r_s Level 1 Level 1
expertise.wireless
Wireless

I recently downgraded from Mountain Lion to Lion. I erased my internal hard drive, installed Lion, updated to 10.7.4, and then migrated my user account data using the Migration Assistant.

 

I am unable to open the Energy Saver or Desktop & Screen Saver Preference Panes. I get an error message that says "Could not load Energy Saver preference pane."

 

I opened Console.app and this is the error message:

 

9/16/12 2:49:55.975 PM System Preferences: [NSPrefPaneBundle instantiatePrefPaneObject] (/System/Library/PreferencePanes/EnergySaver.prefPane): principalClass is nil.

 

And for Desktop Pane:

 

9/16/12 2:52:58.706 PM System Preferences: [NSPrefPaneBundle instantiatePrefPaneObject] (/System/Library/PreferencePanes/DesktopScreenEffectsPref.prefPane): principalClass is nil.

9/16/12 2:53:05.221 PM talagent: PersistentUI: CSBackupSetItemExcluded() failed with OSStatus -61

 

I have no idea what to make of this! Can anyone help?

 

I have already reinstalled the 10.7.4 Combo Update and deleted the System Preferences preferences in my user account.


MacBook Pro, OS X Mountain Lion (10.8.1)
  • s_w_i_t_t_e_r_s Level 1 Level 1
    expertise.wireless
    Wireless

    After doing some searching I've seen some threads suggesting this error is caused when the iLifeMediaBrowser file is missing from /System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/.

     

    However, that doesn't seem to be the case for me. When I navigated to that directory, I see the file right where it should be:

     

    /___sbsstatic___/migration-images/195/19591643-1.png

     

    Also, I've tried installing the 10.7.4 update to no avail.

     

    What now?

  • MoogNinja Level 1 Level 1

    Same problem, I downgraded from the bug ridden "Mountain Goat" OS with a fresh instal (and using time machine set up assistant) and now that funky OS has messed up Lion as well.

     

    Preference panes not working for desktop, energy saver, and mail not working.

  • kalkap Level 1 Level 1

    Anyone figure this thing out yet?  I completely erased my hard drive and started over because of several issues from Mountain Lion that I just couldn't get straigtened out and now I'm having this issue as well.

  • kalkap Level 1 Level 1

    Update:  Here is a link for what worked for me.  It appears that you have to go into the more info section of the system preferences applicaltion and check mark the box to open it in 32 bit for some reason.

     

    https://discussions.apple.com/thread/4114533?start=0&tstart=0