3 Replies Latest reply: Oct 16, 2012 2:48 PM by Skepticus
Skepticus Level 1 Level 1 (0 points)

I have now come several times come across what appears to be an easy reproductible bug, which occurs when Lion goes to sleep with a keyboard switched to another language (mostly European languages).

 

I am using several keyboard including the U.S. standard keyboard, the Swiss French keyboard, the Japanese keyboard, and Asian extended keyboard (a nonstandard keyboard not provided by Apple).

 

When I am writing text in French using the Swiss French keyboard and my Mac goes to sleep, I need to input my admin password to wake it up because I have chosen this option in Security & Privacy. The problem is that some keys are in different locations because of the different keyboard. Thus, my computer rejects the password ad infinitum, and I finally have to force it to shut down. Once it reboots, the problem is over because the same bug does not persist in the login screen.

 

I am surprised nobody seems to have run into this problem before. Or am I missing something?

Either a solution (other than simply having a PW that remains the same whatever the keyboard) or an acknowledgement that this is indeed a bug would be greatly appreciated.

 

Thank you for your time.

 

P.S.: The same bug occurs on my iMac and on MacBook Pro, which both have Lion 10.7.4 installed.


iMac 2.16 GHz Intel Core Duo and MacBook Pro 17" 2.66 GHz Intel Core Duo, Mac OS X (10.6.1)
  • 1. Re: Bug found when Lion goes to sleep with a keyboard switched to another language
    Tom Gewecke Level 9 Level 9 (71,735 points)

    You aren't talking to Apple here, just other users like yourself.  The channel to report bugs is

     

    http://www.apple.com/feedback/

     

     

    In system preferences/users & groups/login options, have you checked the box for Show Input Menu at Login Page?

  • 2. Re: Bug found when Lion goes to sleep with a keyboard switched to another language
    Skepticus Level 1 Level 1 (0 points)

    Thank you Tom.

    As suggested, I submitted this as a feedback as well.

     

    I also checked the box for Show Input Menu at Login Page in system preferences/users & groups/login options. I will see whether it suffices to resolve the issue. My first attempt after checking this option was not very successful. After putting the mac to sleep and trying to wake it up, I got the spinning wheel and had to force shut down.

     

    Anyway, I will update this thread as soon as I have been able to test the suggested strategy.

  • 3. Re: Bug found when Lion goes to sleep with a keyboard switched to another language
    Skepticus Level 1 Level 1 (0 points)

    Here is the promised update (sorry for the delay).

    In the strict sense, the issue is resolved as per Tom Gewecke's suggestion. It cannot be considered a "bug," since there is a way to circumvent the problem. Yet, I would suggest that this remains an issue insofar as the default setting still makes the login screen behave in a way that is unacceptable. The fact that users have to tweak the preferences in order to obtain an obvious result can be considered bad design of the OS at this level.

    I would recommend that the Apple programmers simply improve the interface in this regard and be a little more "international" in the way they test the system.

     

    In any case, I really appreciate the help received through this channel.

    Gratefully yours,

            Skepticus