Previous 1 2 3 Next 283 Replies Latest reply: Oct 24, 2013 3:11 PM by topedia Branched to a new discussion.
Phreddo Level 1 (0 points)

This started recently, I think there was some quicktime upgrade that happened.  I've rebooted my computer and the problem persists.  I've found similar discussions referring to AppleMobileDeviceService, but I don't know if this is that issue or something else.

Running Windows 7 64 bit.


Only antivirus is MS security essentials and TrustedID SecureScan (made by Immunet?).  TIA


Process explorer shows PID 7988

Windows 7
  • Mark J P Level 1 (10 points)

    This has been happening to me as well for the last three or four days.  It has never been a problem in the past. 


    I believe there was an iTunes update on Wednesday or Thursday of last week and it has been a problem since then.  When using iTunes my CPU goes up to 100% and stays there.  The services using the CPU are iTunes.exe, ATH.exe and AppleMobileDeviceService.exe (all are obviously Apple related).


    If I stop these Apple services mentioned above then my CPU drops back down to 2-3%.  If I open iTunes again it doesn't take long before the CPU is maxed out once more.


    Prior to this latest update iTunes has never been a problem on my machine over the last four or five years of use.


    The machine in question is using Windows 7 x64 (with all latest updates), iTunes x64.


    This is a real problem as the machine becomes unusable until I close iTunes down.  I usually leave iTunes open all of the time so that I am able to access music from my MacBook and other devices around the house.


    Does anyone have any ideas?


    Thanks in advance.

  • Phreddo Level 1 (0 points)

    I guess for the time being i'll have to shutdown iTunes when i'm not syncing

  • BrandonCali Level 1 (10 points)

    I had to close down ATH.exe cause it was really bad, I even had to eject all my devices. I had my iPhone hooked up wirelessly and my iPod Classic hooked up through USB. So I don't know, if this problem continues with ATH.exe and my music skipping may need to use a different player until iTunes fixes the problem. My audio has NEVER skipped before with the last version of iTunes.

  • Phreddo Level 1 (0 points)

    That's the other thing, I had to use resource monitor and process explorer to even see the running processes.

    I shut down iTunes, but my CPU didn't calm down until I unplugged my iPod Touch.

  • BrandonCali Level 1 (10 points)

    ATH.exe was the issue that was causing the 100% cpu on my computer. I closed AHT.exe but now my iTunes keeps skipping when listening to music. Why does Apple do this? They make a good version of iTunes and they need to change it because of iOS 6 and now it's having issues.

  • petipro Level 1 (0 points)

    Same problem here, since the latest iTunes update (10.7).

    AppleMobileDeviceService.exe and ATH.exe use 25-25% cpu after 1-2 hours after windows start.


    Here is the proof:


    cmd/netsh winsock reset doesnt work!!!


    Please fix Apple!!!

  • Mark J P Level 1 (10 points)

    Interestingly I disabled wireless sync in iTunes for both my iPhone and iPad this morning and the problem has not occurred since (8am-2pm) and iTunes has been open the whole time and playing music for much of it.  I have also synced my iPhone via USB and experienced no problems.



    So from my somewhat limited troubleshooting, it looks like it could be potentially be a problem with wireless sync - appearing in the most recent iTunes update.


    I do like using the wireless sync feature but if this solves the problem for the time being then I'll just have to leave that feature turned off, at least iTunes is usable with it disabled.


    I hope this helps someone else and I hope that Apple are able to resolve this issue sooner rather than later.

  • Phreddo Level 1 (0 points)

    Seeing as how ATH.exe is short of "airtraffichost," this seems logical.

    Unfortunately, since we don't know the cause, it'll be hard to tell if this is a solid fix.

    However, I made those changes last night and so far everything is normal.


    I can live without wifi sync for now.


    Thanks for the tip!

  • Mark J P Level 1 (10 points)

    A quick update.


    My PC has been fine for a couple of days now since disabling wireless sync on my iDevices, so it does seem to have done the trick.


    I'll be sure to provide an update if this changes.

  • zappe Level 1 (0 points)

    I have the same problem, though I don't want to disable the wireless sync

  • Mark J P Level 1 (10 points)

    Yes I feel the same way, but it has solved the problem for me for the time being.

  • 3G working on iOS4 Level 1 (0 points)

    yeah same issue here. itunes bringing windows home server 2011 to its knees at 100 % cpu.  turning off wireless sync seems to be the work around for now.  boo.

  • fbara Level 1 (0 points)

    I just notice this today.  I'm running Win 7 Pro 64-bit, iTunes  CPU hanging around 40% for about 20 min. 


    I leave iTunes running in the system tray so it can do the wireless syncing.  When I look at iTunes, it's not doing anything, not syncing, not downloading content, nothing.  However, ATH.exe stays around 40% cpu.


    I'd like Apple to notice this thread and take a look at it.

  • kaylarosefrr Level 1 (0 points)

    I'm having the same problem...

Previous 1 2 3 Next