9 Replies Latest reply: Feb 3, 2013 11:14 PM by greever
Gibralter52 Level 1 Level 1 (0 points)

Everytime I go to install the software from the website, I'm being prompted that I'm not the Admin and to log in as such.  Well I am the Admin.  Contacted Epson support and they said its the OS. I've restarted and redownloaded the software several times but nothing works. Ideas?


MacBook Pro (13-inch Early 2011), OS X Mountain Lion (10.8)
  • 1. Re: Can't install Epson stylus 230 with Mountain Lion.
    John Blanchard1 Level 5 Level 5 (4,740 points)

    Is your password correct? Caps lock? It won't matter how many times you download the software - you need the admin password to install. Maybe create another user? Change your password? Does your password work at other times?

  • 2. Re: Can't install Epson stylus 230 with Mountain Lion.
    Gibralter52 Level 1 Level 1 (0 points)

    Yes my password is correct.  Though at the time I am not being prompted to log in as Admin my ML, its just the download immediately stating I am not the Admin.  I tried using it as another user and the same exact thing is happening.  And I have since changed my password but nothing has changed at all.

  • 3. Re: Can't install Epson stylus 230 with Mountain Lion.
    Matt Broughton Level 5 Level 5 (4,905 points)

    It might help us replicate your issue if you could be more specific as to the exact model you have and the software you are trying to install (country you are dowloading from, printer driver, ICC profiles, CD print, etc). 

     

    There are numerous Epson models with the "Stylus" and "230" in the model number.

     

    Also, is it a printer listed on the supported printers list Apple provides at http://support.apple.com/kb/HT3669 ?

     

    Everyone is sort of guessing what may be wrong.  If we can download what you have, we may be able to see what problems there may be.

  • 4. Re: Can't install Epson stylus 230 with Mountain Lion.
    Gibralter52 Level 1 Level 1 (0 points)

    Exact model off of the box and website: Epson Stylus nx230 http://www.epson.com/cgi-bin/Store/support/supDetail.jsp?BV_UseBVCookie=yes&oid= 182103&infoType=Overviewhttp://

     

    Downloading from website: In the USA.  Once I'm on the page specific to the site I download the software and drivers for Mountain Lion.  Once the download completes I double tap from the download list to open the Epson software and click to open and that is when I get this error message from the software "You must have Admin user privileges to install the software.Log out and then log in as an Admin user to start the installation".  I have done this a number of times.  I have also created a new admin profile to see if that would work and still no solution.

     

    And yes this printer is supported by Apple

     

    Thank you for your help.  It is much appreciated.

  • 5. Re: Can't install Epson stylus 230 with Mountain Lion.
    Matt Broughton Level 5 Level 5 (4,905 points)

    Thank you for providing the information.  It certainly helps in trying to replicate what you are experiencing.  First, let me say that you really shouldn't have to download software from the Epson site.  The latest drivers would normally be pushed by Apple's Software Update.

     

    If you specifically want the Epson Scan software, then you would have to get that from Epson.   I personally do prefer the Epson Scan software over the standard Image Capture software, but that is only my opinion.

     

    ILn any event, I followed your directions.  I downloaded two files. The main printer drivers was a file epson14341.dmg and the Epson Scan software was epson14339.dmg.  I did get two prompts.  The first was to say I wanted to open the software downloaded from the web.  The second was a standard authentication for the installer.  Screen shots below.

     

    Screen Shot 2012-09-18 at 2.42.21 PM.png

    Screen Shot 2012-09-18 at 2.40.32 PM.png

     

    Are you getting a chance to enter your username and password?  Can you post a screen shot of what is preventing you from installing the software?

  • 6. Re: Can't install Epson stylus 230 with Mountain Lion.
    Gibralter52 Level 1 Level 1 (0 points)

    Once again thank you so much for your help.  I also downloaded epson14341.dmg and I get the same first screen shot of the alert that it was downloaded from the internet but this is the second screen shot I am getting which does differ from yours:

     

    Screen Shot 2012-09-21 at 10.19.20 AM.png

     

     

    Sorry for my poor screen shot.  As you can see I can't get as far as you have.  And also to clarify I am logged in currently as the Admin but I am not prompted at all in the process to verify the installation....I can't even get that far.

  • 7. Re: Can't install Epson stylus 230 with Mountain Lion.
    Matt Broughton Level 5 Level 5 (4,905 points)

    Thank you for the screen shot.  As luck would have it, I had problem installing Epson software on a new installation I was creating.  I didn't get the dialog box that you did, but the installer did hang up midway through the process saying it did not have the permissions to create a folder.  I had to force quit the installer.

     

    I resolved my problem by unmounting the disk image.  I then mounted it again and the installer worked properly.  No logging out or restrarting.  Very strange.  You might try the same thing.

     

    The other suggestion I would have is to create a new user account--either Standard or Administrator and try the instller from there.

  • 8. Re: Can't install Epson stylus 230 with Mountain Lion.
    greever Level 1 Level 1 (0 points)

    I am having the same problem.  Being told that I must be logged into an admin account to load the software.  I was not prompted for the admin user/password as would normally occur.  I tried logging in as the admin user, then as root, all with the same result...  must be logged in as an admin user.

     

    I have just upgraded from 10.6 to 10.8.  This was following a clean install of 10.6.  I had earlier been running 10.5 but my machine dies. I was unable to upgrade correctly from backup.  Another bump in a frustrating process...

     

    I downloaded the software off the Epson site.  When I try to download from the Apple site, the download hangs and the process must be killed.

     

    Just unmounted the image and remounted it, to see if that changed anything.  It doesn't.

  • 9. Re: Can't install Epson stylus 230 with Mountain Lion.
    greever Level 1 Level 1 (0 points)

    I have figured out how to load the Epson software.

     

    Instead of clicking on the Epson image, I selected Show Package Contents.

     

    I went into Contents/MacOS directory.  There was a file EpsonInstaller.  I clicked on that file and the installer executed.  It prompted me for password and went on to install the product.

     

    Something is amiss with how the installer is executed when the icon is clicked.