14 Replies Latest reply: May 2, 2013 12:43 AM by DCYP
mdelvecchio Level 1 Level 1 (0 points)

hello,

 

i have an Apple TV where i subscribe to Season Passes for various shows and watch them on my TV. great. problem: my Macs are also downloading the same exact content, storing them on their harddrives. theyre very large files, and i dont need want to store them locally or use my bandwidth.

 

i do, however, want my Music purchses to auto-download to the Macs.

 

how do i set this? i thought i used to be able to but in the new iTunes i dont see checkboxes for TV...in Preferences > Store > Automatic Downloads i see a checkbox for "Music", which is checked.

 

 

thanks,

matt


Pages, OS X Mountain Lion (10.8.1), iTunes
  • 1. Re: stop itunes from downloading tv shows
    paddythegeek Level 1 Level 1 (0 points)

    Bump.  My problem exactly.  Read an old thread about contacting Apple Support to have the shows removed from the d/l queue, but that seems a bit much.

  • 2. Re: stop itunes from downloading tv shows
    mdelvecchio Level 1 Level 1 (0 points)

    ok here's what i did -- went into Preferences > General and unchecked the "TV Shows" from my itunes library. then i deleted the show files. then i monitored it for a couple days and they didnt seem to come back...

     

    try that and let us know!

  • 3. Re: stop itunes from downloading tv shows
    paddythegeek Level 1 Level 1 (0 points)

    Yep, that did it - good job!

  • 4. Re: stop itunes from downloading tv shows
    janedoemac Level 1 Level 1 (0 points)

    I tried that as well...However, whenever I checked for available downloads, they showed up again. When I view my iTunes store account, it still says I have items waiting for download. So, unless I remove them from the download queue, I think they will jsut keep trying to download. I broke down and emailed Apple iTunes support to remove them from the queue, because I don't think there is any other solution... Also, I think if enough people email them with this problem, maybe they'll actually fix it...

  • 5. Re: stop itunes from downloading tv shows
    MacBob1 Level 1 Level 1 (15 points)

    Something I just tried and it appears to work... even after "checking for available downloads"

     

    1. Go to "TV Shows" in iTunes
    2. Select All TV shows using Cmd-A
    3. Right Click over selections, Mark as Watched (may have to mark as unwatched first, then mark as watched)
    4. Then, Right Click Again over selections, "Uncheck Selections"

     

    So in theory, if marked as watched and the item is unchecked... no more downloads.

     

    [UPDATE]: Nevermind.  Quit iTunes, Restarted.  Downloading Resumed...  ARGGGHHHH!

  • 6. Re: stop itunes from downloading tv shows
    DEWacht Level 1 Level 1 (0 points)

    After trying all of the suggestions in this thread, what I did was let the shows download and then delete them off my Mac right after the download finished. Does not address the use of bandwidth issue but disk space is freed up and the shows are available for download when I want them. This is something Apple needs to fix. Hold over from pre-iCloud days???

  • 7. Re: stop itunes from downloading tv shows
    JEStoner Level 1 Level 1 (0 points)

    I completely agree.  Apple acts like we all have terabytes of storage and fiber to the home.  This issue could be easily fixed by adding an option like - "Stream Only" in place of pause download

  • 8. Re: stop itunes from downloading tv shows
    mdelvecchio Level 1 Level 1 (0 points)

    weird. i kinda have to conclude you may have it set incorrectly since removing the TV Shows checkbox from my library did the trick -- itunes no longer downloads the episodes.

  • 9. Re: stop itunes from downloading tv shows
    MrHk Level 1 Level 1 (0 points)

    Hey all, I had same problem 100+ season pass episodes downloading when I watched them on apple TV (which started to eat up my HD).  In the process of trying to stop this I ended up deleting all of my TV shows off my imac and loosing all of my purchased items on apple TV (as i somehow hid the shows)

     

    As per normal the awnser was on various apple boards and partly my fault.

     

    In short:

     

    1) Make sure that you have "download pre-orders when available" disabled in your iTunes preferences by going to iTunes > Preferences under the Store tab. Then, untick 

     

    If you have this selected in itunes you are telling itunes to download all new shows that you watch.  If you untick it new future shows will not download (you may get a few old shows downloading from old orders but new ones will not download).  Note if you manually select "check for available downloads" it can override this option

     

    2) Hiding Episodes - Do not "hide" TV shows, eg by pressing x, this will remove the shows from your computer and apple TV so you will not be able to watch or download them again.  To find them again you will need to go into your account online under the cloud and unhide

     

    3) To make it easy for you to redownload episodes in itunes 11, make sure that you have "Show iTunes in the Cloud Purchases" enabled in your iTunes preferences by going to iTunes > Preferences under the Store tab. Then, click OK.  You can then redownload the episodes to computer from the main library should you ever need them (otherwise you need to log on to store and then select the purchased items in the Quick Links section per instructions for 10.7 in link below)

     

    Here is a good link on how to re-download tv shows apps etc uising itunes 11 itunes 10 and various other IOS devices

    http://support.apple.com/kb/HT2519

  • 10. Re: stop itunes from downloading tv shows
    R Allen Matsumoto Level 1 Level 1 (15 points)

    It seems like MrHk has found the answer - just some semi-oblique UI work in iTunes that makes the option less than obvious, untill you look at it and read it carefully. Thanks MrHk!

  • 11. Re: stop itunes from downloading tv shows
    SoCalGadgetGuy Level 1 Level 1 (0 points)

    This is a complicated mess and has been around for several iTunes versions. Apple needs to figure out a simple interface for using iCloud across all devices that makes sense and just works. Even the store Genius can't figure this one out. This involves way too many settings, settings on every device, inconsistent nomenclature, and buried interfaces. Something in this mess of settings needs to be "the boss" that simply turns it on/off in one place, or at least automatically rectifies this slop. I'm so fed up with this old problem of eating up bandwidth and storage I will probably never purchase another TV show or movie using AppleTV, only rent. Thank goodness rentals go away forever after 24 hours.

     

    And to the guy who's going to say "Stop buying in the first place. Why are you buying stuff you only watch one time?" you're fogetting there are some items in the iTunes Store that are not available for rent and are purchase only. Those are the movies and shows I am never going to watch using iTunes.

  • 12. Re: stop itunes from downloading tv shows
    dPod Level 1 Level 1 (35 points)

    Disabling "download pre-orders when available" finally did the trick! (That option used to only apply to album pre-orders, which is a big part of the confusion, but I guess the fine print does mention iTunes Pass now.)

     

    I had been searching for a solution for months. Every time I launched iTunes, it would start downloading 20+ episodes of TV shows, even if I had already watched them on my Apple TV.

     

    Last time I checked, the other major thread dedicated to this problem did not include this solution despite all the replies. So thanks!

  • 13. Re: stop itunes from downloading tv shows
    vvgearboy Level 1 Level 1 (0 points)

    This didn't work for me.  That box was already unchecked in my preferences and this one show keeps tormenting me.  I'll try DEwacht's advice and "bite the band width bullet." 

  • 14. Re: stop itunes from downloading tv shows
    DCYP Level 1 Level 1 (0 points)

    DId anyone notice that the automatic downloads has stopped since about 2 to 3 weeks ago?

    I think Apple must have resolved this issue. I manually "check for available downloads" and the

    content is no longer downloading automatically.