Previous 1 2 Next 17 Replies Latest reply: Feb 13, 2014 10:57 AM by Ritayan
Barbara Passman3 Level 2 (180 points)

New Mac, fresh install of Mountain Lion

When I click to open a .Pdf from a web page,while in Safar, I get a black window

Nothing opens in Preview or in Acrobat

No option to download


The same item opens easily in FireFox into Acrobat


My hunch is that some plugins did not migrate when I moved from old MacbookPro to  brand new one

How do I fix?

MacBook Pro with Retina display, OS X Mountain Lion (10.8), Hubby'siMac 20" 2009 ,10.6.6. 2 Gig RAM
  • VikingOSX Level 6 (15,761 points)

    The first thing I would do after a new (update or full) install of Mountain Lion, would be to run Disk Utility and let it verify/fix permissions and verify the drive. Then check if the in-browser PDF viewing functionality has returned to Safari.


    The second check would be to look in your home directory in the Library/Internet Plug-Ins folder, and ensure it is empty.


    The third check would be that you are using the latest version of Adobe Acrobat Reader (10.4.1) to have the most current Adobe PDF Viewer plug-ins installed. Older plug-ins may clash with the Quartz PDF plug-in that Safari uses by default; resulting in neither plug-in working in Safari. This may explain why Firefox worked fine.


    I have both plug-ins installed and the Adobe PDF plug-in over-rides the default OS X PDF viewer in Safari 6. I find that the Acrobat plug-in offers more in-browser functionality for Safari.


    Any improvement?

  • Barbara Passman3 Level 2 (180 points)

    Permissions were fixed after all migrated and while making backup

    Main Library Internet plug ins folder has Adobe PDFViewer

    Does NOT have the Quartz PDF plug in

    Where do I get it?


    My user (~/Library) Internet Plug ins folder has other needed plug ins  (Citrix, Evernote, Google) Also has something called PDF Browser Plug in but it is old- from 2004.

    I removed it

    This Library has neither Acrobat nor Quartz PDF plug ins


    Yes, I have the latest Acrobat x Pro and Reader. 10.4.1


    Any thoughts?

  • Barbara Passman3 Level 2 (180 points)



    Another post elsewhere on this Apple discussion area reminded me

    Plug in...

    in addition to the Adobe PDFViewer , there is another Adobe plug in, previously found to be a troublemaker

    The  "AdobePDFViewerNPAPI.plugin"

    Identified as causing Safari problems several versions ago of Safari

    THAT has to be removed and then Acrobat plug in works in Safari!



    Thanks all for helping my brain think

  • VikingOSX Level 6 (15,761 points)

    You can get the following file (actually a special directory) from another Mac running Mountain Lion:


    1. /Library/Internet Plug-Ins/Quartz Composer.webplugin


    Run Disk Utility again to let Mountain Lion fix the permissions on this file, once you have added it back.


    In the same location, I have both AdobePDFViewer.plugin and AdobePDFViewerNPAPI.plugin. Both have a date stamp of Jul 27 (2012). I have no PDF viewing issues in Safari 6 or Firefox. I believe that Acrobat Reader updates now keep these current. I too am using Acrobat 10.1.4.


    I believe once you recover the above Quartz PDF plugin, Safari will settle down and display PDF.

  • Barbara Passman3 Level 2 (180 points)

    I found I do have the quartz composer web plugin in  /Library/Internet Plug-Ins/Quartz Composer.webplugin

    So that was not the problem) ( My date stamp is June 20, 2012


    Removing the NPAPI  Adobe plugin lets Safari open .pdf files.

    That has been documented previously... Maybe I have other things on my Mac which conflict with this plugin- things you do not have.


    FireFox has not had a problem with .pdf

  • oldmacgeek Level 1 (0 points)

    I had the same problem and finally (!!!) solved it: Besides the NPAPI plugin there is another plugin called AdobePDFViewer.plugin

    I removed (to desktoop)  both plugins and I was able to view PDFs from Safari. Then I added back the AdobePDFViewer.plugin and black screen showed up again. Removed it and added the NPAPI plugin and everything worked as it should.  So it is the old AdobePDFViewer.plugin that seems to be the problem.

    BTW, it was always possible to download the PDF that you could not view. Just right click (or cntl click) on the black screen and the download (save) the pdf.

  • Lewdvig Level 1 (20 points)

    Removing those plugins did not cure the issue for me.


    I realize that this is likely an Adobe issue, but darn if I don't get one of these windows like annoyances almost everyday now.


    Since Snow Leopard, each rev of OS X has introduced more clutter and bugs.

  • thobaum Level 1 (0 points)

    I have OS 18.8.2 and run Acrobat 8.1.3, and had previously also installed the latest version of Acrobat. But then I had problems with Firefox openeing pdfs. I trashed Acrobat 10.4.1 or whatever it was.


    Maybe as a result of all these actions, Safari became sick and could not open the pdfs. Now I moved the plugins around as suggested by oldmacgeek, and finally found, that the AdobePDFViewerNPAPI.plugin was the problem. I may conclude that the Acrobat version used requires just one of the plugins, and that the presence of two different plugins in the related folder paralyzes the Lion .


    Indeed (in response to Lewdvig), there are many things Apple should work on and actively come up to the users, e.g. the problem 'imovie & built-in camera'. So let us hope and pray!

  • jdien Level 1 (5 points)

    Removing AdobePDFViewerNPAPI.plugin f fixed my problem too!

  • Ritayan Level 1 (0 points)

    Remove from the folder /Library/Internet Plug-Ins:

    1) AdobePDFViewer.plugin

    2) AdobePDFViewerNPAPI.plugin


    It will work then! It happend with me too, and now working perfect

  • Stefan Vasiljevic Level 1 (0 points)

    This solved my problem too!!!

  • Aaran Level 1 (0 points)

    Had the same problem and searched online


    Found this solution almost immediately


    Thanks guys!

  • coreworksnet Level 1 (15 points)

    Solved my problems too -- I had switched over to Firefox & Chrome b'c I thought the issue was with the recent Mavericks time-frame update of Safari. Thanks for posting.

  • Bucharest021 Level 1 (0 points)

    I recently removed Adobe Reader from my Macbook Pro (mid 2012, running Mavericks) and it would also show me a black page in Safari (latest version) when clicking on a PDF link within a website.


    The suggestion to remove 1) AdobePDFViewer.plugin and 2) AdobePDFViewerNPAPI.plugin instantly solved the issue!


    Thank you

Previous 1 2 Next