12 Replies Latest reply: Feb 27, 2016 2:13 PM by EasyDoesIt
Scott Carmichael Level 2 Level 2

So I use my ipad at work in a room without wi-fi?  My mac pro has internet via eathernet.  Can I use bluetooth to share the internet from my mac pro to my iPad 3 via bluetooth?  If so, what is the proper wat to set up the sharing prefpane to get this working correct?  I'm not having much luck.  Also is there any changes I need to make to the ipad ofther than doing the pairing?  My mac pro os running 10.8.1

 

Any help is appreacited,

 

Thanks,

Scott

Solved by Scott Carmichael on Sep 19, 2012 9:45 AM Solved
So I did get it to work and here is how: Pair your ipad via bluetooth to your mac.  Then on your ipad turn off WI-FI.  Then on your mac, under sharing, select Internet Sharing.  Then for the "Share  your connection from" option, select ethernet.  For the "To computers using:" opyion , select Bluetooth PAN.  Then turn on internet shaying in the left column.  WA LA, it works.  Kinda slow, but makes but a lot better than nothing!
  • Philly_Phan Level 6 Level 6
    expertise.iphone
    iPhone

    No.

  • Scott Carmichael Level 2 Level 2

    So I did get it to work and here is how:

     

    Pair your ipad via bluetooth to your mac.  Then on your ipad turn off WI-FI.  Then on your mac, under sharing, select Internet Sharing.  Then for the "Share  your connection from" option, select ethernet.  For the "To computers using:" opyion , select Bluetooth PAN.  Then turn on internet shaying in the left column.  WA LA, it works.  Kinda slow, but makes but a lot better than nothing!

  • Granite Apple Level 1 Level 1

    FYI I found that if I had multiple users logged into my Mac I couldn't get my iPad to connect to my Mac over bluetooth. Once I logged out the other users, it connected right away.

  • leroyfrog Level 1 Level 1

    Has anyone had luck doing this with an ipod touch or iphone?

  • Granite Apple Level 1 Level 1

    I was able to get my iPad to pair with my MBP and show that it was connected, but was never able to load a web page (kept timing out).

  • jamaicaplain2002 Level 1 Level 1

    Right, so this doesn't work.  Since Mac is basically unix, it is certainly possible to do this, but Apple does not want to support it natively anymore, I'm guessing, for business reasons.  Oh Apple, how we sort of like thee.

  • viksclicks Level 1 Level 1

    It works. You need to make it work, by assigning blutooth PAN a manually assigned ip address.

    192.168.2.1 subnet 255.255.255.0 and in router address field 192.168.2.1, provide DNS as 8.8.8.8 and second dns 8.8.4.4. Of course enable the internet sharing beforehand.

    Unpair and pair your ipad again.

    I have not tried this with iPad but worked with a Nexus device.

  • jamaicaplain2002 Level 1 Level 1

    Awesome!  This does indeed work.  I'm so happy I'm going to sum it up for people:

     

    First do the above answer:

     

    'Pair your ipad via bluetooth to your mac.  Then on your ipad turn off WI-FI.  Then on your mac, under sharing, select Internet Sharing.  Then for the "Share  your connection from" option, select ethernet.  For the "To computers using:" opyion , select Bluetooth PAN.  Then turn on internet shaying in the left column.'

     

    Next go to Network preferences to do viksclicks answer.  Click on Bluetooth Pan. Ignore everything except the "Advanced" button at the bottom.

     

    IPv4 address: 192.168.2.1 subnet 255.255.255.0 and in router address field 192.168.2.1, provide DNS as 8.8.8.8 and second dns 8.8.4.4.

    Unpair and pair your ipad again.

     

    Also, BTW can choose "Share your connection from" WiFi instead of from Ethernet("land-line") in the first step if your mac connects via wifi. Wish I had had this a couple of weeks ago when I needed it


  • Philly_Phan Level 6 Level 6
    expertise.iphone
    iPhone

    Scott Carmichael wrote:

     

    So I did get it to work and here is how:

     

    Pair your ipad via bluetooth to your mac.  Then on your ipad turn off WI-FI.  Then on your mac, under sharing, select Internet Sharing.  Then for the "Share  your connection from" option, select ethernet.  For the "To computers using:" opyion , select Bluetooth PAN.  Then turn on internet shaying in the left column.  WA LA, it works.  Kinda slow, but makes but a lot better than nothing!

    Wow.  Obviously I didn't think that it was possible.

  • jamaicaplain2002 Level 1 Level 1

    Note: just learned that this doesn't work on iPhones. (obviously bc making people use up their cellular data plans is big business)

  • Basil B Level 1 Level 1
    Pair your ipad via bluetooth to your mac.  Then on your ipad turn off WI-FI.  Then on your mac, under sharing, select Internet Sharing.  Then for the "Share  your connection from" option, select ethernet.  For the "To computers using:" opyion , select Bluetooth PAN.  Then turn on internet shaying in the left column.  WA LA, it works.  Kinda slow, but makes but a lot better than nothing!

    Just tried this with Yosemite 10.10.1 on MacBook Air and iOS 8 on iPad 3 works just fine, thanks guys

  • EasyDoesIt Level 1 Level 1

    I was very hesitant to try this (but sure want to!) : as I turn on ethernet sharing I get this from Mac: " if your computer is connected to a network, turing on ethernet sharing may affect the network settings of other computers and disrupt the network. Contact your sys admin before turning on internet sharing." 

    I live in a house with 1-2 other macs, and its a weekend...Dont want to mess with others computers...

     

    Then, the instructions to configure Bluetooth PAN were not specific enough: "IPv4 address: 192.168.2.1 subnet 255.255.255.0 and in router address field 192.168.2.1, provide DNS as 8.8.8.8 and second dns 8.8.4.4...


    Questions: Should l I be entering this into config manually? DNS wants 8 digits, not 2 with 4 each...


    Wow, this would sure be a great thing to get working - we're not allowed wifi here...the enet to usb adapter-to powered hub to camera to ightening links did not work.


    ipad 4, ios 9,2,1, MBP el cap latest.