1 2 3 4 Previous Next 45 Replies Latest reply: Jun 10, 2014 11:12 AM by Frank Malloy
eggcouncil Level 1 Level 1 (0 points)

Ever since I upgraded to Mountain Lion, I often receive "message has no content" for replies to the active email, meaning the one which has been clicked on, and is being displayed.  I have to close Mail and re-open before I am able to view the content of the message, though the "no content" error still appears in the email list.  Eventually it goes away.

 

Running 10.8.1, and receiving mail from Exchange 2010.  I do not observe this issue with email received by my Gmail account.


Mac Pro, OS X Mountain Lion
  • 1. Re: "this message has no content" in Mountain Lion
    RYU_CGY Level 1 Level 1 (0 points)

    I currently have this issue, rebuilding and cleaning the mail boxes does nothing... I did not tice once I passed 3000 messages the mail application starts getting funky.

     

    Here are my symptoms:

     

    • First the email app stops marking read messages.
    • App starts slowing down.
    • Calendar starts giving me it can not communicate with the server
    • Then it starts showing me no content email messages

     

    So here is my opinion but I need help to confirm... Gathered from this very common problem...

     

    • Mac OS does not handle weak or slow internet connections well and does not recover well (Noticed at this at the airport today, also notice this on the iphone, bad wifi really kills any sort of functionality).  This might cause the requests to end unexpectedly and return nothing...
    • There seems to be a size limitation the mail application can handle properly or there is a memory leak in the mail application.   From what I read it uses a free DB product that likely doesn't handle large amounts of data very well.

     

    Likely going to switch to Outlook 2011 unless Apple fixes these problems (Apple likely will not fix this as seen in all the dead end blogs for this subject), or not use the mac for work as this makes things more painful than it needs to be.

  • 2. Re: "this message has no content" in Mountain Lion
    eggcouncil Level 1 Level 1 (0 points)

    I've emptied my inboxes, to no avail.  My connection is FiOS 35/35, so conection latenancy and unreliabilty isn't the issue for me at least.  I have upgraded to 10.8.2, but the issue remains.  Very annoying to have to restart mail to be able to read a reply to the currently selected message!

     

    In addition, and this issue has been plaguing me since Mountain Lion, the "reply" button on occasion, does nothing until I deselect the message I want to reply to, and reselect it.

     

    Not really happy with Mail these days..beats Outlook, but has some very annoying quirks..

  • 3. Re: "this message has no content" in Mountain Lion
    Soesoesoe Level 1 Level 1 (0 points)

    Same problem here. :s Hope Apple can fix this VERY soon.. What time did you wait for the content to eventually load? It took me over 2 hours or so..

  • 4. Re: "this message has no content" in Mountain Lion
    eggcouncil Level 1 Level 1 (0 points)

    Restarting Mail brought up the content...I never waited it out...

  • 5. Re: "this message has no content" in Mountain Lion
    RYU_CGY Level 1 Level 1 (0 points)

    Update:  Could not find a solution to Mail, had to switched to Outlook, restarting mail and calendar app every few minutes was not reasonable.

     

    Few other notes... noticed that the the calendar works better in Outlook for importing calendar items ( ex. Hockey schedules... Mac Calendar does not handle timezones correctly and shifts times 2 hours)...

     

    If you decide to go to office way the only thing you need to worry about is Office installing duplicate or incompatible fonts which seem to crash outlook or cause performance issues.  There is a way to delete duplicate fonts and have Mac download the appropriate fonts which corrects most of these problems.

     

    Hope Mail and Calendar gets the fixes it needs.

  • 6. Re: "this message has no content" in Mountain Lion
    eggcouncil Level 1 Level 1 (0 points)

    Update to 10.8.2 has not fixed this issue.  ARGHHHH

  • 7. Re: "this message has no content" in Mountain Lion
    jardilio Level 1 Level 1 (0 points)

    I believe 10.8.2 has actually made this issue worse. Previously I could delete the affected message, then wait a second or 2 and do an undo. Then the message would display. Now, when I delete, the message remains in view and doesn't go away. The menu bar does show that I have an option to "Undo Delete Message" as if it tried to, but nothing happened.

  • 8. Re: "this message has no content" in Mountain Lion
    rstegner Level 1 Level 1 (0 points)

    I agree,  I updated to 10.8.2 and now the problem is much worse,  I have tried to do a repair but all that did is corrupt it to the point I delete the account from mail and reinstall it.   I do have several thousand messages I am going to work on deleting.   In the meantime is looks like Outlook will be the solution.

  • 9. Re: "this message has no content" in Mountain Lion
    Ben Warren Level 1 Level 1 (0 points)

    I also have this problem, Mail v6.2(1499) on Mountain Lion 10.8.2.  I'm on corporate LAN, so link speed has nothing to do with it.

     

    The content is definitely there, as you can see it in View->Message->Raw Source.  If I restart Mail, the message contents show up in the main pane, although "This message has no content" is in the preview window.

     

    It looks like the Mail app just doesn't parse certain reply messages properly.

  • 10. Re: "this message has no content" in Mountain Lion
    Orilus Level 1 Level 1 (0 points)

    The only solution that I've found to work (not really a solution), is to delete the problematic email and then undelete. It usually loads the email correctly at that point. You have to give it a second or two when you delete. *****, but it's the only thing that works now. C'mon Apple! Fix Please!

  • 11. Re: "this message has no content" in Mountain Lion
    kstearnes Level 1 Level 1 (0 points)

    Glad I'm not the only person with this problem.  Sure wish Apple would fix it soon though because I am trying to rid my computer of all things Microsoft and really don't want to have to use Outlook again.  And yes, it did seem to get worse with the last update to Mountain Lion.

     

    PLEASE GOD APPLE FIX IT!  And oh yeah, releasing the new Mac Pro in the next month or two would be awesome too.  Hope I'm not asking to much there...lol.

     

    Message was edited by: kstearnes

  • 12. Re: "this message has no content" in Mountain Lion
    GSARider Level 1 Level 1 (0 points)

    still an ongoing issue for me, have to keep going to my iphone or ipad to see the content of certain emails. Not good.

  • 13. Re: "this message has no content" in Mountain Lion
    Raman_Pfaff Level 1 Level 1 (0 points)

    Exactly the same for me. Email from exchange server likes to appear empty. Had to go back to Outlook.

  • 14. Re: "this message has no content" in Mountain Lion
    Warby1 Level 1 Level 1 (0 points)

    I am having exactly the same issue. Very fustrating!

1 2 3 4 Previous Next