Previous 1 2 3 Next 160 Replies Latest reply: Apr 1, 2013 5:49 AM by escottr
yerodtr Level 1 Level 1

I moved to iOS 6 and when my phone came up it could not connect to my home network. I did the following on the phone:


- Updated phone to iOS 6 from 5.1.1

- I thought maybe the network settings were messed up so I "forgot" the network and tried again, no luck.

- Reset all network settings, no luck.

- Full restore of iOS 6 and setup as a new phone (no data/apps/etc restored), no luck.

- Removed all encryption on my access point, no luck.


So I then setup a spare access point I had and the iPhone connected right away (even with the same SSID and encryption as my normal home access point). This indicates an incompatibility between iOS 6 and my access point.


It is not an encryption issue, because it can connect to an open, WEP, and WPA2 configuration on my spare access point without a problem. It can even connect to my Mini that is performing Internet Sharing.


The  access point is a Netgear WG102 and before iOS 6  my iPhone 4S worked great on it. I also have an old 2gen iPod Touch, 1st gen iPad, Macbook Air, Mac Mini, etc, etc, etc on the access point with no issues. It's just my iPhone and iOS 6 that can't connect to it.


I did the following to the access point:


- running latest/greatest firmware

- changed RTS threshold, Frag length, Beacon Interval, DTIM interval, etc,  with no luck.

- enabled WMM with no luck (which I saw fixed someone elses issue with a beta version of iOS 6 and their iPad)

- hard/factory reset of the access point (phone can't connect to the default and wide open "Netgear" SSID when it comes up)


The phone works on all other access points that I have tried outside my house.


Any thoughts?

iPhone 4S, iOS 6
Previous 1 2 3 Next