Previous 1 5 6 7 8 9 Next 160 Replies Latest reply: Apr 1, 2013 5:49 AM by escottr Go to original post
  • DERISCO Level 1 Level 1 (0 points)

    Contrary to popular believe, it's not a problem with the access point its a problem with the iOS6 it does not see 802.11n you can conect to 802.11b,g networks after Reset Network Settings or Forget this network. You can buy a new AP but you'd be wasting your money even Apples AP or time capsule has the same problem with the iPhone 4S. if your AP has only 802.11n enabled and you can't enable bor g that would be the only reason you'd have to buy a new AP. I don't know if Apple's trying to pull fast one and say the iPhone 5 is faster the 4s because it connects to 80211n and the iPhone 4S does not.

    People are confused with this.

    The first issue is the iPhone 4S after upgrading will not connect to wireless or Wi-Fi networks. Until you Reset Network Settings or Forget this network.

    The second issue is that the iPhone 4S does not see the 5 GHz 802.11n  networks and there is no fix for that, except as some have suggested downgrading wireless access points which really doesn't sound like a reasonable suggestion since the iPhone is mobile and connects to many different access points.

  • Focal Level 1 Level 1 (5 points)



    I think there is a broad issue with many iphones and iOS6, however most of the people in this thread are having a specific issue that relates only to a few of these models of router, one of which doesn't have 802.11n capabilities.


    I realize that if you haven't read all of the replies this might not be apparent, but most of the people in this thread have a more specific issue related to their routers (it may still be Apple's fault for writing code that is not compatible for some reason, but either way a firmware downgrade works in these specific cases).

  • Slammis Level 1 Level 1 (0 points)



    Iam sorry but there is no way to get My whifes 4s whith ios6 working on My ap, however it works just fine with everything Else ive tried!!


    Yes, the fault might still be Apples...


    But it can also be à combination of things..

  • A.Q Level 1 Level 1 (0 points)

    Hey, try going to Settings > General > Reset > Reset Network Settings once you have done this you will have to re-enter your router password so make sure you have it handy.

    Ahmed Quider


  • BobbyDanJr Level 1 Level 1 (0 points)

    I am having the same issue. Three calls to Apple. Plenty of info and suggestions, but no fix. My ticket has been sent to the engineers. I;ve tried restoring iphone. Opening up router. Reseting settings etc. Called Frontier (router) and no help there. They said must be Apple problem. Can you connect at a public wi-fi?

  • Slammis Level 1 Level 1 (0 points)

    It Does not help on the 4s with wg102 ap

  • Slammis Level 1 Level 1 (0 points)

    The 4s can connect to My iPhone 4 wifi sharing and To the neighburs ap:s but not the netgear wg102

  • Christian Rank Level 1 Level 1 (5 points)

    According to my findings, iOS 6 on iPhone 4S sends an "extended capabilities" packet to the AP during the association phase, and some (many?) APs do not like this and reject the association -> no Wi-Fi connectivity.


    This is a big issue on our campus network with HP Wi-Fi components:

  • MJS_73 Level 1 Level 1 (0 points)

    I few others have touched on firmware issues with the WG102 - I have just downgraded from 5.0.3 to 5.0.1 and my 4s will join the network. Success!

  • Walleth Level 1 Level 1 (0 points)

    Hi all,


    Just to echo the original poster I have experieced severe issues with my home network after upgrading my iphone 3GS to IOS 6.

    After spending a large amount of time isolating the issue I am confident my network problems are purely down to the ISO 6 update.


    I have an ADDON Magic r9500 Wireless Router. There is no alternative firmware from Addon, so I can't solve the problem as Netgear routers owners have done by downgrading their firmware.


    I have two wired connection to the router and various wireless devices also accessing the router. Everything operates fine and can connect to the internet all devices until I try to connect to the network with my iphone 3gs IOS6 over wifi.


    Very soon after I connect to the router with my iphone the router appears to lock out / crash. It is still broadcasting the network name but ALL my wired and wireless devices lose network connection and therefore the internet permanently. I can still see the network on my iphone but I am unable to join it again.


    The only temporary fix is to turn off wifi on my iphone and reset the router. Then my computers and laptops can connect to the internet fine once again.


    Like the original poster I have tried all of the suggested fixes, including:


    -changing http proxy to auto

    -unsyncing icloud safari

    -resetting all network settings

    -changing router to g or b only

    -reinstalling ios 6


    Whatever my iphone is now transmitting to my router it is causing it to lock up and crash taking down the network for all devices. At the moment I cannot use my iphone on wifi and worry about celluar data charges!


    I do want to downgrade to IOS 5.1.1 but I don't have a recent backup. I though the iphone would automatically backup before upgrading. However that most recent backup seems to have been overwritten with an IOS 6 one. So partly my mistake there for being too trusting of a software 'update'!







  • Christian Rank Level 1 Level 1 (5 points)

    Downgrading router firmware my be an option for the private use case, but not for the enterprise.

    I hope that Apple will release a fix for iOS 6 soon.

  • stevenestrada Level 1 Level 1 (0 points)

    >> *Sep 21 08:40:46:336 2012 ac1 WMAC/7/ERROR : Invalid Extended Capabilities IE length (4). <<


    Could be a test to profile wireless lans and their reactions - like the poor guy whose ios6 crashed his entire home network, and the campus' hp gear.

  • Slammis Level 1 Level 1 (0 points)

    I can confirm, on netgear wg102 a firmware downgrade to 5.0.1 fixes the problem so that iPhone 4s can connect!

  • BobbyDanJr Level 1 Level 1 (0 points)

    Are people still having the connection problem to home wifi after installing ios 6.0? I am still not able to connect.   

  • grm10375 Level 1 Level 1 (0 points)

    I have a Netgear Router also.  I can connect but the connection will only last while I'm actively using the phone, Facebook, browsing the web...etc.  Once I'm done and the phone is sitting, the connection is lost and I have to reconnect.  My router is NETGEAR RangeMax NEXT Wireless Router WNR834B.


    I have had issues with the phone previous to this update but nothing this major.

Previous 1 5 6 7 8 9 Next