Previous 1 3 4 5 6 7 Next 103 Replies Latest reply: Jun 25, 2013 7:58 AM by tuerqin Go to original post Branched to a new discussion.
  • Sanbur Level 1 Level 1

    Even I have the same problem on 'the new iPad'. Was surprised to read so many upgrades gone bad, and Apple continues to ship that same upgrade software. Apple - please pull off that upgrade software back. Put in a new one that at least warns the user to back up their files first.


    I upgraded to iOS 6 directly on WIFI. Had not backed up or connected my iPad to a laptop for a long time (this is my stupidity). All my photos and videos, more than a years personal data files, are not accessible now.

    I am unable to understand that if Apple had to upgrade the OS, why should it touch the users data files? If Apple is changing the file system itself, between iOS 5 and iOS6, then it should definitely prompt users to 'backup the files' first. Apple can see these issues on this community for more than a year. If the update fails, and if the new OS does not go through correctly, thats ok. But there needs to be a way to get to the old OS - directly or via iTunes. Is it necessary to have to "erase media files" during restore? I dont know why this step of 'erasing' media files is coming in the way of updating the operating system of a device.


    User interaction needs to improve. There is no use for a user to see that 'All media files will be erased' during "restore phase". A user cannot do anything about it that time. Please move that warning BEFORE the update starts. 


    Currently, my iTunes is connecting to the iPad correctly. It is saying that iOS is up to date. But would have to restore iPad (even when iOS is up to date). Do not know what exactly it is restoring. Apple software engineer said that there is NO SOFTWARE that can connect to the iPad and scan the disk within Apple. I truely doubt that Apple cannot provide a tool to help their users to recover the files. I researched on this for my entire Christmas day, instead of using iPad to "create new memories". Sorry for the frustration on this, but I do want Apple engineers to note it.


    Drfone recovery software does not work yet with 'the new iPad'. I am hoping that Apple or somebody will provide a tool soon. If anybody knows of a recovery tool on 'the new iPad', please let me know. And please backup your media before any Apple update.

  • JLauren26 Level 1 Level 1

    Were you ever able to restore your photos or data? I did the upload without backing up as well, but have not yet connected my phone to my iTunes.

  • cathywht Level 1 Level 1
  • Sanbur Level 1 Level 1

    @JLauren26 - no, I have not been able to restore my photos.

    @Cathywht - Thanks for the post. I had not read this post.

    Solution 1 in the post says 'keep recovering several times'. Did not understand what exactly was meant there. If I recover it once, iTunes gives me a warning that all my media will be erased. Should I proceed irrespective of that warning? It further said - "You can recover data (mostly photos) from the latest iTunes backup or Firmware or iCloud backup.".

    I do not have a iTunes backup or iCloud backup. Whats the meaning of 'firmware' in the above statement?


    I will try Tiny Umbrella 6 from Solution 2 and repost here. Thanks for this link. I have kept my iPad as is, hoping that somebody will create a tool where I can copy my media from a direct disk read from iPad. This kind of solution is available from iPad 1 and iPad 2, but not for iPad 3.


    Thanks again.

  • paul-taegel Level 1 Level 1

    Thank you.  That was very helpful.

  • Camk89 Level 1 Level 1

    I have gone crazy trying to solve this problem trying everything tried above. If you have tried all the steps of restoring it, using apps like Tiny Umbrella and Redsn0w and things still are not working. This is an easy way that may fix your problem.



    1. Click on Finder so it is chosen in the top left corner. Click Go and choose Go to Folder.



    2. Type /etc/hosts anad press Go.



    3. Move the file hosts to the desktop then right click the file and press open with Text Edit. (Enter your password if asked through any step in this entire process)



    4. At the bottom of the page you will see these two lines







    On your last line you will see that it does not have a # sign in front of



    Add the # sign and change the file and save it. It will ask if you want the remove the extension and choose yes.



    5. Move the hosts file back into the etc folder from which you moved it to the desktop to replace the file. If asked press Authenticate.



    Now go and restore your phone!!!

  • mf0011 Level 1 Level 1

    Does not owrk, at least for me.


    Just got my 3gs out of recovery yesterday it showed a "Device not found error" while recovering.

    Used Tiny umbrella for Exit recovery (not FIX as the program suggests).

    Kicked out of recovery and IOS6 started, Itunes showed error installing, phone showed IOS6 succesfully installed and went to setup?!?

    Then wanted to restore data and then was a error on Itunes, again.

    Then deleted the restore backup as option on itunes since the phone was working fine, then synced and guess what, all data were preserved, despite deleting the restore file and strangely restore file is still there ?!?


    But anyhow everything works, unfotunately not thanks to Apple.

  • adamcegan Level 1 Level 1

    EikeWeinberg's instructions worked for me! Thank you!


    Like many of you, when I connected my iPhone 4S to iTunes this morning it invited me to upgrade to iOS 6. Of course I initiated the upgrade without much thought. Then at the end of the upgrade, my phone crashed showing the same "Error -1" message and became stuck in recovery mode (USB -> iTunes on screen). I was devestated because my 16GB hard-drive was full of videos and pictures. My last iCould back-up was in June because it caps at 5GB. Of course iTunes performed a back-up before the upgrade but iTunes back-ups are effectively worthless to me--they don't include photos or videos; just apps, contacts, etc.


    I spent an hour on the phone with an AppleCare rep (he was very nice and wanted to help) who informed me that performing the "Restore" function in iTunes is the only way to get the phone out of recovery mode and that the meaningless back-ups I had would be all the data I can recover. Determined to recover the 10+GB of photos and videos I told him thanks and that I was going to search for a third-party software that could recover my data for me before restoring my iPhone. That's when I found EikeWeinberg's step-by-step instructions on TinyUmbrella which got my phone out of "Recovery Mode" and back to it's previous state. Now I am backing up my photos and videos before I try upgrading to iOS 6 again, which probably will include the "restore" function in iTunes.


    (I had actually read about TinyUmbrella and redsn0w before I came to this thread, but was hesitant to use either because they seem to have been created for "jailbreaking," which I didn't want to do (primarily because I have AppleCare and I didn't want to jeopardize the warranty). But after reading EikeWeinberg I tried it out and it worked great.)

  • melisslissliss Level 1 Level 1

    Thank you for your response. I'm in the Nothing Is Working boat.


    I looked at my /etc/hosts file in Text Edit like you said, and it looked like this:


    # Host Database


    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##          localhost          broadcasthost

    ::1             localhost

    fe80::1%lo0          localhost


    The doesn't have the and isn't on the last line.  Thoughts?


    Thank you in advance!

  • glenysfromtoorak Level 1 Level 1

    I see I'm not the only one having problems. I updated my iPad to ios6.1 and had no problems. When I tried my iPhone 4S I also got the connect to iTunes message. The trouble with that is I don't have access to iTunes and now I can't use my phone !! Any suggestions? Surely the iPad and phone updates should work the same way....

    P.S I'm not very computer literate which is why I just have the iPad!! HELP

  • King7Dom Level 1 Level 1

    thanks very much, restoring finally!, downloaded like 10gb of data because of that recovery loop


    EDIT: Actually, it is asking me to restore again =,=

  • STUPENDOUS!!! Level 1 Level 1

    Yeah that YouTube "edit the hosts file" thing worked for me.

    Nice work there Mr Hussain

  • STUPENDOUS!!! Level 1 Level 1

    Correction, not necessarily at the bottom of the Hosts file text.

    Mine was halfway up as I had a bunch of Adobe activation stuff at the bottom.


  • jkchohan Level 1 Level 1

    TinyUmbrella thing worked for me

  • iamstardust Level 1 Level 1

    Hey man i've been in the same boat as you for 6 hours and finally found what worked for me! Try this site:


Previous 1 3 4 5 6 7 Next