13 Replies Latest reply: Jan 7, 2013 1:49 AM by rwillett
jacksmommy719 Level 1 Level 1

Wifi option is grayed out and set to off...unable to turn to "on" after iOs6 update


iPhone 4S, iOS 5.1.1
  • mattlynham Level 1 Level 1

    Same problem here. 4s update to ios6 and now wifi switch greyed out!

  • rlaubhan Level 1 Level 1

    Seems to be a fairly common problem. See other posts on this board.

  • AusMossy Level 1 Level 1

    I just upgraded 4S to iOS6 and WiFi isn't greyed out, but every time I try to connect to WiFi it displays a login page on apple.com which gives a page not found error. The networks I'm trying to connect to are my own, definitely never had a login page to access them before.

  • samuelgarcia87 Level 1 Level 1

    I am also getting the same issue as AusMossy, I just upgraded my 3GS and when I select my Wifi, it disconnects and takes me to an unexistend page "Log In" page at apple.com

     

    Please fix this as it is terribly annoying.

     

    wifi.PNG

  • dave21r21 Level 1 Level 1

    I just updated my 4s and had the same problem. I did a reboot of the phone and now the wi-fi is working fine.

  • AusMossy Level 1 Level 1

    I just got off the phone from Apple Support. Had to go into settings and General. Go down to Reset and choose that, then choose Reset Network Settings. The phone will reboot and then when you go to connect to WiFi you will need to re-enter password. All was fine for me after that.

     

    Apple phone support was excellent, once you're able to get onto them.

  • AusMossy Level 1 Level 1

    I'd tried rebooting phone before calling support but that didn't help.

  • pcolsen Level 1 Level 1

    did you ever figure out what the problem was? how did you solve it?

  • jacksmommy719 Level 1 Level 1

    Still have not been able to figure out the issue. Apple engineering working on the issue but no update yet. Still have a greyed out wifi and battery is draining faster then bath water in a tub!! Might have to exchange the phone completely! I've restored the phone to its original settings and nothing is helping these issues.

  • Viperv10srt Level 1 Level 1

    Same here.called support restore phone to factory, plus all the other simple things, still no wifi.. 10 to 15 min to take wifi out, got hours into trying to get it back !!!! Wait to see if apple figures out a fix, or go through the process of getting a new phone... Major inconvenience !!!!!!!

  • pcolsen Level 1 Level 1

    Just talked with apple tec support. It seems that its something worng before the update, and the update just made it real. I have to ship my phone off to them and have them repair it. It seems that they will not be able to fix it with out getting the phone...

  • chris_teixeira Level 1 Level 1

    had the same problem, have you tried letting the battery die? i let my battery die and when i charged it, it worked after that, its only been one day though so not sure if its completely fixed, hope this helps

  • rwillett Level 1 Level 1

    I used the battery draining method to get the wifi working again, and it worked the two days ago.

     

    However yesterday evening the iPhone stopped finding networks though I could select wifi, after powercycling the phone, I then got the grey wfi button so couldn't select it. I drained the battery again in exactly the same way as before and powered on again, but this time it didn't work.

     

    This is a pain as I use wifi all the time, plan B is a factory reset, Plan C is a Samsung Galaxy 3.