Skip navigation

how to merge phone number with imessage on 10.8.2

174797 Views 71 Replies Latest reply: Jan 3, 2014 12:01 PM by Ralph Johns (UK) RSS
  • _SIKES_ Level 1 Level 1 (0 points)

    So Apple releases some ****** iOS6 with horrible maps, then forces me to use it if I want iMessage to work properly?

     

    After hours of downgrading to get my iPhone back to iOS5 updating is the last thing I want to do.

     

    3 words, **** you apple.

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Dec 11, 2012 12:45 PM (in response to David Cher)

    Hi,

     

    On my iPhone's the number is not listed with a Country code and is laid out  like this xxxxxxxxxxxxx

     

    However by the time shows up on the Messages up on the Mac it has the country code added and is  in the Country code xxx - xxx - xxxx  format.

     

     

     

     

    Sigcopy2.png
    8:45 PM      Tuesday; December 11, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • David Cher Level 1 Level 1 (0 points)

    the issue is on the mac when i tried to add the number as an email address, i do not get any email for verification

  • E-Money15 Calculating status...
    Currently Being Moderated
    Dec 11, 2012 4:40 PM (in response to David Cher)

    Follow these steps (make sure to delete the email under send/receive on the iDevice so the confirmation comes through)

     

    1. Add your missing phone number as a new E-Mail on your Mac under preferences once Messages is open.

    2. Enter the phone number on Messages>Preferences as this format 1 xxx-xxx-xxxx

    3. On iPad go to Settings>Messages>Send/Receive>Delete email

    4. On iPad go to Settings>Messages>Off

    5. On iPad go to Settings>FaceTime>Off

    6. On iPad go to Settings>iCloud>Delete Account

    7. Power off iPad.

    8. Power on iPad.

    9. On iPad go to Settings>iCloud>Sign in

    10.On iPad go to Setting>Messages>On

    11.On iPad go to Settings>Messages>Send/Receive and choose the phone number that FINALLY is available and either delete or keep email address-I chose to delete the email address and use the ph # only.

    12.On iPad go to Settings>FaceTime>On

     

    I hope this saves someone the 5 hours I wasted!

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Dec 12, 2012 11:43 AM (in response to David Cher)

    Hi,

     

    Try it the other way round.

     

    Delete the Apple ID on the iPhone

    Turn Messages Off on the iPhone

    Turn It On again after a few minutes wait.

     

    Check the iPhone Number is now ticked as the only Send and Receive ID

    When it is showing as ticked then Add the Apple ID to the iPhone.

    When that has been Added restart Message on the Mac.

     

    You will get a pop up message about the iPhone using it's number and the Apple ID with the options to Accept or Deny.

    Both will list the iPhone Number and the Apple ID is different from Messages on the Mac.

    However the Accept will also tick them to make them active.

     

     

    Sigcopy2.png
    7:43 PM      Wednesday; December 12, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • David Cher Level 1 Level 1 (0 points)

    thanks it worked , as i was using another Apple id and it have been already been registered under another one ....

  • cmelich Calculating status...

    Tech Addict,

     

    What Darren worked for me. You need to do it in steps. It will take about 2-5 minute.

     

    Make sure you are on WiFi and have your mac on.

     

    1. Open iChat

    2. Go to preferences.

    3. Sign out of the imessage account.

    4. Go to your iphone, Sign Out of both iMessage and Facetime. Anything within the Message and Facetime section on the iPhone. TURN IT ALL OFF.

    5. Restart the iphone.

    6. Turn on FaceTime & then turn on iMessage in your iphone only.

    7. Once the iPhone activates FaceTime & iMessage. You should receive a popup on your Mac.

    8. The pop up will list the e-mails and not the phone number. No worries..

    9. Go into iChat preferences and log into the imessage account.

     

    Once logged into iChat, you should received 2 or 3 pop-ups that say the phone number was added to FaceTime and imessage..

     

    These are the steps i took and it worked. Good Luck...

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Dec 13, 2012 1:08 PM (in response to cmelich)

    HI,

     

    Should read:-

     

    Make sure you are on WiFi and have your mac on.

     

    1. Open iChat  Messages app

    2. Go to preferences.

    3. Sign out of the iMessage account.

    4. Go to your iPhone, Sign Out of both iMessage and Facetime. Anything within the Message and Facetime section on the iPhone. TURN IT ALL OFF.

    5. Restart the iPhone.

    6. Turn on FaceTime & then turn on iMessage in your iPhone only.

    7. Once the iPhone activates FaceTime & iMessage. You should receive a popup on your Mac.

    8. The pop up will list the e-mails and not the phone number. No worries..

    9. Go into iChat Messages preferences and log into the iMessage account.

     

    Once logged into iChat  Messages and the iMessages account, you should received 2 or 3 pop-ups that say the phone number was added to FaceTime and iMessage...

     

     

    Sigcopy2.png
    9:07 PM      Thursday; December 13, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • ItsSherlock Calculating status...

    Hi,

    I would like to know if I can add my phone number to my messages app without an iPhone. I have the 2011 21'' iMac and an iPad 4, and my phone is currently the samsung galaxy s3. Its not an iPhone but it gets the job done. I am on T-Mobile so if I were to get an iPhone it will be $700.

    If you have already answered this question, I apologies for not looking moar carfully.

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Dec 24, 2012 11:58 AM (in response to ItsSherlock)

    Hi,

     

    No.

     

    It has to be a iPhone or iPad (with Cell/mobile number) that is running iOS 6

     

    Other phones will not work as they cannot run Messages

    3Sigcopy2.png
    7:58 PM      Monday; December 24, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • BGT3 Calculating status...

    This worked for me as well. I had previously synched my MacBook Pro, iPad2 and iPhone 4s iMessages up to my phone # (so people would get the iMessages from the same "account", not 3 different accounts).  I also tried to send an email to my iPhone through the settings feature on iMessage on my MacBook, and it didn't work.  But disabling iMessage on my iPhone and re-enabling it worked.  Thanks. 

  • udance4ever Level 1 Level 1 (0 points)

    thanks Caleb!! this worked beautifully to change my # to an overseas #!  thank you!

  • suomiseth Calculating status...

    So, I tried this.....twice.  I have signed out all my iPad, iPhone 5 and the messages app on my MBP, starting from my phone, signed back in.

     

    Still nothing.  I had my messages app on my MBP and my iPhone 5 working fine, but then I bought a iPad mini and have been trying to figure out a way to get regular sms into the messaging app.... well, that is another topic, but for now.  I just want to get my messages app and my iPad using my phone number again for iMessage.

     

    When I sign into my apple ID on the phone, the number just doesn't show up on the MBP messages app.  When I try to add the cell number as an email account from the messages app.... It never sends the verification message.  Argh.

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Mar 15, 2013 3:43 PM (in response to suomiseth)

    HI,

     

    After removing the Apple ID from the iPhone (so  the number becomes the principle ID) are you disabling Messages or putting the iPhone into Airplane mode for a few minutes to break with the iMessages Server ?

     

    I used the Airplane Mode.

    On going to Settings > Messages > Send and Receive afterwards the number was then ticked (even though th option was till greyed out.

    I added back the Apple ID

     

    I then restated Messages on the Mac.

    This then showed the pop up alert type messages about the iPhone using it's number and the Apple ID

     

     

    3Sigcopy2.png
    10:43 PM      Friday; March 15, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • suomiseth Level 1 Level 1 (0 points)

    The phone is in airplane mode now.  I will give it 10 minutes and try to sign back in. 

     

    Do I need to "break" the connection with the iPad, too?  Right now the iPad and the MBP are on the same page, I just can't get the phone number back on. 

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.