11 Replies Latest reply: Sep 24, 2012 8:02 PM by Peggy
cybercrypt13 Level 1 Level 1 (25 points)

Am I missing something?  Did Apple move into another world and decide that we're all dumber than they are and that we no longer need to take an existing document and save it as something else?  I had a page I use as my company letterhead that I just open, save as another name and use for typing our letters.  However, Apple now has removed the ability to do this and now forces me to go to the OS to make a copy of the file before I come back to pages to open it.  Do they not know that ALL SOFTWARE IN THE WORLD has a save as in it for things like this?

 

I hate programmers that don't think before they write code!

 

 

Glenn


MacBook Pro with Retina display, OS X Mountain Lion, 16gb RAM 512MB HD
  • Peggy Level 8 Level 8 (38,585 points)

    Save As was removed in Lion but has made a return in Mountain Lion. You do have to hold down the Option/alt key while clicking the File menu for it to appear. There is also a keyboard shortcut.

     

    Peggy_sig.png

  • cybercrypt13 Level 1 Level 1 (25 points)

    Thanks but I still don't see it.  I'm in ML and just upgraded to latest Pages app from store.  when I press option key I only see Close change to Close All.


    no other menus show up or change.

     

    Thanks,

     

    Glenn

  • Peggy Level 8 Level 8 (38,585 points)

    It's missing on my iMac, too, but not on my other Macs in ML. I haven't had time to troubleshoot it. The keyboard shortcut ⇧ ⌘ ⌥ S does work.

     

    Peggy_sig.png

  • cybercrypt13 Level 1 Level 1 (25 points)

    I tried the shortcut too and mine just makes a thunk sound like I hit something that has no action tied to it.

  • Smartmart Level 2 Level 2 (170 points)

    The keyboard shortcut worked for me so Thanks , but it should be in the File menu all the time and not hidden.  10.8.2 update has apparently restored a save as type function but I can't find it.  Read the following article http://tidbits.com/article/13284 which shows it working in simple text.  However it doesn't seem to follow in Pages and haven't had stomach to face the dissapointment in numbers.  I'd like to know the name of the idiot who messed up the whole Save As finctionality as well.  Could it be Craig Federighi the head of software engineering at apple?  Is there anyway to un-hide Save as so we don't have to use the alt key?

     

    Second option of course is to forget iWork all together and use Microsoft Office.  I never thought I'd ever hear myself saying that but there you go.

  • Peggy Level 8 Level 8 (38,585 points)

    Take a look at this article a tuaw.com.

     

    Peggy_sig.png

  • Smartmart Level 2 Level 2 (170 points)

    Peggy,

     

    I read that article about a couple of weeks ago and tried it. Although it does perminently place Save as in the File menu, it didn't change the fact that when I used the comand, the changes were also saved to the original document.  Mountain Lion worked exactly as before.

     

    Maybe the 10.8.2 update has fixed this.

  • Smartmart Level 2 Level 2 (170 points)

    Save As now seems to work as it should and did in the good old days, as long as you know to press the option key to bring it up in the sub menu.  Out of interest, I haven't seen the “Keep changes in original document.” checkbox in any app as mentioned in the 10.8.2 update notes and the tidbits article that I posted earlier.  Was it planned originally then ditched in favour of simply restoring "Save As" as it was pre-Lion?

  • Peggy Level 8 Level 8 (38,585 points)

    Yes, it has been "fixed" in 10.8.2. But the issue was not with Save As… but that autosave automatically saves any changes & doesn't/didn't "know" to revert to the previous state when Save As… was envoked. Since Lion you have been able to revert to a previous version on files saved to Time Machine.

     

    Peggy_sig.png

  • cybercrypt13 Level 1 Level 1 (25 points)

    Sorry but I have latest update and nothing at all has changed.  When I click file and press option key I get no save as or anything like it.

     

    Where in control panel do you turn off the auto save crap? Maybe I have something disabled somewhere that is causing my problem?  Why do you have to take something so awesome as OSX and do something so stupid just in the sake of change?

  • Peggy Level 8 Level 8 (38,585 points)

    There is no way to turn autosave off as far as I know. Use versions to revert as I said before. And leave feedback for Pages & OS X.

     

    Peggy_sig.png