1 2 3 4 Previous Next 53 Replies Latest reply: Dec 26, 2013 4:23 PM by Nuvin Go to original post
  • 15. Re: wifi keeps disconnecting
    keithbro256 Level 1 Level 1 (0 points)

    Having this issue too, as is my coworker! Connects to wi-fi for a second and then disconnects!

  • 16. Re: wifi keeps disconnecting
    SAStarbucks Level 1 Level 1 (0 points)

    Only thing I can think of is that this could be related to the global http proxy in safari.  If not then it could be related to the wii handshake process with certain routers, but then this would have shown up in GM...

  • 17. Re: wifi keeps disconnecting
    dhshaw Level 1 Level 1 (0 points)

    *** apple!  Wi-Fi was working fine until i upgraded to iOS 6.  tried multiple wireless hotspots and they all disconnect after a second and redirect to that apple login page.  Need to fix this quickly!

  • 18. Re: wifi keeps disconnecting
    SAStarbucks Level 1 Level 1 (0 points)

    It is now working for me, anyone else? My guess is global HTTP proxy, has to be.

  • 19. Re: wifi keeps disconnecting
    Phil S Level 1 Level 1 (0 points)

    This worked for me....

     

    Mine is functioning properly again.

     

     

     

    Hapened to me to go to WI_FI networks and click the arrow on your wifi name then turn off the AUTO_LOGIN

    and it should work

  • 20. Re: wifi keeps disconnecting
    istacey Level 1 Level 1 (0 points)

    I had this very same problem immediately after upgrading my 3GS to iOS6. It was really annoying me and I cound't do anything with it, hence my search leading me to this post.

     

    Since then however, after about 30 minutes, its started working. I can only assume that the phone needed to "call home" to Apple, or maybe my employer who has setup various profile on my phone before allowing me to connect to WiFi.

     

    My advice is to try to give it 30 minutes of peace whilst it "calls home". If, like mine, it struggled with a 3G connection and defaults back to Edge or GPRS, I suspect hammering the phones connectivity with internet servers isn't going to help.

     

    Mine has multiple email accounts, iCloud, Facebook, Twitter plus more which will all be fighting for the Edge connection.

     

    Ian

  • 21. Re: wifi keeps disconnecting
    MyermanCMYK Level 1 Level 1 (0 points)

    Same issue for me. iPad 3 updated to iOS 6 today. Wifi @ home Belkin play n600 wireless. Worked fine until the iOS update. Kicks me to an apple.com authentication page which cannot be found. Canceling that page disconnects me from my wifi network. Thank goodness for my cellular service.

  • 22. Re: wifi keeps disconnecting
    BlakeMAC027 Level 1 Level 1 (0 points)

    I was just having the same problem.  Went through all the normal router modem trouble shooting steps.  The wifi on my iPad2 and both the 4S in my house (AirPort Extreme latest version) would connect and then try to sign in to that Apple signon page that everyone is talking about on this thread.  I then went to my MacBook Pro and everything was working perfectly.

     

    In my mind it as to be an iOS issue as the wifi was strong with my MacBook pro and I never had an issue before today.  This definately baffles me.  Another thing I noticed is that my Airport Extreme was not visible on my iOS devices through the utility but it was on my Mac.

     

    Both iPhone4S and iPad2 are up and running now with no real explination as to what changed.

  • 23. Re: wifi keeps disconnecting
    rwoodward Level 1 Level 1 (0 points)

    I solved this issue on my iPhone 4 by doing the following:

    1. Next to the Wifi network you're trying to connect to, click the blue circle arrow.
    2. Scroll to the bottom and change the HTTP Proxy to Auto.
    3. Back out to the network selection screen.
    4. Click the network you are trying to join (you should get the Apple page again, just hit Cancel at the top-right.)
    5. Click on the blue circle arrow again, and set the HTTP proxy back to Off.
    6. Return to the network selection screen one more time and select the network you're trying to connect to.  Hopefully, this will remove the proxy that the device thought you were trying to go through even though the proxy was turned off.
    7. Good luck!
  • 24. Re: wifi keeps disconnecting
    MyermanCMYK Level 1 Level 1 (0 points)

    By the way. Updated my iPhone 4S today as well and it connects just fine. S seems to be limited to my iPad.

  • 25. Re: wifi keeps disconnecting
    tarorleans Level 1 Level 1 (0 points)

    I'm having the same issue since the upgrade. I cannot now do a Restore as iTunes tells me my does not support this build but it did the upgrade a few minutes ago. I am totally screwed.

     

    TWIZTD_ If you think what you did, please share it. Will be greatly appreciated.

  • 26. Re: wifi keeps disconnecting
    Aghi Level 1 Level 1 (0 points)

    I had same problem as well ...

     

    I just removed setting gear from the recent apps, and re-launched it again.

     

    my wifi connection returned to normal operation now ... very weird.

  • 27. Re: wifi keeps disconnecting
    lechat Level 1 Level 1 (0 points)

    Don`t auto setup just add your wifi name and password manually. This will skip the PIB code

  • 28. Re: wifi keeps disconnecting
    jshorr Level 1 Level 1 (0 points)

    Same issue on my iPhone 4s and my wife's iPhone 4.

     

    Updated to iOS 6, try to connect to WiFi (Airport Extreme), it allows me to type in the password (and accepts it), but then pops up with a "log in" screen and apple's website.

     

    Same issue with both phones.  iPad 3 ("new" ipad) was updated to iOS 6 and connects to the wifi fine, as do our laptops.

     

    For kicks I reset the airport extreme's to factory defaults and re-set them up, but the problem persists.  Also tried rebooting both phones several times.

     

    Particularly frustrating because I did a full factory reset on my phone, so now I can't reinstall my apps from an iCloud backup without WiFi...

  • 29. Re: wifi keeps disconnecting
    wmeyer51 Level 1 Level 1 (0 points)

    This seems crazy, but I opened icloud in settings on the phone clicked on my username and it showed my options. I backed out and now my wifi is working