Previous 1 2 3 4 Next 53 Replies Latest reply: Dec 26, 2013 4:23 PM by Nuvin Go to original post
  • black6 Level 2 (160 points)

    Oh that worked for me, cheers pal.

  • Walman Level 1 (0 points)

    Not worked for us. We have 2 iphone4 and an ipad2 (new under warranty). And my mum has a new iPad 2. We all disconnect from wifi when idle and won't reconnect. We used to. And used to reconnect when returning he. But not anymore. We're on ios6.01

    We've tried network resets. iCloud deletes and resets. Phone resets. Nothing works.

  • ahmadjoon Level 1 (0 points)

    I have exact the same problem too . And i think we have to wait for 6.1 . If that upadate wont fix it .........


  • jpuma1616 Level 1 (5 points)

    To all having problems with their iPhone keeps disconnecting on their wifi at home, try to change your Wifi Channel Settings on your router, usually its on automatic change it to channel 9, this is what I did to fix my iPhone wifi disconnecting problem.

  • TWIZTD__ Level 1 (0 points)

    This does seem to have fixed the issue with the WiFi. It looks like it now stays with a constant WiFi signal and not a signal when you hit the home button to view your home screen it goes from 3G/4G to a WiFi signal icon with doing what jpauma1616 recommends it looks like it does work and help. Thanks so much for your reply to this issue.

  • dsmall Level 1 (0 points)

    I had the same issue on my new Ipad.


    Fixed by doing the following


    - Under Settings, Wi-Fi connect to your wifi network (enter password if applicable)

    - Under Settings, Wi-Fi select "ask to join networks" = ON

    - Under Settings, Wi-Fi select "Wi-Fi" OFF, then ON


    Check that your network now automatically connects. It'll now do the same if your device sleeps or you close the cover on the new IPAD


    Hope this helps

  • Satish101 Level 1 (0 points)


    This seems to be an endemic problem in using Macbook Pro as a hotspot to support wifi connection to other devices. In any case, if nothing works then I try the below, which I have confirmed few times that it does work.


    1. Turn off all devices that you wish to connect to Macbook pro hotspot. These will be Iphone, Ipad, and all other computers sharing the hotsopt.

    2. Turn off Macbook pro.

    3. Re-start the Macbook pro and confirm by using the browser that Internet connection is alive on Macbook.

    4. Go to System Preferences, then click on network sharing and uncheck the Internet sharing checkbox and then Internet sharing from Ethernet to WIFI will show an off status.

    5. Recheck Internet sharing checkbox. It will ask your permission to start Internet sharing. Click ok (or any affirmative button).

    6. [I have not seen much advantage of doing this: you can click on the lock on the bottom ostensibly preventing further changes. I have found that in spite of locking changes they do happen anyways. However, if locking worked for you in past then go ahead and lock the changes].

    7. After few minutes, start your first hot spot sharing device. If that successfully connects to hot spot then turn on and add all additional devices one by one.


    Hope that works for you. Good luck and best wishes.

  • Matino99 Level 1 (0 points)

    I recently updated my ipad mini to the iOS 6.1.3 this pass week. Now my wifi connection continues to flip between wifi and LTE. I reset all settings, reset my modem/router combo. I later received the update on my iPhone and neglected to install the update and my iPhone connects perfectly to my modem/router. I have reset my modem to the default factory settings and still iPad mini continues to flip back and forth between wifi and LTE. I am thinking about backing up to a previous backup... Anyone else having the same issues.

  • yrvaken Level 1 (0 points)

    Yes, I have the exakt same problem on my iPhone 4S! Dont know how to solve this.?

  • mayub Level 1 (0 points)

    i am also facing the similar issue iphone 4s disconnecting the WIFI and moviing to 3g. i tried restoring the iphone , different wifi router still no luck.

  • mitchsewbaran Level 1 (0 points)

    I have an iPod Touch 4G and I've been having this issue for the past several days. But I tried this solution and my wi-fi hasn't even disconnected when I shut off my iPod. Thanks a lot, bro!

  • Venkateshwaran Level 1 (0 points)

    I am also facing the similar issue on my iPhone 5 disconnecting the WiFi and moving to 3g for past severa days. I tried



    Restoring the iPhone

    Different WiFi Router

    Chaning the WiFi Channel to 9 but still no luck.

  • blacmount Level 1 (0 points)

    Hi, just to let you all know that the wifi connection in my IPad 2 has been bothering for some time, always having to switch off and then on wifi.


    But today the sun just shone.

    After trying lot's of configurations, I just disabled the WMM in the wireless settings of my router (TP-Link WR841ND), and no more switching wifi off and on.


    Hope it works for someone with similar annoying problems.


    All the best!

  • Nuvin Level 1 (20 points)


    It appears to work for me.

    I  disabled these features on my cable router and things appear to be stable.


    WMM support     


    Power Save Support




Previous 1 2 3 4 Next