Previous 1 4 5 6 7 8 Next 115 Replies Latest reply: Sep 21, 2012 1:07 PM by ie11 Go to original post
  • Stan52 Level 1 Level 1 (35 points)



    David from Apple Support just requested my Aperture crash log for the Facebook crash.


    My point of view is this, at least now I can getAaperture to open and work. Yes I still have Facebook issues. But at least Aperture now opens where it always crashed before. I believe Apple will work this out. Suggest others post to Aperture feedback and offer to help.


    Just my 2 cents.

  • Proggie Level 4 Level 4 (1,300 points)

    Ok this worked for me. After repairing the library it launched without crashing. I haven't tried to upas to Facebook yet because I have offline photos and can't do that until I connect my NAS at home.

  • Proggie Level 4 Level 4 (1,300 points)

    Grrr why can't I edit my post???



  • DiploStrat Level 2 Level 2 (345 points)

    I was able to get 3.4 to run by:


    -- Deleting Aperture


    -- Reloading from original 2>3 upgrade CD. (N.B. 3.1 did NOT run, but crashed.)


    -- Download and apply the 3.4 update only.


    Did one quick test with Facebook, deleting a photo. That worked without problems.

  • billfromhackettstown Level 1 Level 1 (0 points)

    awesome this worked for me thanks so much

  • cmw nj Level 1 Level 1 (0 points)

    Note my solution here:


    Re: Aperture 3.4 crashes on startup how do I downgrade?


    Much simpler

  • ie11 Level 1 Level 1 (10 points)

    Thanks, TIm.  Slightly different scenario and messages after re-start but followed the prompts as seemed appropriate and they worked.  Will wait to delete old files from desktop after a day or two of use--just in case--but it seems to have worked.  Think it's safe to go to sleep, perchance to dream...

  • sdpage Level 1 Level 1 (0 points)

    I had the same problem... I upgraded from Aperture 2.0 to the 3.0 trial version and then bought it and Apple sent me the activiation key... 


    I deleted 3.4 and reinstalled the trial version.. My key was recognized and it installed 3.0... I upgraded from 3.0 to 3.4 and bypassed all interim versions or updates. Viola !!!! It worked without issue... And like most of you I had already converted the library that active at the time of my initial update to 3.4.... After the process I just described I opened the previously converted library without problem and am back in business.... I proceeded to open and upgrade all my other libraries so I would be done with it...


    All is well that ends well... Reading what Clem said early on was what helped me... The difference being I did not have a 3.0 disk but had still had my 3.0 trial version on disk.....


    It works....

  • Clem Level 3 Level 3 (660 points)

    @sdpage Glad it worked for you.  The self-solution for the install problem sounds more confusing/laborious than it really turns out to be.

  • Trevor Harley Level 2 Level 2 (365 points)

    I submitted a bug report to Apple and amazingly David (probably the same one as above) got back to me. He confirmed that while deleting the plist file is a temporary fix the only permanent solution is to delete Aperture, redownload it (I deleted the trial version from the link above, the licence gets inherited) and immediately reapply the update. So my experience has ended happily, like sdpage's above. I bet someone in the Aperture team is getting a carpetting though.

  • ie11 Level 1 Level 1 (10 points)

    Ugh, more work, but thanks for sharing!! Cheers!

  • Trevor Harley Level 2 Level 2 (365 points)

    It honestly isn't that much work. It all downloads in the background and works just fine. You don't even have the bother of trying to find your serial number.

  • ie11 Level 1 Level 1 (10 points)

    Thanks for the encouragement.  I guess I'll run a backup, just to be safe, before I do.  And I'll wait until my electric company stabilizes my service.  Guess someone's been cutting through underground cables this afternoon....Thanks again!

Previous 1 4 5 6 7 8 Next